iOS WebLink Maestro - Device detected, but can't get past detection screen.

Find answers to common installation issues with the WebLink mobile.
Post Reply
OhNoOhJeez
New User
Posts: 2
Joined: Sun Mar 28, 2021 2:57 pm

iOS WebLink Maestro - Device detected, but can't get past detection screen.

Post by OhNoOhJeez »

Hello,

I have an iDataLink Maestro RR2 installed alongside a Pioneer AVH-4500NEX in my 2018 Subaru Forester XT with Harmon Kardon. I originally programmed the Maestro using my PC. I am trying to reprogram the device while it is installed in the vehicle using the WeblinkMaestro app in the Apple App Store installed on my iPhone 12 Pro Max.

When I perform a scan with the app, it detects my Maestro RR2. I tap on the Maestro RR2 in the list and it brings me to the following screen:

Image

I tap on the "Retry" button and it just brings me back to the list of devices where again it detects my device; tapping on my device gives me the same screen as above.

What am I doing wrong? I've tried this with the head unit on and off, WiFi on and off, the car running and not running, and toggling Bluetooth with no difference in behavior.

Thanks for your time.

Chris LaRoche
Moderator
Posts: 360
Joined: Mon Oct 07, 2019 12:49 pm

Re: iOS WebLink Maestro - Device detected, but can't get past detection screen.

Post by Chris LaRoche »

Can you try resetting the RR2 from the radio? Go in Settings, then in one of the menus you'll see "OEM Setup" or "vehicle setup". Go to Maestro Settings>Maestro Module>Module master reset.

This will not delete anything but may make the module show back up for mobile flash. Thanks!
Chris LaRoche
Automotive Data Solutions
Technical Support - Maestro
MECP Master Installer

OhNoOhJeez
New User
Posts: 2
Joined: Sun Mar 28, 2021 2:57 pm

Re: iOS WebLink Maestro - Device detected, but can't get past detection screen.

Post by OhNoOhJeez »

Chris LaRoche wrote:
Mon Mar 29, 2021 7:50 pm
Can you try resetting the RR2 from the radio? Go in Settings, then in one of the menus you'll see "OEM Setup" or "vehicle setup". Go to Maestro Settings>Maestro Module>Module master reset.

This will not delete anything but may make the module show back up for mobile flash. Thanks!
Hey Chris,

Can confirm that this did the trick; I was able to flash the module using the phone app. Thank you for your help!

Chris LaRoche
Moderator
Posts: 360
Joined: Mon Oct 07, 2019 12:49 pm

Re: iOS WebLink Maestro - Device detected, but can't get past detection screen.

Post by Chris LaRoche »

Right on! Glad it's working for you!
Chris LaRoche
Automotive Data Solutions
Technical Support - Maestro
MECP Master Installer

Post Reply

Return to “Weblink Mobile”