2016 Jeep Renegade idatalink maestro issues

Group using the CH1, CH2 and CH3 firmwares for uConnect, steering wheel controls, OEM amplifier retention. compatible with select Mitsubishi and Volkswagen vehicles * see specific firmware for full feature list.
Post Reply
SmokeGSU
New User
Posts: 3
Joined: Tue Sep 11, 2018 8:20 am

2016 Jeep Renegade idatalink maestro issues

Post by SmokeGSU » Tue Sep 11, 2018 9:29 am

Hello all. First time purchaser and installer of idatalink products.

I just installed the maestro and Ch3x harness in my Jeep last night and I've got some issues that I'd like help figuring out. I'm using a JVC KW-M730BT radio.

These are the issues I'm currently experiencing:
1. When I turn on/turn off the Renegade, the parking brake automatically engages on its own. This isn't normal.
2. The Renegade has automatic windshield wipers that activate when the vehicle detects rain. There are two settings for this, 1 and 2. When either one of those settings are now active, the wipers are constantly turned on with about a three or four second delay. This isn't normal.
3. Similar to 2, and I think I'll have to confirm this later, but the automatic headlights may also be turning on automatically when in the "auto" setting. I'll confirm later today.

Finally, very mild and not really an issue, more of a "what's this for?" I believe it was the CH3X that included an extra harness, though it may have been the maestro - neither had a parts list so with time I've forgotten what package it came in. This harness had several long (15" or so, except for one that was white and gold colored and maybe four inches long) wires and all of the wires were colored/striped non-traditionally. The install directions from idatalink didn't call out for this harness at all, so I just put it to the side. The slot where it could fit in the maestro was already taken up by one of the harnesses from the CH3X big wiring harness bundle. I'm just curious what that extra harness was for. It didn't seem to be required after hooking things up.

I'd really appreciate some help with these issues. Thanks!

SmokeGSU
New User
Posts: 3
Joined: Tue Sep 11, 2018 8:20 am

Re: 2016 Jeep Renegade idatalink maestro issues

Post by SmokeGSU » Wed Sep 12, 2018 7:33 pm

Update 9/12/18:

I reflashed the maestro last night. I had initially run the default of having every module selected under the "settings to keep" section, which included leaving some selections checked, such as factory amp and parking assist, even though my Jeep didn't have those settings. So a couple of things happened last night.... I checked the CH3X harness and found one set of wiring that I hadn't previously disconnected, which was the red and black 2-wire connectors. I disconnected those, which solved several issues, such as flashing odometer. With those wires disconnected and the maestro flashed with all "settings to keep" checked, the parking brake situation seemed to be resolved, as in it was no longer auto-engaging as soon as I'd turn on/off the Renegade. Having all selections checked seemed to fix issue number 1 I previously posted about.

The auto-sense windshield wipers (original issue 2) still weren't working and I thought it may be because of having every selection chosen for settings to keep. So I reflashed the maestro, making certain to uncheck the factory amp and the parking assist options since I didn't have them, and then reinstalled everything. The auto-sense wipers still aren't operating properly after reinstallation and now the parking brake is auto-engaging again.

At this point, I'm pretty confident if I reflash the maestro to have every option selected AGAIN, that will fix the parking brake automatically turning on as soon as I turn on/off the Jeep. But that still doesn't fix the auto-sense wipers. I saw one other topic on here from a couple of years ago where there was some back and forth between the customer and a staff member about idatalink's engineers looking into the issue but it doesn't seem that a solution was ever provided. I need help figuring out what the problem is and why the auto-sense wiper feature still isn't working.

Issue 3 was bad memory - there's nothing wrong with the auto-sensing headlights at this time.

User avatar
billr
ADS Team
Posts: 106
Joined: Mon Feb 05, 2018 9:18 am

Re: 2016 Jeep Renegade idatalink maestro issues

Post by billr » Thu Sep 13, 2018 6:11 pm

In regards to the wire harness and the 2 pin connectors in it (Black, Red, and White 2 pin connectors) the correct orientation should be that the Red 2 pin is not connected to anything, the White 2 pin connector is connected to the mating White 2 pin connector, and the Black 2 pin connector should be not connected to the wire harness however connected to the OBD2 harness that should be installed down under the dash.

If you go into the OEM Setup menu of the radio (probably in the AV menu of the JVC), go into the Vehicle Features, then Vehicle Settings, then Safety & Driving Assistance and in there there will be an Electric Parking Brake option. Click it and there should be an Auto Park Brake tab, push it and there will be an On and Off option. it is probably On, just click the Off and issue will be fixed with regards to the parking brake. I had a customer with this same issue the other day and this fixed it.
as for the Rain Sensing Wipers, in the same Safety & Driving Assistance menu there is an option for Rain Sensing Auto Wiper...it is probably turned off, just click it to turn it on.
William (Bill) Repicky
Automotive Data Solutions Technical Support
MECP Master Certified
ASE A6 Certified
866-427-2999

SmokeGSU
New User
Posts: 3
Joined: Tue Sep 11, 2018 8:20 am

Re: 2016 Jeep Renegade idatalink maestro issues

Post by SmokeGSU » Thu Sep 13, 2018 7:15 pm

Bill, you're a wizard! Ya know I kept reading people talking about menus for their uconnect controls and I went through every menu over and over again and couldn't figure out what people were talking about. I'd seen the "OEM Setup" option under AV like you mentioned, but I assumed it was to revert the radio back to default, so I never clicked on it until you mentioned it here. Oh man, so many options! I found everything and more as you mentioned. Thank you for the direction!

User avatar
billr
ADS Team
Posts: 106
Joined: Mon Feb 05, 2018 9:18 am

Re: 2016 Jeep Renegade idatalink maestro issues

Post by billr » Fri Sep 14, 2018 8:35 am

I'm glad it's all working now. you're right, there is a ton of stuff in that OEM menu for the Renegade, you could spend hours just going over all the options.
William (Bill) Repicky
Automotive Data Solutions Technical Support
MECP Master Certified
ASE A6 Certified
866-427-2999

Post Reply

Return to “Dodge, Chrysler, Jeep”