idatalink connector for Kenwood 574s

Group using the FO1 and FO2 firmware for Ford SYNC retention * see specific firmware for full feature list.
Post Reply
ifly185@gmail.com
New User
Posts: 8
Joined: Thu Aug 30, 2018 5:16 pm

idatalink connector for Kenwood 574s

Post by ifly185@gmail.com » Mon Sep 03, 2018 2:26 pm

In the Maestro RR module, connector "E", there is a blue/yellow wire called: radio control 1 output. I don't find an input on the Kenwood 574s for that. There is a iDatalink input with the 3.5 plug supplied with the FTR1, but I can't find anything about the single blue/yellow wire labeled "radio control 1 output". Where does it go?

User avatar
Dara DeGrand
ADS Team
Posts: 5135
Joined: Mon Dec 02, 2013 1:34 pm

Re: idatalink connector for Kenwood 574s

Post by Dara DeGrand » Tue Sep 04, 2018 8:37 am

You shouldn't be using the blue connector with this install type. Do not connect it.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

ifly185@gmail.com
New User
Posts: 8
Joined: Thu Aug 30, 2018 5:16 pm

Re: idatalink connector for Kenwood 574s

Post by ifly185@gmail.com » Wed Sep 05, 2018 12:53 pm

Thanks, did I miss something about this in the install and if so, is there a more specific install manual for the RR and FTR1? I'm wondering if there is something else that I'm missing.
Bob

User avatar
Dara DeGrand
ADS Team
Posts: 5135
Joined: Mon Dec 02, 2013 1:34 pm

Re: idatalink connector for Kenwood 574s

Post by Dara DeGrand » Wed Sep 05, 2018 2:34 pm

You should be following this guide:
http://images.idatalink.com/corporate/C ... 180528.pdf
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

ifly185@gmail.com
New User
Posts: 8
Joined: Thu Aug 30, 2018 5:16 pm

Re: idatalink connector for Kenwood 574s

Post by ifly185@gmail.com » Wed Sep 05, 2018 6:27 pm

Thanks, that is what I have been using, but didn't understand the specificity of the drawing on Step 4. OK, knowing that, is it the "B" connector on the RR that is not used also? For me it would be a big help to have the specific RR connectors that are used in Step 4 be marked so you don't have to guess. :D

User avatar
Dara DeGrand
ADS Team
Posts: 5135
Joined: Mon Dec 02, 2013 1:34 pm

Re: idatalink connector for Kenwood 574s

Post by Dara DeGrand » Thu Sep 06, 2018 8:38 am

They're drawn specific to their shape, size, and color on the diagram, and they're all attached to the vehicle specific wiring harness, so you shouldn't have to think about it too hard. Plug in the connector into the slot that matches its size and color. If it's not mentioned on the diagram, then it's extra, and you don't need it.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

ifly185@gmail.com
New User
Posts: 8
Joined: Thu Aug 30, 2018 5:16 pm

Re: idatalink connector for Kenwood 574s

Post by ifly185@gmail.com » Thu Sep 06, 2018 5:31 pm

I must have thought about it too hard. I get it now. Thanks

Post Reply

Return to “Ford, Lincoln, Mercury, Mazda”