2012 Golf R with Dynaudio and added subwoofer + Maestro RR + Pioneer AVH-4200NEX SCV/Speed Dependent Volume Issues

Group using the VW1 firmware for Media Device Interface (MDI), Multi-Funtion Display (MFD), bluetooth, amplifier turn on, amplifier digital fader, amplifier gain adjustment, steering wheel control, custom gauges, vehicle info, park assist, Navigation arrows on MFD, climate status screen...
Post Reply
bcunje
New User
Posts: 8
Joined: Mon Jul 23, 2018 10:08 pm

2012 Golf R with Dynaudio and added subwoofer + Maestro RR + Pioneer AVH-4200NEX SCV/Speed Dependent Volume Issues

Post by bcunje » Thu Jul 26, 2018 10:28 am

Good afternoon all!

I have the following hardware installed in my 2012 VW Golf R:
-idatalink Maestro RR + VW1 harness
-Pioneer AVH-4200NEX head unit
-Factory Dynaudio speaker amplifier (controlled over CANBUS, interfaced with the Maestro RR) with 8 speaker system
-Add on subwoofer attached directly to SW Output on the Pioneer AVH-4200NEX

As connected, everything works perfectly and sounds amazing, except one thing: Speed Dependent Volume Control is enabled and I cannot find any settings to disable it.

Prior to removing the stock VW head unit, all tone, fader, balance, and SDV/SCV was set to 0.

This is an issue since the car speakers are connected to the factory Dynaudio amplifier, which will increase volume when speed increases, however the subwoofer attached to the Pioneer head unit does not increase in volume. It clearly happens around 20, 40, 60mph speeds, causing an imbalance of speaker vs subwoofer output (very loud and no bass when at highway speeds).

Has anybody else experienced this issue? I cannot fathom a way to disable the SDV/SCV without reconnecting the old head unit, where I am sure it was disabled prior to removal.

Please let me know if you have any insight to this problem!

Thanks,
Brandon

JustinFerroni
ADS Team
Posts: 234
Joined: Mon Jan 15, 2018 2:18 pm

Re: 2012 Golf R with Dynaudio and added subwoofer + Maestro RR + Pioneer AVH-4200NEX SCV/Speed Dependent Volume Issues

Post by JustinFerroni » Thu Jul 26, 2018 3:19 pm

If you go into the OEM SETUP menu you will have a few different menus to choose from. Select Vehicle Features in this menu you have to select amp settings and speed comp is there.
Justin Ferroni
Technical Support Specialist- Maestro
T: 514.807.2888
TF: 866.427.2999

bcunje
New User
Posts: 8
Joined: Mon Jul 23, 2018 10:08 pm

Re: 2012 Golf R with Dynaudio and added subwoofer + Maestro RR + Pioneer AVH-4200NEX SCV/Speed Dependent Volume Issues

Post by bcunje » Tue Jul 31, 2018 11:17 am

Justin,

I initially was not able to access this menu, so I tried doing a "Maestro Device Reset" from my pioneer head unit, which allowed me to actually scroll down and find the Factory Amplifier settings! Looks like the Maestro unit may have been malfunctioning at the time.

I now have access to the Amplifier Gain, and also Speed Comp. After trying it out for a couple days, setting Speed Comp to OFF does fix the issue! However it only stays that way while the car is powered. Once I turn off my car ignition and turn it back on, the Speed Comp seems to reset.

When I go in the Factory Settings menu, it displays that Speed Comp is set to OFF, however if I select OFF again when the car is moving, it audibly becomes quieter, indicating that Speed Comp was in fact enabled at that time.

Resetting the Speed Comp to OFF every time I get in the car doesn't seem like a good solution. Is there any way I can script the Maestro to just do it for me automatically?

Let me know.

Thanks,
Brandon

JustinFerroni
ADS Team
Posts: 234
Joined: Mon Jan 15, 2018 2:18 pm

Re: 2012 Golf R with Dynaudio and added subwoofer + Maestro RR + Pioneer AVH-4200NEX SCV/Speed Dependent Volume Issues

Post by JustinFerroni » Tue Jul 31, 2018 3:17 pm

could you please send me the MRR's serial #? if you'd like you can attach it here or PM it to me
Justin Ferroni
Technical Support Specialist- Maestro
T: 514.807.2888
TF: 866.427.2999


bcunje
New User
Posts: 8
Joined: Mon Jul 23, 2018 10:08 pm

Re: 2012 Golf R with Dynaudio and added subwoofer + Maestro RR + Pioneer AVH-4200NEX SCV/Speed Dependent Volume Issues

Post by bcunje » Wed Aug 01, 2018 9:24 am

Hmm message seems to be stuck in my Outbox, and not Sent...

The number on the box of my Maestro RR is: 189A8557BA... Hopefully that's the SN. If not, I can take my head unit out and hopefully read it from there, or perhaps access it from the Pioneer Headunit Maestro Menu.

Let me know.

Thanks,
Brandon

User avatar
Zack Flynn
ADS Team
Posts: 334
Joined: Mon Dec 12, 2011 9:46 am

Re: 2012 Golf R with Dynaudio and added subwoofer + Maestro RR + Pioneer AVH-4200NEX SCV/Speed Dependent Volume Issues

Post by Zack Flynn » Thu Aug 02, 2018 11:47 am

Our support team has created a beta firmware for you to flash your RR with that should fix the issue. Log in to your account and reflash the module. Instead of flashing by vehicle, click on the "flash by user firmware" tab and select the 4.1 version that should be the only one there to select. After choosing that firmware, go thru the rest of the flashing process like normal
Zack Flynn
Automotive Data Solutions
Technical Support & MECP Master Installation Technician
Zachary.flynn@adsdata.ca

bcunje
New User
Posts: 8
Joined: Mon Jul 23, 2018 10:08 pm

Re: 2012 Golf R with Dynaudio and added subwoofer + Maestro RR + Pioneer AVH-4200NEX SCV/Speed Dependent Volume Issues

Post by bcunje » Fri Aug 03, 2018 10:47 am

Will give it a shot this weekend. Thanks!!!

bcunje
New User
Posts: 8
Joined: Mon Jul 23, 2018 10:08 pm

Re: 2012 Golf R with Dynaudio and added subwoofer + Maestro RR + Pioneer AVH-4200NEX SCV/Speed Dependent Volume Issues

Post by bcunje » Thu Aug 16, 2018 9:32 am

Installed the new firmware a little while ago, and tried a few things as well. Cannot get the system to cooperate. Tried resetting the module and the head unit, but the problem is persisting, same exact symptoms:

When the vehicle speed increases, the speakers get louder (but not the subwoofer on head unit preouts). Changing the Speed Comp setting to OFF while the vehicle is moving decreases the speaker volume, indicating the Speed Comp was not set to OFF upon power up. Every time the vehicle is turned on/off, this setting resets itself even though it is indicated as being OFF in the head unit menu.

What should my next steps be?

Let me know.

Thanks.

User avatar
Zack Flynn
ADS Team
Posts: 334
Joined: Mon Dec 12, 2011 9:46 am

Re: 2012 Golf R with Dynaudio and added subwoofer + Maestro RR + Pioneer AVH-4200NEX SCV/Speed Dependent Volume Issues

Post by Zack Flynn » Thu Aug 16, 2018 6:17 pm

We will have the guys in engineering take a look and see if we can figure out what is going on with it.
Zack Flynn
Automotive Data Solutions
Technical Support & MECP Master Installation Technician
Zachary.flynn@adsdata.ca

bcunje
New User
Posts: 8
Joined: Mon Jul 23, 2018 10:08 pm

Re: 2012 Golf R with Dynaudio and added subwoofer + Maestro RR + Pioneer AVH-4200NEX SCV/Speed Dependent Volume Issues

Post by bcunje » Thu Sep 06, 2018 6:14 pm

Zack Flynn wrote:
Thu Aug 16, 2018 6:17 pm
We will have the guys in engineering take a look and see if we can figure out what is going on with it.
Hey just checking in to see if you heard anything back from the engineering team. Nothing that I have tried seems to work, so I was hoping that there's a software fix I could use!

Let me know.

Thanks,
Brandon

User avatar
Dara DeGrand
ADS Team
Posts: 5135
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2012 Golf R with Dynaudio and added subwoofer + Maestro RR + Pioneer AVH-4200NEX SCV/Speed Dependent Volume Issues

Post by Dara DeGrand » Fri Sep 07, 2018 8:34 am

The engineer that codes VW has been on vacation for the last 3 weeks and just returned yesterday. We will have him look into it now that he's back.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

bcunje
New User
Posts: 8
Joined: Mon Jul 23, 2018 10:08 pm

Re: 2012 Golf R with Dynaudio and added subwoofer + Maestro RR + Pioneer AVH-4200NEX SCV/Speed Dependent Volume Issues

Post by bcunje » Tue Sep 11, 2018 6:32 pm

Thank you! I will be patiently awaiting your engineer's response :)

User avatar
Zack Flynn
ADS Team
Posts: 334
Joined: Mon Dec 12, 2011 9:46 am

Re: 2012 Golf R with Dynaudio and added subwoofer + Maestro RR + Pioneer AVH-4200NEX SCV/Speed Dependent Volume Issues

Post by Zack Flynn » Wed Sep 12, 2018 1:00 pm

After talking to the guys in engineering and them checking out the coding in the firmware, the change that they made in the firmware for the one you tried was the only thing they thought might be causing your situation. They are going to try to get a similarly equipped vehicle in and see if they can reproduce the issue, and hopefully get something figured out
Zack Flynn
Automotive Data Solutions
Technical Support & MECP Master Installation Technician
Zachary.flynn@adsdata.ca

Post Reply

Return to “Volkswagen”