Strange issue - screen switiching

Group using the FO1 and FO2 firmware for Ford SYNC retention * see specific firmware for full feature list.
Post Reply
wyzard
New User
Posts: 8
Joined: Mon Jul 09, 2018 10:13 am

Strange issue - screen switiching

Post by wyzard » Mon Jul 09, 2018 3:06 pm

Good afternoon.

I have a 2011 Mustang that had a Shaker 500 system in it with sync. I installed the following:

1. Kenwood DNX694S
2. MUS-1 Kit
3. Maestro RR Module
4. Sirius XM adapter.

I have an iPhone 8 and my contacts synced up with the radio.

There are two issues I'm having.

1. Sync functionality is not working. That doesn't concern me that much as the radio functionality, combined with the iPhone/Apple Carplay, provides more functions than sync.

2. My second issue, which is more annoying is this - Whenever I'm using the radio function, the screen switches to the phone contacts screen. Nothing is touched, no buttons are pushed, it just changes.

Could this be a possible sync issue? should I disconnect the sync connection (that is just the one wire correct)? Reset the sync module? (disconnect the battery for 30 minutes)? Reset the RR module to factory through the radio option?

Any thoughts/suggestions would be appreciated.

Also, if I reset the RR module, will it still keep the firmware flash for my vehicle that i did?

Thanks in advance for any help.

User avatar
Dara DeGrand
ADS Team
Posts: 5135
Joined: Mon Dec 02, 2013 1:34 pm

Re: Strange issue - screen switiching

Post by Dara DeGrand » Mon Jul 09, 2018 3:10 pm

When you connected the pink/red wire in the car, did you splice in, or cut the wire in two pieces?
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

wyzard
New User
Posts: 8
Joined: Mon Jul 09, 2018 10:13 am

Re: Strange issue - screen switiching

Post by wyzard » Mon Jul 09, 2018 3:48 pm

Cut it in two Connected to side that goes to steering wheel.

Post Reply

Return to “Ford, Lincoln, Mercury, Mazda”