Upgrade from Kenwood eXcelon DNX690HD to DDX9905S

Group using the FO1 and FO2 firmware for Ford SYNC retention * see specific firmware for full feature list.
Post Reply
ace72ace
New User
Posts: 3
Joined: Tue Jun 05, 2018 10:30 am

Upgrade from Kenwood eXcelon DNX690HD to DDX9905S

Post by ace72ace » Tue Jun 05, 2018 10:47 am

I've removed the RR module from my 2013 Mustang to try and register the new head unit to the module, however the USB cable I was using appears to be incompatible as Windows 10 didn't recognize the connected USB device.

I also saw browser warnings and wondered what is the best browser to use once I get the right cable, IE, Chrome or FF?

I scanned the code on my RR and my phone captured this link;

http://bit.ly/KM1MPF?r=qr

Is there anything else I need to do to get my upgraded head unit to work with my existing setup? I have the RR and the MUS-1 kit.

Thanks in advance.

User avatar
Dara DeGrand
ADS Team
Posts: 4631
Joined: Mon Dec 02, 2013 1:34 pm

Re: Upgrade from Kenwood eXcelon DNX690HD to DDX9905S

Post by Dara DeGrand » Tue Jun 05, 2018 4:46 pm

You must use Internet Explorer to re-flash. The RR has to be flashed with the new radio's information or it will not work.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

ace72ace
New User
Posts: 3
Joined: Tue Jun 05, 2018 10:30 am

Re: Upgrade from Kenwood eXcelon DNX690HD to DDX9905S

Post by ace72ace » Wed Jun 06, 2018 10:36 am

Thanks. I'm aware I need to reflash the RR to register the new unit. Will give it shot tonight. However I am concerned that even using the latest version of Internet Explorer, the web page was still spitting out the requirements list;

BROWSER ERROR
ENSURE YOUR PC MEETS THE FOLLOWING REQUIREMENTS:

1. USE WINDOWS XP OR LATER

2. USE INTERNET EXPLORER 7 OR LATER

3. MAKE SURE YOUR BROWSER IS ACTIVEX-ENABLED

4. MAKE SURE YOUR BROWSER IS JAVASCRIPT-ENABLED

I'm guessing it's the settings for #3 and 4 in IE, as 1 and 2 are OK. I will verify my settings.

Have any users had luck using Microsoft Edge browser? The only reason I ask is I've been a support engineer for way too long and am intimately aware of all the things that can go wrong when trying to use a web browser.

User avatar
Dara DeGrand
ADS Team
Posts: 4631
Joined: Mon Dec 02, 2013 1:34 pm

Re: Upgrade from Kenwood eXcelon DNX690HD to DDX9905S

Post by Dara DeGrand » Wed Jun 06, 2018 10:57 am

You can open IE through edge. In the upper right hand corner, you should see three dots. Click that and choose "open with internet explorer". It will open the website in a new window, have you log in again, and you should be good to go at that point.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

ace72ace
New User
Posts: 3
Joined: Tue Jun 05, 2018 10:30 am

Re: Upgrade from Kenwood eXcelon DNX690HD to DDX9905S

Post by ace72ace » Mon Jun 11, 2018 11:21 am

Was able to re-flash my RR with IE after making changes to the security settings and installing the latest Weblink update. Module wasn't recognized with first USB cable, so if other users don't have a known good/works with RR cable, be prepared to try more than one cable if getting the 'Cable not detected error' after installing Weblink and verifying IE settings.

This link was helpful;

http://www.amunga.com/flashing-an-idata ... indows-10/

Post Reply

Return to “Ford, Lincoln, Mercury, Mazda”