Ford F250 Gauges

Post Reply
Notrepidation44
New User
Posts: 4
Joined: Mon May 14, 2018 4:39 pm

Ford F250 Gauges

Post by Notrepidation44 » Mon May 14, 2018 5:14 pm

I have a 2016 Ford F250. Radio installed is a Kenwood DDX9904S. Idatalink Maestro RR installed with harness F01. Kenwood version 1.4.0008.1600. Maestro version 03.03.
Everything seems to be working as advertised so far. Steering wheel controls will sometimes go out, but will usually work again within 5 minutes doing nothing.
The main problem I am having with the gauges. When first installed everything seemed to work on the first day. Now I am having problems with certain gauges going out. I know the OBII is working as some gauges will continue displaying. Gauges that usually go out are Engine Oil Temp, Exhaust Gas Temperature, Torque, Fuel Level used to not go out, but now it does. Gauges that usually stay are Engine Load, Pedal, Engine Coolant Temp and some more but do not always have them displayed. This problem occurs weather I have Auto disable or always enabled in OBII settings.
I originally fixed the problem by validating PID when they stopped working. It worked the first time, but does not work every time I try. I usually have success resetting Maestro through radio settings. But of course this is annoying as you have you can not do this on the fly as you have to open door and cycle ignition and the annoying part of resetting up the gauge menu display along with min/max settings.
Do you have any suggestion how to fix this problem or what to look for?

User avatar
Zack Flynn
ADS Team
Posts: 256
Joined: Mon Dec 12, 2011 9:46 am

Re: Ford F250 Gauges

Post by Zack Flynn » Mon May 14, 2018 8:29 pm

When you lose communication, does the LED indicator on the RR do anything? Does the loss of steering wheel controls happen at the same time the loss and regaining of gauges happens?
Zack Flynn
Automotive Data Solutions
Technical Support & MECP Master Installation Technician
Zachary.flynn@adsdata.ca

Notrepidation44
New User
Posts: 4
Joined: Mon May 14, 2018 4:39 pm

Re: Ford F250 Gauges

Post by Notrepidation44 » Mon May 14, 2018 9:03 pm

The two issues are unrelated.

I do not know if the RR led does anything when the steering wheel controls go out as the RR is buried behind the dash. The steering wheel controls have never been out long enough to warrant taking the dash apart to investigate. The steering wheel issues has only happened twice so far and not a big problem as of now. I only brought up in case it had something to do with the gauges possibly.

The gauges do there own thing. They either work or they do not. The gauges never go out mid drive. They either start with the truck and work or they are off at startup and never appear again. As mentioned validating PID's worked one time to fix issue, but every other time resetting the RR has worked through radio software, except possibly once. Before researching the issues and learning about validating PID and resetting RR through radio, the gauges would work about 50% of the time. I originally thought the problem might of been RR reset button being pressed behind dash. I fixed that problem by removing tape on original bundle and re bundling so RR will sit behind AC controls where nothing can be pushed against it. I also did a quick inspection of OBII wires and do not see any damage or loose connections.

User avatar
Zack Flynn
ADS Team
Posts: 256
Joined: Mon Dec 12, 2011 9:46 am

Re: Ford F250 Gauges

Post by Zack Flynn » Tue May 15, 2018 1:34 pm

There is a newer firmware out now, or we could also send you an earlier version to flash with to your user account to see if that would help clear up the issue. Give us a call and we can get you sent up and step you thru flashing the earlier user firmware, to see if something might have changed in any of the updates. The FO1 firmware is our most used firmware, and this isn't a common issue.
Zack Flynn
Automotive Data Solutions
Technical Support & MECP Master Installation Technician
Zachary.flynn@adsdata.ca

Notrepidation44
New User
Posts: 4
Joined: Mon May 14, 2018 4:39 pm

Re: Ford F250 Gauges

Post by Notrepidation44 » Tue May 15, 2018 7:54 pm

Thank you for information.

I thought this seemed like a really odd problem. It worked all day today. I have been leaving OBII in always enabled for now. I will see how it goes for the rest of the week. I plan on taking dash apart this weekend. I will try new firmware first and if that doesn't work I will call to try an older version.

Notrepidation44
New User
Posts: 4
Joined: Mon May 14, 2018 4:39 pm

Re: Ford F250 Gauges

Post by Notrepidation44 » Sun May 20, 2018 8:51 pm

So gauges did not last. They stopped working mid drive this time. This weekend I flashed the maestro with newest firmware, even though radio shows the version as 3.3 but computer showed 3.4 when I did it. New firmware still causes gauges to go out. The gauges worked as usual in beginning then stopped. As usual certain gauges continued working. EGT and EOT stop.

On the long drive the steering wheel went out again twice. Changing volume on radio instantly fixed steering wheels both times. Still do not know if led was flashing as I can not replicate problem when dash was apart.

So we still thinking a call to try older firmware?

Post Reply

Return to “FO1 radio replacement solution”