Cannot connect via bluetooth

8-Channel Interactive Signal Processor w/ Integrated iDatalink Maestro Module
DaveST
New User
Posts: 15
Joined: Thu May 03, 2018 7:32 am

Cannot connect via bluetooth

Post by DaveST » Thu May 03, 2018 9:52 am

Hi, I have a 2016 focus st. I installed the DSR1 using the afo2 cable but I can't get any Bluetooth device to connect to the dsr1. I've tried a Google pixel 2, essential PH-1 and an iPad. All the devices see the DSR1 and briefly say connected but when it goes to "synchronize levels" I get this error: "connection failed, perfect tune was unable to connect to the selected dsr1". I also tried hooking the universal harness up to 12v on a test bench, no where near my vehicle and the results were the same. Finally I tried connecting to the dsr1 when it's being powered by USB. In this case it actually connects for a few seconds and I can hit the "details" button and see the info of the DSR1. After 5 seconds or so I get a different error: "No response from device, the dsr1 failed to respond to commands sent via Bluetooth-perfect tune has disconnected from the dsr1 as this may help fix the issue. If the dsr1 continues to not respond it may help to reset your dsr1." I used the dsr1 updater several times thinking that maybe the first time I updated the firmware something was corrupt. No changes.

User avatar
Dara DeGrand
ADS Team
Posts: 5022
Joined: Mon Dec 02, 2013 1:34 pm

Re: Cannot connect via bluetooth

Post by Dara DeGrand » Thu May 03, 2018 10:03 am

Please make sure your DSR1 is up to date on the Rockford side -

http://rftech.custhelp.com/app/answers/detail/a_id/1324

Next, update the AR through our website. When you're there, if you see a button at the bottom talking about Updating the BLE, please do that; this could be the root of your bluetooth connection issues. See the attached image.
BLE.png
You do not have the required permissions to view the files attached to this post.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

DaveST
New User
Posts: 15
Joined: Thu May 03, 2018 7:32 am

Re: Cannot connect via bluetooth

Post by DaveST » Thu May 03, 2018 10:55 am

Hi Dara, thanks for the quick response. The first time I went in to do the maestro ar configuration, there was the option to update (red circle) so I did. Just now I re-did the following: Used the dsr updater to update to 1.4.4, then went to the maestro ar site and flashed my specific vehicle. The button you circled was no longer there since I did that yesterday. The errors I'm seeing are there same. Out of curiosity is it possible to downgrade to a previous version of the BLE? Or maybe you want me to try something else?

User avatar
Dara DeGrand
ADS Team
Posts: 5022
Joined: Mon Dec 02, 2013 1:34 pm

Re: Cannot connect via bluetooth

Post by Dara DeGrand » Thu May 03, 2018 11:13 am

The BLE isn't backwards compatible with the newer firmware that's on the module, so downgrading it wouldn't work.

When you first installed the app on the android device, did you allow it to access your location? If not, that can cause the bluetooth to not connect.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

DaveST
New User
Posts: 15
Joined: Thu May 03, 2018 7:32 am

Re: Cannot connect via bluetooth

Post by DaveST » Thu May 03, 2018 11:32 am

Location permissions are definitely turned on. It shows perfect tune has access to location and storage.

DaveST
New User
Posts: 15
Joined: Thu May 03, 2018 7:32 am

Re: Cannot connect via bluetooth

Post by DaveST » Thu May 03, 2018 11:45 am

Also I'm not sure if this is relevant but when the DSR1 is powered by the car or a 12v power supply it's only visible to any of my Bluetooth devices for around 5 seconds. When it's plugged into the USB for power, it stays visible always. When powered by 12v the light cycles through a few colors, then goes solid white, then flashes green for a couple seconds, then goes back to white. Powered by USB it cycles through a few colors, then stays white.

DaveST
New User
Posts: 15
Joined: Thu May 03, 2018 7:32 am

Re: Cannot connect via bluetooth

Post by DaveST » Thu May 03, 2018 2:22 pm

Normally, can you connect to a DSR1 via Bluetooth while it's being powered by the USB instead of the 12v wires?

User avatar
Dara DeGrand
ADS Team
Posts: 5022
Joined: Mon Dec 02, 2013 1:34 pm

Re: Cannot connect via bluetooth

Post by Dara DeGrand » Thu May 03, 2018 3:21 pm

That's not the best idea- we definitely want you to be able to configure the module in the car.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

DaveST
New User
Posts: 15
Joined: Thu May 03, 2018 7:32 am

Re: Cannot connect via bluetooth

Post by DaveST » Thu May 03, 2018 9:21 pm

Dara, I spent some time in the car tonight. The very first time the dsr1 is connected to the vehicle with the af02 cable, any of my devices will see it in the perfect tune app but I get that connection error. After 5 seconds or so none of the devices will see the dsr1 anymore. I tried starting the car, just putting it in run without actually starting, leaving it off for a few minutes then back on but no matter what, no device can see the dsr1 in the app. I also tested this with an iPhone 7. I made sure the Bluetooth was turned off on all other devices except the one I was testing each time.

User avatar
Dara DeGrand
ADS Team
Posts: 5022
Joined: Mon Dec 02, 2013 1:34 pm

Re: Cannot connect via bluetooth

Post by Dara DeGrand » Fri May 04, 2018 8:29 am

After going over this with the RF staff yesterday, we suspect you might have defective hardware. Past that, we're still looking into it, but that might be the case here.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

DaveST
New User
Posts: 15
Joined: Thu May 03, 2018 7:32 am

Re: Cannot connect via bluetooth

Post by DaveST » Fri May 04, 2018 8:55 am

Dara, I will wait for your response on how to proceed. Thanks for looking into this.

z4gunn
New User
Posts: 10
Joined: Tue Oct 03, 2017 7:59 pm

Re: Cannot connect via bluetooth

Post by z4gunn » Mon May 07, 2018 6:09 pm

There is new version of iOS PerfectTune that enables logging. Can you try the following sequence:

1.) Update BLE module via Weblink (if you have not already done so)
2.) Reflash Maestro FW via Weblink (if you have not already done so)
3.) Install DSR1 back into vehicle
4.) Power cycle the vehicle one or two times
5.) Launch PerfectTune v2.2.2
6.) Press and hold the "Setup" and "Tune" buttons for 3-seconds until the "Diagnostics" button is visible under the logo
7.) Press "Diagnostic" button and enable logging/
8.) Go back to home screen and press Bluetooth button at bottom
9.) Once the device is visible, make note of the RSSI reading which indicates signal strength under the signal bars. This will help determine if there is an interference / installation orientation issue that is affecting the BLE signal.
10.) Connect to the device and go back to home screen.
11.) Test connection by moving one of the sliders. The LED on the device should blink blue in response to adjusting the home slider.
12.) Continue tuning until connection error is encountered.
13.) Press "Diagnostic" button and "Send Logs" to send logs to our tech support email


// Rockford Engineering

DaveST
New User
Posts: 15
Joined: Thu May 03, 2018 7:32 am

Re: Cannot connect via bluetooth

Post by DaveST » Tue May 08, 2018 10:24 am

I will give this a try tonight and let you know what happens and if it sends the logs successfully. Thanks!

DaveST
New User
Posts: 15
Joined: Thu May 03, 2018 7:32 am

Re: Cannot connect via bluetooth

Post by DaveST » Tue May 08, 2018 9:38 pm

1. I re- updated
2. I re-flashed
3. I installed using the af02 harness with the vehicle off
4. Started the car, let run about 15 seconds, turned off and then back on
5. Launched perfect tune (I uninstalled and then redownloaded and installed today to make sure I was on the latest)
6. Diagnostics on
7. Logging on
8. Push Bluetooth button, Dsr1 does not show up.

If I power cycle the dsr1 by unplugging the harness from the dsr1 and then plugging it back in, the light cycles through colors, then goes white, then flashes green for about 5 seconds then back to white. During the 5 seconds of flashing green the iPad will see the dsr1 and the signal strength looks like full bars. The value is about -45 but fluctuates. If I connect the dsr1 to a 12vdc power supply and use the universal harness supplied with the dsr1 the behavior is the same. I was no where near the vehicle when testing with the 12vdc power supply and universal cable. During both tests, the only Bluetooth device with Bluetooth turned on was the iPad. iOS version 11.2.2.

z4gunn
New User
Posts: 10
Joined: Tue Oct 03, 2017 7:59 pm

Re: Cannot connect via bluetooth

Post by z4gunn » Wed May 09, 2018 9:08 am

A reading of -45 indicates a strong signal, so I do not think this is a installation or BLE range issue. When the unit is flashed for Ford you can only see the device for 5-seconds after startup and then you cannot find it anymore in the device menu? Have you tried pressing the Bluetooth scan button at the bottom of the device manager screen to scan again?

// Rockford Engineering
Last edited by z4gunn on Wed May 09, 2018 2:26 pm, edited 1 time in total.

Post Reply

Return to “Maestro DSR1”