2008 Mustang RR flashing red

Post Reply
johnnyb619
New User
Posts: 5
Joined: Fri Apr 13, 2018 8:35 pm

2008 Mustang RR flashing red

Post by johnnyb619 » Fri Apr 13, 2018 8:44 pm

Hello! I installed a Kenwood DNX 893S and the RR in my car a few weeks ago and it worked great, then I decided to add new speakers a 5 channel amp and subwoofers. I ran speaker wires to all the speakers except the right front and it worked. When I decided to connect the last right front speaker, the head unit failed to power on after that. I took the unit completely out and disconnected the harness, looked for shorts and performed a bench test on the HU. The HU powered on with the bench test. I called Crutchfield and they told me that my car does not have a dedicated 12 volt supply and the RR unit makes one for the radio to power on. I reflashed my RR to remove the factory amplifiers and also did the reset by disconnecting and reconnecting with the button held down. Still not working. I bypassed all the speaker wires on the head unit and RR harness. would that cause it not to work right?

User avatar
Dara DeGrand
ADS Team
Posts: 4398
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2008 Mustang RR flashing red

Post by Dara DeGrand » Mon Apr 16, 2018 9:56 am

Speaker wire connections won't keep your radio from turning on.

If you have reset the RR and it still isn't sending accessory power out, I recommend re-flashing it, and then resetting it once more as you put it back in the vehicle.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

johnnyb619
New User
Posts: 5
Joined: Fri Apr 13, 2018 8:35 pm

Re: 2008 Mustang RR flashing red

Post by johnnyb619 » Tue Apr 17, 2018 3:30 pm

I reflashed the unit along with holding the reset button until it shows a rapid red flash then a green one. The unit will still not send accessory power to my Kenwood. Is there anything else I can do?

User avatar
Dara DeGrand
ADS Team
Posts: 4398
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2008 Mustang RR flashing red

Post by Dara DeGrand » Tue Apr 17, 2018 5:17 pm

Did you verify with a multimeter that the RR is not sending accessory power? Or are you just assuming since the radio isn't turning on? I just want to be sure.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

johnnyb619
New User
Posts: 5
Joined: Fri Apr 13, 2018 8:35 pm

Re: 2008 Mustang RR flashing red

Post by johnnyb619 » Tue Apr 17, 2018 5:31 pm

I did use a multimeter to test the ground, the yellow wire and the red accessory wire. The yellow wire works fine, the radio has a blinking triangle, but nothing going to the red wire at all. I have re-flashed about 5 times and reset and still nothing.

johnnyb619
New User
Posts: 5
Joined: Fri Apr 13, 2018 8:35 pm

Re: 2008 Mustang RR flashing red

Post by johnnyb619 » Tue Apr 17, 2018 11:52 pm

Also I paired the red and yellow wires together and started up the radio. When I did it with the data cable connected, it brought up the prompt to turn the key to the ON position and something about the VIN on the vehicle, but it never responded to that. I also was able to confirm that the serial number that I used to flash the RR was correct.

User avatar
Dara DeGrand
ADS Team
Posts: 4398
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2008 Mustang RR flashing red

Post by Dara DeGrand » Wed Apr 18, 2018 8:39 am

Check the 16 pin connector on the FO1 harness that plugs into the car. That's where the data comes in to tell us to turn the radio on. If it's not connected or you have bent pins obstructing that connection, it would cause this.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

johnnyb619
New User
Posts: 5
Joined: Fri Apr 13, 2018 8:35 pm

Re: 2008 Mustang RR flashing red

Post by johnnyb619 » Wed Apr 18, 2018 2:10 pm

The 16 pin connector was the problem, somehow i connected the wrong one. Everything works as it should now. Thanks a lot! I have one more question, how do I get the 0-60 gauge to work?

User avatar
Dara DeGrand
ADS Team
Posts: 4398
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2008 Mustang RR flashing red

Post by Dara DeGrand » Wed Apr 18, 2018 2:28 pm

When you're stopped, press the brake a few times and it should say "READY" on that gauge.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Post Reply

Return to “FO1 radio replacement solution”