Kenwood DMX7704s Stuck in Rear View

Group using the TO1 and TO2 firmware * see specific firmware for full feature list.
Post Reply
mark60
New User
Posts: 3
Joined: Sat Apr 07, 2018 7:53 pm

Kenwood DMX7704s Stuck in Rear View

Post by mark60 » Sat Apr 07, 2018 7:59 pm

Installed today in a 2015 Toyota Rav4 without factory JBL. Everything works as it should except for the factory backup cam. It comes on when shift into reverse but then stays on. I too can switch it with the headunit buttons and go to any other screen but it won't leave rear view on it's own. I have the TO2 harness and the TOY02-DS firmware. I've reflashed and the problem persists.

User avatar
Dara DeGrand
ADS Team
Posts: 4390
Joined: Mon Dec 02, 2013 1:34 pm

Re: Kenwood DMX7704s Stuck in Rear View

Post by Dara DeGrand » Mon Apr 09, 2018 9:14 am

If you have access to a meter, meter the voltage on the purple/white wire. It should only have 12 volts on it when you are in reverse. If that is how it's working and the Kenwood isn't following that, it's a Kenwood firmware bug.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

mark60
New User
Posts: 3
Joined: Sat Apr 07, 2018 7:53 pm

Re: Kenwood DMX7704s Stuck in Rear View

Post by mark60 » Tue Apr 10, 2018 5:45 pm

Thank You Dara. It actually started working on it's own but my wife just told me it's intermittent. Sometimes it stays in rear view and sometimes it doesn't. One other curious thing was that the only way I could get the voice control button on the steering wheel working was to use the harness with the blue plug. I taped the mike plug and attached the blue/yellow wire to the corresponding wire on Kenwoods harness.

User avatar
Dara DeGrand
ADS Team
Posts: 4390
Joined: Mon Dec 02, 2013 1:34 pm

Re: Kenwood DMX7704s Stuck in Rear View

Post by Dara DeGrand » Wed Apr 11, 2018 8:31 am

That connection is not required- in fact, it might cause weird operation if you leave it hooked up.

Does the light on the RR blink when you press the voice button? If you press and hold it, does the voice command activate? Does it not work under certain conditions (when using carplay, as an example) ?
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

mark60
New User
Posts: 3
Joined: Sat Apr 07, 2018 7:53 pm

Re: Kenwood DMX7704s Stuck in Rear View

Post by mark60 » Thu Apr 12, 2018 4:04 pm

I won't get to take the dash apart and check it before the weekend but I will update. I started out with the blue plug harness off the unit and only tried it when the voice control didn't react to button press. I was going back over the wiring diagrams and I had everything wired exact as per the DS diagram (no blue plug). I checked other diagrams and saw that on the AS diagram you use the blue plug but no data cable (headunit with no idatalink support) The Kenwod harness has a wire matching the Maestro's and it was labeled steering wheel control so I figured I'd try it. That gave me the voice control button and everything seemed to work correctly. The camera initially didn't shut off even before I plugged in the blue plug so I wouldn't think the extra wire would be causing the camera issue. The camera seems to go off when it feels like it. Sometimes it goes off when shifted out of reverse and randomly it stays in rear view mode.

This is in my wife's Rav4 and I'll be installing the same HU with the Maestro in my '15 Tundra in a week or two so I'm already expecting the same issue given same year Toyota, same HU, and same wiring diagram. If I can get my wife's working well them mine will be easy :)

Post Reply

Return to “Toyota”