Vehicle image on vehicle info page of head unit

Group using the CH1, CH2 and CH3 firmwares for uConnect, steering wheel controls, OEM amplifier retention. compatible with select Mitsubishi and Volkswagen vehicles * see specific firmware for full feature list.
Post Reply
dcoffin
New User
Posts: 3
Joined: Fri Feb 16, 2018 12:05 am

Vehicle image on vehicle info page of head unit

Post by dcoffin » Fri Feb 16, 2018 12:25 am

I purchased an Alpine i207-WRA with Maestro and installed the unit. All the features appear to work. However the picture of the vehicle on the 'Vehicle Info' page shows a two door coupe instead of a Jeep Wrangler. How do I change this to the correct vehicle?

The Alpine description on the product page shows a Wrangler.

User avatar
Dara DeGrand
ADS Team
Posts: 4935
Joined: Mon Dec 02, 2013 1:34 pm

Re: Vehicle image on vehicle info page of head unit

Post by Dara DeGrand » Fri Feb 16, 2018 8:43 am

The vehicle info, gauges, and climate screens are actually designed by Alpine. I have a feeling the product page on their website was just a photoshopped image. The image has always been a two-door car when it's installed in the vehicle, so there's no way to change it.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

dcoffin
New User
Posts: 3
Joined: Fri Feb 16, 2018 12:05 am

Re: Vehicle image on vehicle info page of head unit

Post by dcoffin » Fri Feb 16, 2018 8:49 pm

Thanks for the quick reply Dara. I'll admit that I'm a little annoyed that Alpine would do something like that.

tjernagel
New User
Posts: 1
Joined: Fri Jul 06, 2018 8:50 pm

Re: Vehicle image on vehicle info page of head unit

Post by tjernagel » Fri Jul 06, 2018 9:01 pm

I'd like a little more info. I installed the Alpine X209-WRA-OR in a 2018 Jeep Wrangler JK and flashed the iDatalink with the 2018 firmware. I too had the image of a sedan on a radio that could only be installed in a Wrangler.

But... At the direction of Alpine I flashed the iDatalink module to a 2017 Jeep Wrangler JK the image of a Wrangler suddenly appeared but I lost being able to select my transmission temperature as a gauge. Under the 2018 firmware it worked fine.

Seems to me iDatalink and Alpine need to be on the same page because things aren't working as advertised.

If this is an Alpine issue why did using different firmware resolve it?

User avatar
Dara DeGrand
ADS Team
Posts: 4935
Joined: Mon Dec 02, 2013 1:34 pm

Re: Vehicle image on vehicle info page of head unit

Post by Dara DeGrand » Mon Jul 09, 2018 8:41 am

The firmware for the 2007 to 2018 wrangler is exactly the same. Alpine is responsible for the aesthetic design of the vehicle info, gauges, and climate screens, so changing the year-model you flashed for shouldn't make any difference. Have you tried resetting the RR, Validating the PIDs again to see if the option comes back?
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

dcoffin
New User
Posts: 3
Joined: Fri Feb 16, 2018 12:05 am

Re: Vehicle image on vehicle info page of head unit

Post by dcoffin » Sat Sep 01, 2018 12:37 pm

It certainly did make a difference. After several months of applying updates over and over again at the recommendation of Alpine, someone on the WranglerForum.com site had success by choosing the 2017 Wrangler instead of the 2018 before reflashing.

I pulled my Maestro unit out of the dash, chose the 2017 instead of the 2018 and reflashed the unit. After reinstalling it and turning on the i207-WRA, the Wrangler appeared. :mrgreen:

Post Reply

Return to “Dodge, Chrysler, Jeep”