Maestro RR / 2008 FJ Cruiser / Alpine iLX-107 - Firmware Issue

Steering Wheel & Radio Replacement Combo
Post Reply
matt.hocker
New User
Posts: 3
Joined: Fri Oct 27, 2017 6:42 am

Maestro RR / 2008 FJ Cruiser / Alpine iLX-107 - Firmware Issue

Post by matt.hocker » Fri Oct 27, 2017 6:50 am

I have a 2008 Toyota FJ Cruiser in which I have installed the Alpine iLX-107 and Maestro RR, the latter two bought from Crutchfield. I have spent several hours with Crutchfield support and we have come to the conclusion that there is a programming error in the Maestro firmware for this configuration. Alpine concurs.

The following functions work perfectly with the firmware:
- CAN bus integration for sensors including tire pressure
- Steering wheel controls

But these do NOT work:
- The sensors page of the iLX always shows a large "0 mph" at the top even when the correct CAN bus-read sensor for speed shows the actual vehicle speed. I can neither hide nor configure this displayed value. The iLX has a vehicle speed input which is connected to the Maestro and it appears that no data is being sent to it.
- The AUX input briefly shows on bootup but then the Maestro commands the iLX to remove it. The AUX connector is not being used by the Maestro for anything.

This is obviously a very new head unit so I'm not surprised that there are a few issues. I think the firmware needs to be tweaked to fix these two issues. Is this something I can do or that someone at iDataLink can assist with?

Thanks in advance. This is a cool little product let down by a few annoying firmware issues.

User avatar
Zack Flynn
ADS Team
Posts: 332
Joined: Mon Dec 12, 2011 9:46 am

Re: Maestro RR / 2008 FJ Cruiser / Alpine iLX-107 - Firmware Issue

Post by Zack Flynn » Fri Oct 27, 2017 9:20 am

Not all vehicles have the network and wiring behind the radio where the VSS is derived from. That said, it could also have something to do with the firmware on the RR and if it flashed without errors during the flashing process. Your best bet would be to give us a call when you have access to the module in the car, and we can do some trouble shooting together.

The AUX input issue is the Alpine radio dedicating the port to the RR module anytime it sees one connected to the data port, and we have no control over that part. Alpine may change that in future revisions of their radio firmware, but that is out of our hands.
Zack Flynn
Automotive Data Solutions
Technical Support & MECP Master Installation Technician
Zachary.flynn@adsdata.ca

matt.hocker
New User
Posts: 3
Joined: Fri Oct 27, 2017 6:42 am

Re: Maestro RR / 2008 FJ Cruiser / Alpine iLX-107 - Firmware Issue

Post by matt.hocker » Fri Oct 27, 2017 9:44 am

Thanks for the prompt reply. A couple of additional points:

- For the VSS line, the wiring diagram does have it wired from Pink (RR) to Green/White (Alpine) so it is connected. As to what is passed from the RR to the Alpine or where the RR sources the data from, I can't speculate. One thought I had is that if there is another line that I can tap from another harness, I can certainly do that although I'd need to know where it would come from.
- The whole AUX thing is really weird. Why would it turn this off when there is no input coming into it from anywhere? I have an AUX connector in my car on the center console that I would like to connect to this but I have no way to do it. The other use I had for this was an additional camera. But since I can't choose it on screen except if I catch it at the moment it boots up, it's super annoying.

User avatar
Dara DeGrand
ADS Team
Posts: 5128
Joined: Mon Dec 02, 2013 1:34 pm

Re: Maestro RR / 2008 FJ Cruiser / Alpine iLX-107 - Firmware Issue

Post by Dara DeGrand » Mon Oct 30, 2017 8:59 am

VSS isn't necessary to connect on radios that aren't equipped with navigation.

The aux thing is an alpine design. Normally, their radios have two aux ports, and one of them is locked out for idatalink function, so this has never been an issue. However, now that the radio only has one aux but their design has stayed the same, the aux is disabled from regular use. We are trying to work with Alpine to figure out a solution for this, but there's no fix yet.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

matt.hocker
New User
Posts: 3
Joined: Fri Oct 27, 2017 6:42 am

Re: Maestro RR / 2008 FJ Cruiser / Alpine iLX-107 - Firmware Issue

Post by matt.hocker » Mon Oct 30, 2017 9:10 am

The iLX-107 is a strange beast. It has both VSS input and a GPS antenna, yet neither seem to serve any function except to annoy me with "0 mph" on that screen all the time.

As for the AUX thing, I'd really appreciate a long term solution on this. It's not in use by the iDataLink as far as I can tell and I need it for other purposes. I'm simply shocked that I can't use it.

Post Reply

Return to “Maestro RR”