2011 RAM 1500. Just installed the RR and the CH1 paired with a Pioneer AVH-601EX.

Post Reply
CWilliams1077
New User
Posts: 2
Joined: Fri Jun 26, 2020 9:49 pm

2011 RAM 1500. Just installed the RR and the CH1 paired with a Pioneer AVH-601EX.

Post by CWilliams1077 »

Here are the issues I am dealing with. I have no steering wheel controls whatsoever. I also have no gauges or any vehicle monitoring. I have read what you have said about Pioneer systems not supporting the monitoring features but they're product reviews along with the user manual that I printed off of your website says it is supposed to be a function. Also correct me if I'm wrong but when I used your website to research and determine what products I need to have the features I want the checklist for vehicle monitoring was marked? So I flashed and reflashed and reflashed the RR made sure the product and serial number were correct and still nothing. I do have a constant double blinking red light and when I try the steering wheel controls nothing changes. Everything else is working great except my back up camera but that is because I don't have the adapter yet for that. When I checked the firmware version in the Pioneer is 18.15 so could that need to be updated? I know I spent a lot of money speciality for certain features and I don't have them which is extremely frustrating. Any ideas are appreciated. Thank you.

User avatar
Murph
Site Admin
Posts: 6709
Joined: Sun Oct 23, 2011 8:35 pm

Re: 2011 RAM 1500. Just installed the RR and the CH1 paired with a Pioneer AVH-601EX.

Post by Murph »

Double red means there is no communication between the radio and the module. Make sure you plugged in the black 4 in to 4 pin cable. That is how the Pioneer talks to the Rr.
Brian Murphy
MECP Advanced Certified Installer
ADS Tech Support
Automotive Data Solutions inc.
8400, Bougainville, Montreal, QC.
1-866-427-2999
support@idatalink.com

User avatar
Dara DeGrand
ADS Team
Posts: 6777
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2011 RAM 1500. Just installed the RR and the CH1 paired with a Pioneer AVH-601EX.

Post by Dara DeGrand »

There is a troubleshooting section at the end of each guide.

Problem: The light on the maestro is blinking red twice.

Solution: Ensure the 4-pin data cable is connected between the radio and the RR, and that it is plugged into the black port on the Maestro RR. The red and blue ports on the RR should be empty. Make sure the correct radio model and serial number were entered during the flash. Verify the radio’s serial number entered during the fl ash matches what is listed on the radio screen. This can be found in the settings of the radio, listed as Device Id, Device Number, or Serial Number
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

CWilliams1077
New User
Posts: 2
Joined: Fri Jun 26, 2020 9:49 pm

Re: 2011 RAM 1500. Just installed the RR and the CH1 paired with a Pioneer AVH-601EX.

Post by CWilliams1077 »

Ok got the steering wheel, obdII system monitoring to work now but I still have no image on my back up camera. Do I need the avch1 for the camera to work? When I put it in reverse the screen goes black so I know it is receiving signal to activate the camera there just is no picture.

User avatar
Dara DeGrand
ADS Team
Posts: 6777
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2011 RAM 1500. Just installed the RR and the CH1 paired with a Pioneer AVH-601EX.

Post by Dara DeGrand »

If the camera showed on the radio screen, yes, you need the AV-CH1.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Post Reply

Return to “CH1 radio replacement solution”