rr2 steering

Group using the SU1 and SU2 firmware* see specific firmware for full feature list.
Post Reply
jgarcia
New User
Posts: 2
Joined: Wed May 06, 2020 9:13 pm

rr2 steering

Post by jgarcia »

Hello,
I have a 2016 Subaru STI w/o nav and I'm tying to doing a radio install. The radio is an Alpine ILX-F309 also installing maestro rr2. The steering wheel controls are not working. The rr2 blinks red twice and the green light also blinks. I already checked the serial number on the firmware and also tried downgrading from 1.8 to 1.7, then plugging the rr2 back in and still nothing. I checked idata cable connection is in correct location, still, nothing. Wiring seems to be correct. Any advice or suggestions to get the steering wheel controls working would be greatly appreciated.

User avatar
Dara DeGrand
ADS Team
Posts: 6621
Joined: Mon Dec 02, 2013 1:34 pm

Re: rr2 steering

Post by Dara DeGrand »

Are you using the SU2 harness?

When you press a button on the steering wheel, does the light on the RR blink like it sees you pressing a button?
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

User avatar
Zack Flynn
ADS Team
Posts: 928
Joined: Mon Dec 12, 2011 9:46 am

Re: rr2 steering

Post by Zack Flynn »

Version 1.9 was made live today on the site. Give that a try. In addition, you might want to check the small 10 pin connector that plugs into your F309, that has our data connection in it. Those have been known to have bad connection to the radio thru their part of the harness. If you have a multimeter with a continuity setting on it, check the data cable continuity all the way from the terminals that connect to the RR (4 pin black plug) all the way to the terminals that are in Alpine's connector where it actually plugs into the radio chassis. You might find your issue there.
Zack Flynn
Automotive Data Solutions
Technical Support & MECP Master Installation Technician
Zachary.flynn@adsdata.ca

jgarcia
New User
Posts: 2
Joined: Wed May 06, 2020 9:13 pm

Re: rr2 steering

Post by jgarcia »

Good evening,
I checked the continuity from the 10 pin connector that plugs into the F309 to the 4 pin black plug. Everything checks out, still having the same issues even with update 1.9
I have the su2 harness
the rr2 blinks twice red and it also blinks green regardless of what inputs are done to the steering wheel.

User avatar
Zack Flynn
ADS Team
Posts: 928
Joined: Mon Dec 12, 2011 9:46 am

Re: rr2 steering

Post by Zack Flynn »

It's possible you have an encryption problem with the F309, or a bad RR2 then. I spoke with you the other day on the phone both times you called in, and I had the guy s in engineering check out our firmware as far as communication back and forth with that radio and an RR2, and it all passed.
Zack Flynn
Automotive Data Solutions
Technical Support & MECP Master Installation Technician
Zachary.flynn@adsdata.ca

Post Reply

Return to “Subaru”