2015 WRX Nav&Harman Kardon no sub

Group using the SU1 and SU2 firmware* see specific firmware for full feature list.
Post Reply
Turner8889
New User
Posts: 4
Joined: Fri Apr 17, 2020 7:32 pm

2015 WRX Nav&Harman Kardon no sub

Post by Turner8889 »

I recently installed a Kenwood DDX9903s in my 2015 WRX with factory nav and Harman Kardon system. I used the iDatalink Maestro and SU2 harness. Everything with the install works perfect, except the factory sub doesn’t work. Is there anything I missed or is this a software issue? What is required to get it working again? Thanks!

User avatar
Dara DeGrand
ADS Team
Posts: 6630
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2015 WRX Nav&Harman Kardon no sub

Post by Dara DeGrand »

Ensure the crossover on the radio's front channels is set to full (all frequencies). Most radios have it set to high pass by default. If that's the case, the low frequencies will be filtered out, not make it to the amp, and the sub will not operate.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Turner8889
New User
Posts: 4
Joined: Fri Apr 17, 2020 7:32 pm

Re: 2015 WRX Nav&Harman Kardon no sub

Post by Turner8889 »

All the crossovers are set to full. For the speaker the SU2 harness has RCA’s that go into the headunit, but there wasn’t a set for the sub out of the headunit. How does the harness/interface send the subwoofer signal to the amp?

User avatar
Dara DeGrand
ADS Team
Posts: 6630
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2015 WRX Nav&Harman Kardon no sub

Post by Dara DeGrand »

The radio sends audio the same way the OEM radio did. It is a single left and right channel that go to the amp. From that point, the amp digitally controls the output and sends it to each respective speaker.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Turner8889
New User
Posts: 4
Joined: Fri Apr 17, 2020 7:32 pm

Re: 2015 WRX Nav&Harman Kardon no sub

Post by Turner8889 »

So then the harness is using the front and rear RCAS to send the sub signal and not the sub RCAS on the aftermarket headunit? If so, then I don’t understand why it isn’t working.

User avatar
Zack Flynn
ADS Team
Posts: 928
Joined: Mon Dec 12, 2011 9:46 am

Re: 2015 WRX Nav&Harman Kardon no sub

Post by Zack Flynn »

As Dara stated, there are only 2 channels of audio that go from the headunit to the factory amplifier. The front left and front right RCAs are the only connections for audio input to the factory amp, and the fading and balancing are controlled digitally. If you play with the EQ or sound settings in the new radio you might get the subwoofer to be audible, but there is no specific output from the radio to control the subwoofer or level like there would be in an aftermarket amplifier setup.
Zack Flynn
Automotive Data Solutions
Technical Support & MECP Master Installation Technician
Zachary.flynn@adsdata.ca

Turner8889
New User
Posts: 4
Joined: Fri Apr 17, 2020 7:32 pm

Re: 2015 WRX Nav&Harman Kardon no sub

Post by Turner8889 »

Ok, that makes more sense. Thanks, I’ll see if I can get a bit better output from it.

Post Reply

Return to “Subaru”