2014 Durango Auto Climate troubleshooting

Group using the CH1, CH2 and CH3 firmwares for uConnect, steering wheel controls, OEM amplifier retention. compatible with select Mitsubishi and Volkswagen vehicles * see specific firmware for full feature list.
Post Reply
bjohnson1102
New User
Posts: 2
Joined: Thu Feb 13, 2020 9:13 am

2014 Durango Auto Climate troubleshooting

Post by bjohnson1102 »

Hello,

Yesterday I installed a Pioneer avh-w4500Nex receiver, along with the maestro rr2. Everything seems to work, with the exception of my climate controls when set on auto. Previously I could set my climate at auto at 70 degrees, and it would warm the car fine. Last night, when I fired up the vehicle, set at auto, ice cold air was coming out of the dash level vents at full speed. I need to turn the temp dial all the way up as high as it will go (85 degrees) in order for the car to blow hot air. Even one degree below that (84 degrees) the air is still cold, and tends to blow out of the dash level vents when set at auto, rather than blowing out of the under dash vents as you would expect when the heat is on.

While not a total killer, since the heat still works when fully turned up and not using auto, I'd prefer to use the auto settings.

Any thoughts appreciated.

Brad

bjohnson1102
New User
Posts: 2
Joined: Thu Feb 13, 2020 9:13 am

Re: 2014 Durango Auto Climate troubleshooting

Post by bjohnson1102 »

I did get this resolved. There appeared to be a short in the wiring harness. I clipped off the harness, rewired it, and now climate controls work fine.

Brad

Post Reply

Return to “Dodge, Chrysler, Jeep”