2015 Forester "Check Audio System" suddenly

Group using the SU1 and SU2 firmware* see specific firmware for full feature list.
Post Reply
jpcaudill
New User
Posts: 7
Joined: Mon Jul 15, 2019 11:10 pm

2015 Forester "Check Audio System" suddenly

Post by jpcaudill »

Hello,

I have a Pioneer DMH-1500NEX using the RR and SU1 harness. Everything was working perfectly fine - until suddenly it wasn't. Everytime I turn the car on I get the "check audio system" warning on the factory dash screen. It seems like things like the parking brake integration, backup camera, anything that communicates with the car itself have just stopped working. It also seems like my Pioneer unit is in perpetual "night mode" as the RR doesn't seem to recognize the headlight status any longer.

Before I got taking my dash apart - I just wanted to ask if this is something known so I can do exactly what I need to do to fix it instead of going on a wild goose chase.

Thank you!

Chris LaRoche
Moderator
Posts: 56
Joined: Mon Oct 07, 2019 12:49 pm

Re: 2015 Forester "Check Audio System" suddenly

Post by Chris LaRoche »

Hi,

The "check audio system" warning is somewhat commonly seen with these. Usually it's from the battery dying in the car/jump starting, but can also come up with the radio unplugged/key turned on. Typically resetting it is as simple as removing the fuse in the engine bay labeled "Back-up". I think it's fuse 8, but check your manual to confirm. Wait a minute or two and reinstall it.

As for the night mode, if you're using the orange/white illumination wire from the RR, it behaves the same as the vehicle's illumination wire. So if your dash lights are on, the radio will be dimmed. This one you'll need to disconnect to eliminate the issue or turn the lights entirely off. I have the same setup with my 2008, just one of the quirks of how Subaru illumination is set up. If you shut the headlight switch off entirely, the radio should brighten up to daytime mode. But auto/park/headlight positions will all illuminate the dash lights, which dims the radio.
Chris LaRoche
Automotive Data Solutions
Technical Support - Maestro
MECP Master Installer

jpcaudill
New User
Posts: 7
Joined: Mon Jul 15, 2019 11:10 pm

Re: 2015 Forester "Check Audio System" suddenly

Post by jpcaudill »

Chris LaRoche wrote:
Thu Jan 16, 2020 12:03 pm
Hi,

The "check audio system" warning is somewhat commonly seen with these. Usually it's from the battery dying in the car/jump starting, but can also come up with the radio unplugged/key turned on. Typically resetting it is as simple as removing the fuse in the engine bay labeled "Back-up". I think it's fuse 8, but check your manual to confirm. Wait a minute or two and reinstall it.

As for the night mode, if you're using the orange/white illumination wire from the RR, it behaves the same as the vehicle's illumination wire. So if your dash lights are on, the radio will be dimmed. This one you'll need to disconnect to eliminate the issue or turn the lights entirely off. I have the same setup with my 2008, just one of the quirks of how Subaru illumination is set up. If you shut the headlight switch off entirely, the radio should brighten up to daytime mode. But auto/park/headlight positions will all illuminate the dash lights, which dims the radio.
Thanks Chris - I'll give the fuse a shot. I haven't had any battery issues I'm aware of (and I live in Colorado so I'd know!) nor has it been reset but I'll try it anyhow.

The illumination mode used to work exactly as you described. But when said check audio issue started, the perpertual night mode started too as well as the parking break not working and the backup camera not relaying to the screen. All of that is fine - it just suddenly stopped. It's odd stuff!

Thanks,
JP

jpcaudill
New User
Posts: 7
Joined: Mon Jul 15, 2019 11:10 pm

Re: 2015 Forester "Check Audio System" suddenly

Post by jpcaudill »

I gave the fuse a shot. It did correct the audio message - however - it did not help with the fact the parking brake no longer seems to have any effect and the rear camera no longer works. Really odd stuff. Also headlights don't affect the day/night mode of the display like they used to although it does appear at least I've got day mode back.

I wonder if this could have anything to do with my phone running Android 10? Although - when I don't connect my phone things like rear camera should work still so that would have nothing to do with it.

I'm puzzled.

User avatar
Zack Flynn
ADS Team
Posts: 831
Joined: Mon Dec 12, 2011 9:46 am

Re: 2015 Forester "Check Audio System" suddenly

Post by Zack Flynn »

Are you getting any gauges, vehicle info, or other OEM features that the radio supports? Are there any messages on those screens in the radio? Check the OBD2 connection, both under the dash and in the connector that it mates with in the harness up behind the radio in the dash and make sure it hasn't come unplugged.
Zack Flynn
Automotive Data Solutions
Technical Support & MECP Master Installation Technician
Zachary.flynn@adsdata.ca

jpcaudill
New User
Posts: 7
Joined: Mon Jul 15, 2019 11:10 pm

Re: 2015 Forester "Check Audio System" suddenly

Post by jpcaudill »

Zack Flynn wrote:
Mon Jan 20, 2020 8:08 pm
Are you getting any gauges, vehicle info, or other OEM features that the radio supports? Are there any messages on those screens in the radio? Check the OBD2 connection, both under the dash and in the connector that it mates with in the harness up behind the radio in the dash and make sure it hasn't come unplugged.
Winner winner chicken dinner! It never even crossed my mind to check that connection - must have knocked it at some point. All better now thanks!

User avatar
Zack Flynn
ADS Team
Posts: 831
Joined: Mon Dec 12, 2011 9:46 am

Re: 2015 Forester "Check Audio System" suddenly

Post by Zack Flynn »

Great. Thanks for letting us know you got it going. Enjoy
Zack Flynn
Automotive Data Solutions
Technical Support & MECP Master Installation Technician
Zachary.flynn@adsdata.ca

Post Reply

Return to “Subaru”