2012 GMC Yukon Denali Backup Camera Issue

Group using the GM3 and GM5 firmware for Onstar bluetooth, sat radio, Door chime, turn signal retention and steering wheel control, custom gauges, vehicle info, park assist... * see specific firmware for full feature list.
Post Reply
hajjinm
New User
Posts: 1
Joined: Sat Jan 04, 2020 2:20 am

2012 GMC Yukon Denali Backup Camera Issue

Post by hajjinm »

Greetings All,

I bought the following through Crutchfield.com:
1. Alpine INE-W987HD Navigation Receiver
2. iDatalink Maestro ADS-MRR Universal Radio Replacement & SWI
3. iDatalink HRN-RR-GM2 Install Harness for select GM
4. 2012 GMC Yukon Denali with Boss Amp, Factory Navigation, and Phone icon in the steering wheel.

I kept the OEM backup camera and didn't install the Alpine one. I installed them as per the guide provided by iDatalink. I checked the connection 3-4 times and it is matching iDatalink provided diagram (except for one wire which is the yellow/black which it doesn't exist in my GM2 harness). Bottom line this what I see after the installation:

1. Backup camera is immediately triggered once I turn the engine key and I cannot switch it off.
2. Once I put the gear in reverse the camera switch off and the head unit become fine.
3. Alpine setting icon faded and I cannot access it.

What do you think is going on, what I did wrong here?

Regards,
Nawaf

User avatar
billr
ADS Team
Posts: 635
Joined: Mon Feb 05, 2018 9:18 am

Re: 2012 GMC Yukon Denali Backup Camera Issue

Post by billr »

based on what you described it sounds like the reverse output of the RR is damaged. The output is just a transistorized output and and if it becomes damaged it will operate in reverse of how it's supposed to work. I would recommend contacting Crutchfield so they can swap out the RR for you.
William (Bill) Repicky
Automotive Data Solutions Technical Support
MECP Master Certified
ASE A6 Certified
866-427-2999

Post Reply

Return to “Chevrolet, GMC, Buick, Cadillac, Pontiac, Saturn, Hummer”