2017 F-550 XL, ilx-309 b/u cam not working

Post Reply
Mustang00
New User
Posts: 4
Joined: Sun Oct 13, 2019 11:27 am

2017 F-550 XL, ilx-309 b/u cam not working

Post by Mustang00 » Mon Oct 14, 2019 12:35 pm

Hello,

Just recently had a maestro rr module along with an alpine ilx-309. When putting the truck in reverse the cam screen comes up as it should however there's no feed coming in(black screen with lines). I checked the t harness going to the OEM connector and the cam feed is goes to a dead end (yel-pin 14, blk-pin 15). Does anyone have a schematic of the OEM connector?

JustinFerroni
ADS Team
Posts: 438
Joined: Mon Jan 15, 2018 2:18 pm

Re: 2017 F-550 XL, ilx-309 b/u cam not working

Post by JustinFerroni » Mon Oct 14, 2019 12:50 pm

Where did the camera original display, on the screen or in the mirror? is it a 4.3" or 8" screen from the factory?
Justin Ferroni
Technical Support Specialist- Maestro
T: 514.807.2888
TF: 866.427.2999

Mustang00
New User
Posts: 4
Joined: Sun Oct 13, 2019 11:27 am

Re: 2017 F-550 XL, ilx-309 b/u cam not working

Post by Mustang00 » Mon Oct 14, 2019 1:31 pm

The camera displayed on the 4.3" screen.

JustinFerroni
ADS Team
Posts: 438
Joined: Mon Jan 15, 2018 2:18 pm

Re: 2017 F-550 XL, ilx-309 b/u cam not working

Post by JustinFerroni » Mon Oct 14, 2019 2:16 pm

Mustang00 wrote:
Mon Oct 14, 2019 1:31 pm
The camera displayed on the 4.3" screen.
Did you use the 12pin connector that plugged into the original 4.3" screen? Also did you reinstall the camera module?
Justin Ferroni
Technical Support Specialist- Maestro
T: 514.807.2888
TF: 866.427.2999

Mustang00
New User
Posts: 4
Joined: Sun Oct 13, 2019 11:27 am

Re: 2017 F-550 XL, ilx-309 b/u cam not working

Post by Mustang00 » Mon Oct 14, 2019 4:56 pm

I'm not sure it was done through with an installer, I just traced wiring from the the install hence the request for a sche5.

User avatar
Zack Flynn
ADS Team
Posts: 741
Joined: Mon Dec 12, 2011 9:46 am

Re: 2017 F-550 XL, ilx-309 b/u cam not working

Post by Zack Flynn » Mon Oct 14, 2019 5:55 pm

Is there a 12 pin connector left over in the dash that isn't connected to anything? That is the one that Justin was asking about, and would likely be where your camera image is routed to from the factory. Connect the 12 pin connector with the RCA that we supply with the kit, and plug that Yellow RCA in to the back of the radio, rather than the one from the larger 54 pin connector that is currently connected.
Zack Flynn
Automotive Data Solutions
Technical Support & MECP Master Installation Technician
Zachary.flynn@adsdata.ca

Mustang00
New User
Posts: 4
Joined: Sun Oct 13, 2019 11:27 am

Re: 2017 F-550 XL, ilx-309 b/u cam not working

Post by Mustang00 » Mon Oct 14, 2019 9:08 pm

I didnt install the system but I'll double check but I'm pretty sure there was just the 54 pin connector.

Post Reply

Return to “FO2 radio replacement solution”