Satellite Radio retention 2010 Toyota Tacoma

Post Reply
amishhacker
New User
Posts: 5
Joined: Mon Sep 02, 2019 5:49 pm

Satellite Radio retention 2010 Toyota Tacoma

Post by amishhacker » Mon Sep 02, 2019 6:33 pm

I have a 2010 Toyota w/o JBL and factory satellite tuner that is separate from the stock radio. I am installing a Pioneer AVX-2550NEX using a Maestro RR and the TO1 wiring harness. I am not getting any satellite radio. However, when I examine the Maestro settings from the radio screen and look at the Maestro Diagnostics, Satellite Tuner, it says "system is detected", but " system is not retained". I have flashed the Maestro RR and there was no place to select satellite tuner. I did the flash 2 times with two possible steering wheel selections, just to see if there would be a way to activate the satellite tuner, however it still is not retained - (ghosted icon).

There was a post in June, 2016 with exactly the same problem in a Toyota FJ Cruiser. I see the same information on the radio screen that he did at that time. (The URL for the post is:
(viewtopic.php?f=405&t=15486&p=60989&hil ... dio#p60989).

In that thread you said that there was a problem with the website. It had been fixed. When he reflashed, the Maestro worked for satellite radio. However, I seem to be having the same issue with my Tacoma.
Is there a fix?
Thanks in advance for your help.

User avatar
billr
ADS Team
Posts: 503
Joined: Mon Feb 05, 2018 9:18 am

Re: Satellite Radio retention 2010 Toyota Tacoma

Post by billr » Tue Sep 03, 2019 10:37 am

On the TO1 harness there should be a solid White 12 way connector that is on the side with the other connectors that plug into the truck. Is that 12 way connector plugged into anything?
William (Bill) Repicky
Automotive Data Solutions Technical Support
MECP Master Certified
ASE A6 Certified
866-427-2999

amishhacker
New User
Posts: 5
Joined: Mon Sep 02, 2019 5:49 pm

Re: Satellite Radio retention 2010 Toyota Tacoma

Post by amishhacker » Tue Sep 03, 2019 1:19 pm

Yes it is. The only plugs not being used are a 2 pin white male plug and a 2 pin black female plug. Everything else that I tested seems to work except the satellite radio.

User avatar
billr
ADS Team
Posts: 503
Joined: Mon Feb 05, 2018 9:18 am

Re: Satellite Radio retention 2010 Toyota Tacoma

Post by billr » Tue Sep 03, 2019 3:31 pm

go ahead and pull the RR back out and re-flash it. when you enter the info and get down to the Vehicle Features section there should be a Sat option now. select it and continue with the flash then let me know if it's working.
William (Bill) Repicky
Automotive Data Solutions Technical Support
MECP Master Certified
ASE A6 Certified
866-427-2999

amishhacker
New User
Posts: 5
Joined: Mon Sep 02, 2019 5:49 pm

Re: Satellite Radio retention 2010 Toyota Tacoma

Post by amishhacker » Tue Sep 03, 2019 6:44 pm

Thanks for the quick response and fix.
I reflashed the Maestro RR as you instructed. The Sirius XM icon is now highlighted on the radio (car sources). When I select it, the Sirius XM screen shows up, but the screen now says "check antenna", and there is no audio, you can't see or select the channels, etc. Thinking that I might have jostled some of the wiring when I was hooking the new head unit up, I reinstalled the old factory head unit and Sirius XM came on fine. What is my next troubleshooting step?
Thanks in advance

User avatar
billr
ADS Team
Posts: 503
Joined: Mon Feb 05, 2018 9:18 am

Re: Satellite Radio retention 2010 Toyota Tacoma

Post by billr » Wed Sep 04, 2019 8:22 am

look farther in the sources of the pioneer and see if there is another Sat Radio icon. Also make sure the audio cable is installed between the radio and RR (3.5mm jack on one end that plugs into the AUX of the radio and a 3 pin black connector on the other end that plugs into the RR).
William (Bill) Repicky
Automotive Data Solutions Technical Support
MECP Master Certified
ASE A6 Certified
866-427-2999

amishhacker
New User
Posts: 5
Joined: Mon Sep 02, 2019 5:49 pm

Re: Satellite Radio retention 2010 Toyota Tacoma

Post by amishhacker » Wed Sep 04, 2019 7:36 pm

Thanks again - I am at least a step closer to getting my head unit to work.
I didn't realize that I needed to use the black 3 pin connector with the AUX plug. I plugged it in and now I get Sirius. However I still get the "check antenna" scroll. The worst part is that I do not get any information on what channel it is on, none of the normal song information, etc. I can change channels only by +/-genre selection or typing in the channel number. It seems to go to random channels however when I type in a channel number, and you can't see which one it goes to because it does not show the channel number on the screen.
Maybe I still do not have everything plugged into the RR???? There are 3 ports still open on the RR (not including the USB port): a red 4 pin port, a blue 4 pin port, and a black 2 pin port. All of the remainder are now occupied. I have a 4 pin blue connector and cable with a 3.5 mm jack that includes an additional blue/yellow wire, I do not seem to have a 4 pin red connector or a 2 pin black connector. Do I need to be using any of these RR ports to get Sirius to work?
Any other suggestions would be welcome.
Thanks for your help

User avatar
billr
ADS Team
Posts: 503
Joined: Mon Feb 05, 2018 9:18 am

Re: Satellite Radio retention 2010 Toyota Tacoma

Post by billr » Thu Sep 05, 2019 8:27 am

can you take a pic of the Sat screen where the title and artist info should be shown and post it up here? So you have audio, you can change stations on the radio, but you just can't see what station you are on, correct?

there shouldn't be anything in the red, the blue, or 2 pin port of the RR.
William (Bill) Repicky
Automotive Data Solutions Technical Support
MECP Master Certified
ASE A6 Certified
866-427-2999

amishhacker
New User
Posts: 5
Joined: Mon Sep 02, 2019 5:49 pm

Re: Satellite Radio retention 2010 Toyota Tacoma

Post by amishhacker » Thu Sep 05, 2019 1:36 pm

Thanks for hanging in there while I try to get this to work correctly.
I have attached the URL to a short video so that you can see the Sirius screen. I am not sure what Sirius channel it was on when I turned on the ignition. However, in the video, I change channels to 122 which is NPR (or at least that is what I typed in). It did change channels, however the channel it changed to was not 122. I am not sure what it was - there are no channel numbers shown on the screen.
If you have trouble with the video, let me know.
Thanks again.
https://www.dropbox.com/s/pe94yqux7ij08 ... o.MOV?dl=0

User avatar
billr
ADS Team
Posts: 503
Joined: Mon Feb 05, 2018 9:18 am

Re: Satellite Radio retention 2010 Toyota Tacoma

Post by billr » Thu Sep 05, 2019 4:23 pm

the engineers are looking into it to see if we can get rid of the Check Antenna warning
William (Bill) Repicky
Automotive Data Solutions Technical Support
MECP Master Certified
ASE A6 Certified
866-427-2999

Post Reply

Return to “TO1 radio replacement solution”