2015 F150 Sync Trouble

Group using the FO1 and FO2 firmware for Ford SYNC retention * see specific firmware for full feature list.
Post Reply
techjag
New User
Posts: 3
Joined: Thu Aug 22, 2019 11:16 pm

2015 F150 Sync Trouble

Post by techjag » Fri Aug 23, 2019 11:00 am

Hi All,

I just put a Pioneer DMH-1500NEX in my truck. I used the FTR1 kit, and the Maestro RR. Followed the instructions and I can't seem to get the Sync syste, to work.

It will act bizarre anytime I have a phone paired with Sync, for example. Randomly it will say Error on the screen, it will randomly turn on the camera view for the backup camera. (It's not coming from the reverse light trigger, it's not the same options displayed... it is specifically the same screen as if I manually enable camera view).

The sync hand free doesn't work right, people can hear me but not the other way around. The display is only a series of empty boxes when I have an active call. None of the steering wheel controls work while a call is active and that screen is up. I can confirm I am not paired to the head unit via bluetooth, only to Sync.

Any pointers on what I may have done wrong here?

Also, I had the 4.3" system but had added the factory subwoofer installed which required changing some settings in Forscan to get output. I no longer have any audio output. The trigger wire does power it up, just no signal. I assumed this might be the case, I just want to confirm before I run a new signal cable that it is indeed required. Thanks.
2015 F150 4.3 System replaced by Pioneer DMH-1500NEX
FTR1, ADS-MRR

User avatar
billr
ADS Team
Posts: 503
Joined: Mon Feb 05, 2018 9:18 am

Re: 2015 F150 Sync Trouble

Post by billr » Mon Aug 26, 2019 9:11 am

The first issue I see here is you want to use Sync :lol:
With all the oddball stuff happening I would disconnect the battery, let it sit for about 15 minutes, and reconnect it to reset Sync.
Next for the audio of Sync, you need to have the Audio Cable (black 3 pin connector on one end and a 3.5mm jack on the other) installed between the RR and the radio, making sure the 3.5mm end is plugging into the AUX of the Pioneer.
I would highly recommend, since you bought a really nice deck with CarPlay and Android Auto in it, to use that for your BT needs and not Sync. You will find it works so much better. You will have to pull the RR out, reflash it and remove the Sync components from the OEM Systems to Retain section so the RR knows to ignore Sync.

As for the audio system, did you install the OEM sub after the radio install of before?
William (Bill) Repicky
Automotive Data Solutions Technical Support
MECP Master Certified
ASE A6 Certified
866-427-2999

techjag
New User
Posts: 3
Joined: Thu Aug 22, 2019 11:16 pm

Re: 2015 F150 Sync Trouble

Post by techjag » Mon Aug 26, 2019 11:17 am

Thanks for the reply, what happens if I flash for no sync but leave the sync module in place? That is how I have it right now and it seems to be working. I really only wanted to use Sync for the mics already in the truck. I used a usb OTG adapter to run the programming port up to the right most usb port of the FTR1 so I can flash the RR without pulling the truck apart (I know that it has to have no power from the 12v to accept the flash, so I'll just pull the battery when I need to do so).

Also for the record I did try pulling the battery to reset the sync modules, and a master reset of the RR. Also tried flashing again with the Sync options just for the sake of troubleshooting.

I am using the the deck for all my BT needs now and have ran the mic from pioneer to an inconspicuous location in the upper tray (I was also installing a 5v power source and added some usb ports to the back of the tray to power my dash cam so it was convenient).

As for the sub, I installed it about a year ago... and with Forscan changed the settings in the ACM to get it to output speaker signal to the factory connector (behind the drivers side C pillar). With the new deck in place I am getting voltage and remote turn on at that connector but not audio signal. I assume that because this audio system doesn't typically have this configuration it isn't accounted for in your firmware for 4.3" screen systems. I'm not worried about it. I ran a new cable form the deck to the sub and connected it outside of the factory connector for $10... no big deal. This will also help me be better prepared for an aftermarket amp solution if I want in the future.

User avatar
billr
ADS Team
Posts: 503
Joined: Mon Feb 05, 2018 9:18 am

Re: 2015 F150 Sync Trouble

Post by billr » Mon Aug 26, 2019 11:43 am

you can leave the module connected, that's fine.
William (Bill) Repicky
Automotive Data Solutions Technical Support
MECP Master Certified
ASE A6 Certified
866-427-2999

Post Reply

Return to “Ford, Lincoln, Mercury, Mazda”