2019 Tundra OBD connector keeps HUD power on and kills battery

Group using the TO1 and TO2 firmware * see specific firmware for full feature list.
Post Reply
pisgahfan
New User
Posts: 3
Joined: Thu Aug 22, 2019 11:42 am

2019 Tundra OBD connector keeps HUD power on and kills battery

Post by pisgahfan » Thu Aug 22, 2019 11:55 am

When the Mestro OBD connector is connected to the Tundra the power to radio HUD stays on and kills battery. When OBD is disconnected the Alpine Halo9 functions as it should and I can see the tire pressure and doors, but not the gauges. Is this a known issue and is there a fix? I would like to have the gauges working and the radio power on and off with the truck. Thanks.

User avatar
Dara DeGrand
ADS Team
Posts: 6130
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2019 Tundra OBD connector keeps HUD power on and kills battery

Post by Dara DeGrand » Thu Aug 22, 2019 12:38 pm

Which harness do you have- the TO1 or TO2?

The correct harness for this truck is the TO2. I ask because the obd2 connector shouldn't affect the gauges functionality; in the TO2 harness, the information for the gauges gets pulled from behind the radio.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

pisgahfan
New User
Posts: 3
Joined: Thu Aug 22, 2019 11:42 am

Re: 2019 Tundra OBD connector keeps HUD power on and kills battery

Post by pisgahfan » Thu Aug 22, 2019 1:26 pm

iDatalink Maestro Module (ALP-MRR3)

I do get the Speed, Tire Pressure, and door info without OBD plugged in, But I don't get the other gauge info (transmission temp, etc.). The main concern is that the OBD connector causes the radio to stay on while it is plugged in, even if ignition is shut off. It seems like I found this issue on a tacoma and it maybe had something to do with the blue power wore creating a continuous loop, but I am not sure and want to verify before cutting any wires. Could the resistor be causing this issue as well?

-Jeff

User avatar
Dara DeGrand
ADS Team
Posts: 6130
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2019 Tundra OBD connector keeps HUD power on and kills battery

Post by Dara DeGrand » Thu Aug 22, 2019 2:14 pm

See the attached tech document for a fix.
Toyota resistor removal.pdf
You do not have the required permissions to view the files attached to this post.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

pisgahfan
New User
Posts: 3
Joined: Thu Aug 22, 2019 11:42 am

Re: 2019 Tundra OBD connector keeps HUD power on and kills battery

Post by pisgahfan » Thu Aug 22, 2019 2:17 pm

Thank you!

Post Reply

Return to “Toyota”