2017 Jeep Wrangler with Alpine Premium Sound System

Group using the CH1, CH2 and CH3 firmwares for uConnect, steering wheel controls, OEM amplifier retention. compatible with select Mitsubishi and Volkswagen vehicles * see specific firmware for full feature list.
Post Reply
T.J
New User
Posts: 1
Joined: Wed Aug 14, 2019 2:13 pm

2017 Jeep Wrangler with Alpine Premium Sound System

Post by T.J » Sat Aug 17, 2019 7:46 am

Hello, I have the Jeep Wrangler 2017 with Alpine Premium Sound System. After installing the Alpine Helo9 I have the following problems.

1. I can not use the fader since only rear goes to the amplifier. The fader is controlled here via "CAN IHS BUS". In addition, the CH1 does not pick up the "CAN IHS BUS" from the C2 connector (see scheme).
http://www.treuberg.ch/photo/share/24NU ... 722e706e67
How is this traded by MRR and CH1?
What do I have to do to connect this correctly?

2. The audio signal to the amplifier is way too high. It begins to distort before half the volume.
Did I load a wrong firmware on the MRR?

I would be very grateful for your competent help.

User avatar
Zack Flynn
ADS Team
Posts: 657
Joined: Mon Dec 12, 2011 9:46 am

Re: 2017 Jeep Wrangler with Alpine Premium Sound System

Post by Zack Flynn » Mon Aug 19, 2019 8:14 pm

What does the LED on the RR do when the ignition is on and the radio is booted up? We control the fader thru our digital communication with the radio, and reading its fader position. There is only two channels worth of audio going to the amplifier, even with the factory radio. As far as the audio level, you can adjust that in the Maestro settings in the vehicle/OE settings menu in the radio. Vehicle Feature Settings/Factory Amp Settings/Amplifier Gain.
Zack Flynn
Automotive Data Solutions
Technical Support & MECP Master Installation Technician
Zachary.flynn@adsdata.ca

Post Reply

Return to “Dodge, Chrysler, Jeep”