10' explorer/AVH-W4500NEX maestro led flashes twice

Post Reply
sal8888
New User
Posts: 1
Joined: Sat Aug 10, 2019 3:45 am

10' explorer/AVH-W4500NEX maestro led flashes twice

Post by sal8888 » Sat Aug 10, 2019 4:33 am

If anyone has any suggestions it would be greatly appreciated.

I just installed a Pioneer AVH-W4500 and a maestro rr in my 2010 Ford Explorer w/sync no nav. I initially had no trouble and everything worked fine. However, I noticed a scratch on my 4500 unit (open box) and returned it. After I received a new 4500 unit, I re-flashed my maestro and connected it and my new unit. I am now getting two red flashes. I have tried everything on this forum regarding the two flashes. I have made sure the s/n is correct SEVERAL times, the 4 prong wire is connected to the unit, and also re-flashed it a couple times. I also have reset the maestro unit, by reconnecting the wires while holding down the reset button. Upon the release of the button I get two green flashes. After the reset when I try to flash it I get a message saying
"it has or is already flashed". Is the reset working correctly? I noticed as soon as I connect the three prong red/black/yellow wire to the right of the green connector the unit flashes green one time the goes straight to the two red led flashes. I can connect all the others wires and not get the red flash. My unit also has no audio and does not turn off when with the ignition off and door open. Please Help!!!

MAESTRO RR - S/N 983FBE7E53
AVH-W4500 - S/N SDTM010164UC

User avatar
billr
ADS Team
Posts: 425
Joined: Mon Feb 05, 2018 9:18 am

Re: 10' explorer/AVH-W4500NEX maestro led flashes twice

Post by billr » Mon Aug 12, 2019 9:10 am

when you checked the s/n of the radio, did you go into the menu of the radio and see what the s/n is there? (usually a general setting under firmware or software, will say device number or serial number). It's possible the s/n is different than what is on the box or even on the radio chassis.

Make sure the data cable (4 pin black cable) is plugged into the black port on the RR next to the USB port. also unplug the data cable from the radio and plug it back in to make sure it was seated all the way in.

Your flash is fine so that isn't an issue.

To reset the RR you unplug everything, hold down the reset button, plug in the power plug (red, yellow, black wires in 3 pin plug) with the reset button still down, and release button when you see the led start flashing Red.
William (Bill) Repicky
Automotive Data Solutions Technical Support
MECP Master Certified
ASE A6 Certified
866-427-2999

Post Reply

Return to “FO1 radio replacement solution”