2016 Jeep Renegade

Post Reply
t1nysuitcase
New User
Posts: 3
Joined: Mon Jul 29, 2019 5:06 pm

2016 Jeep Renegade

Post by t1nysuitcase » Mon Jul 29, 2019 5:14 pm

Hello, all! I've got a 2016 Jeep Renegade Sport with the uConnect 5.0 that I'd like to replace. I have a Pioneer 2300-NEX with CarPlay that I'm interested in using. I've got it mostly installed, but I'm running into a situation with my backup camera.

The parts that I've got installed / purchased are:
Harness: Maestro HRN-RR-CH3
Module: Maestro ADS-MRR

Everything is seemingly working so far, except for a few things:
When I put it into reverse, it does kick on the backup camera screen, but the video is black. The guidelines show but the camera doesn't seem to activate.

Vehicle settings do not seem to be working. I can see where it shows the OEM settings menu, but there is nothing inside of that menu.

Lastly, my odometer is flashing, but I believe that to be because I don't have the OBD2 attachment connected, but i'm not interested in seeing my gauges via my head unit. This should be disabled while flashing, correct?

Any help would be greatly appreciated. Thanks!!

User avatar
Zack Flynn
ADS Team
Posts: 634
Joined: Mon Dec 12, 2011 9:46 am

Re: 2016 Jeep Renegade

Post by Zack Flynn » Mon Jul 29, 2019 8:30 pm

Are all the small 2 pin connectors in the CH3 harness configured like we show in the guide for you vehicle, including the one that goes to the OBD2 connector under the driver side of the dash? That is the most common cause for the issues you are describing.
Zack Flynn
Automotive Data Solutions
Technical Support & MECP Master Installation Technician
Zachary.flynn@adsdata.ca

t1nysuitcase
New User
Posts: 3
Joined: Mon Jul 29, 2019 5:06 pm

Re: 2016 Jeep Renegade

Post by t1nysuitcase » Tue Jul 30, 2019 9:43 am

I did have them plugged in the proper way, as far as I know. I'll double check the next time I try the install.

Does the OBD2 connector need to be connected in order to access backup camera and vehicle settings?

User avatar
Zack Flynn
ADS Team
Posts: 634
Joined: Mon Dec 12, 2011 9:46 am

Re: 2016 Jeep Renegade

Post by Zack Flynn » Tue Jul 30, 2019 12:50 pm

The OBD2 connector needs to be connected for us to get required information from the vehicle on the CAN network for all things to work properly in that application.
Zack Flynn
Automotive Data Solutions
Technical Support & MECP Master Installation Technician
Zachary.flynn@adsdata.ca

t1nysuitcase
New User
Posts: 3
Joined: Mon Jul 29, 2019 5:06 pm

Re: 2016 Jeep Renegade

Post by t1nysuitcase » Tue Aug 13, 2019 1:36 pm

Thanks, Zack. I was able to get all vehicle settings and everything to work properly.

The only issue i'm running into now is I am not getting and video from the backup camera onto the head unit. It seems to trigger the camera when I put it in reverse ( manual transmission ) but the image is blank. Even going into "rear view" shows the guidelines, but no video.
I've verified the yellow RCA cable is going into the correct spot on the back of the head unit ( Pioneer AVH2300-NEX ) but no dice.

User avatar
Zack Flynn
ADS Team
Posts: 634
Joined: Mon Dec 12, 2011 9:46 am

Re: 2016 Jeep Renegade

Post by Zack Flynn » Wed Aug 14, 2019 8:33 pm

Where was the image from the backup camera originally displayed? We only support the camera if it went to the original radio, not if it went to the rearview mirror. If it went to the radio, it is just a analog video signal that comes from the RCA connection we make to the factory harness. Check and make sure the RCA lines up with wires on the factory side of the plug, and that none of the pins are bent or pushed out.
Zack Flynn
Automotive Data Solutions
Technical Support & MECP Master Installation Technician
Zachary.flynn@adsdata.ca

Post Reply

Return to “CH3 radio replacement solution”