Maestro SW not working with WRX 2017 and Alpine Headunit

Analog Steering Wheel Interface
Post Reply
WakaRoman
New User
Posts: 1
Joined: Fri Jul 12, 2019 6:12 pm

Maestro SW not working with WRX 2017 and Alpine Headunit

Post by WakaRoman » Sat Jul 13, 2019 10:38 pm

Recently I purchased the Alpine ILX-W650 with the Maestro SW for my 2017 WRX. After setting up the headunit and flashing the SW on my computer to the profile of the WRX, the steering wheel controls still didn't work. I thought it could be because I had to install the micro-bypass on my Alpine head unit to access those function, but, after recently installing the bypass, the steering wheel controls still don't work. The SW even blinks green once I turn on my car, which, from what I thought, meant that the device was set up properly. The wiring with the harnesses was made by crutchfield, so I trust they were made correctly.

User avatar
Dara DeGrand
ADS Team
Posts: 6100
Joined: Mon Dec 02, 2013 1:34 pm

Re: Maestro SW not working with WRX 2017 and Alpine Headunit

Post by Dara DeGrand » Mon Jul 15, 2019 9:06 am

Did you hook the remaining wires up to the car? You should have gotten a wiring diagram at the end of the flashing process telling you what to connect to the car.

Crutchfield can only wire up the power for you when they hook it up; they cannot make the physical connections to the vehicle. If you did not do those, we're not seeing you press buttons, so we're not able to send any information to the Alpine.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

efstopper
New User
Posts: 3
Joined: Wed Jul 24, 2019 9:59 am

Re: Maestro SW not working with WRX 2017 and Alpine Headunit

Post by efstopper » Wed Jul 24, 2019 3:12 pm

Was this ever resolved? I recently purchased and installed an ilx-w650 for my wrx as well. My Maestro SW blinks and is wired up correctly but the radio does not respond any of commands. the maestro has the correct firmware and the radio has been updated to the latest firmware as well.

efstopper
New User
Posts: 3
Joined: Wed Jul 24, 2019 9:59 am

Re: Maestro SW not working with WRX 2017 and Alpine Headunit

Post by efstopper » Wed Aug 07, 2019 7:57 pm

bump

User avatar
Dara DeGrand
ADS Team
Posts: 6100
Joined: Mon Dec 02, 2013 1:34 pm

Re: Maestro SW not working with WRX 2017 and Alpine Headunit

Post by Dara DeGrand » Thu Aug 08, 2019 9:15 am

Since the OP hasn't responded, I'm not sure if he got it resolved or not.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

efstopper
New User
Posts: 3
Joined: Wed Jul 24, 2019 9:59 am

Re: Maestro SW not working with WRX 2017 and Alpine Headunit

Post by efstopper » Thu Aug 08, 2019 9:18 pm

Would you be able to troubleshoot my issue then? It's very similar. I've done a bunch of Google research and not a lot of results have come up. I have seen that one person took a voltmeter to the end of the 3.5mm jack going to the headunit and it wasn't producing enough voltage to register within the Alpine. Has your team done any testing with this HU?

User avatar
Dara DeGrand
ADS Team
Posts: 6100
Joined: Mon Dec 02, 2013 1:34 pm

Re: Maestro SW not working with WRX 2017 and Alpine Headunit

Post by Dara DeGrand » Fri Aug 09, 2019 8:11 am

Yes; we tested this radio in our office when it first came out. If the radio's firmware is up-to-date, the issue should go away.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Post Reply

Return to “Maestro SW”