2013 200S Compass/U-Connnect Doesn't Work

Group using the CH1, CH2 and CH3 firmwares for uConnect, steering wheel controls, OEM amplifier retention. compatible with select Mitsubishi and Volkswagen vehicles * see specific firmware for full feature list.
Post Reply
Jonessoda9
New User
Posts: 1
Joined: Tue Jul 09, 2019 8:54 pm

2013 200S Compass/U-Connnect Doesn't Work

Post by Jonessoda9 » Tue Jul 09, 2019 9:09 pm

I recently installed the Maestro module with the Kenwood DDX6705S and everything works save for U-Connect and the in dash compass no longer works. I just want to know if I am missing something.

The in dash compass only displays 2 dashes and no longer correctly displays direction. I have tried the "Compass Calibration" option within the EVIC but it does absolutely nothing. I've read online that the compass uses the navigation within the OEM head unit so is this something that cannot be fixed?

I'm less worried about the U-Connect feature but still curious as too why it does not work. Wheel buttons do nothing and I have updated the Kenwood head unit to the latest firmware.

Any help would be greatly appreciated.

User avatar
Dara DeGrand
ADS Team
Posts: 5936
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2013 200S Compass/U-Connnect Doesn't Work

Post by Dara DeGrand » Wed Jul 10, 2019 8:15 am

If you look on the face of the OEM radio, there should be a 3-letter code that starts with R. What is the R-code on your oem radio?

It sounds like the compass was sent by the OEM radio; when you removed the radio, this feature was lost. Because you put in a new radio that does not have navigation, it is unable to send any compass information to the cluster.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Post Reply

Return to “Dodge, Chrysler, Jeep”