2016 Wrangler steering controls

Group using the CH1, CH2 and CH3 firmwares for uConnect, steering wheel controls, OEM amplifier retention. compatible with select Mitsubishi and Volkswagen vehicles * see specific firmware for full feature list.
Post Reply
mblough83
New User
Posts: 2
Joined: Thu Jul 04, 2019 8:05 pm

2016 Wrangler steering controls

Post by mblough83 » Thu Jul 04, 2019 8:12 pm

Good Afternoon,

I installed a pioneer AVH-2550NEX using the maestro RR, idatalink RR-CH1, and the Sat 1. Been having an issue where the steering controls stop working. I called into Idatalink customer service and was told to switch the 3.5MM cable from the WR port to the AUX port on the back of the headunit. This seem to have worked for about 10 mins. Is there any other suggestions that anyone can offer?

Thank you

JustinFerroni
ADS Team
Posts: 403
Joined: Mon Jan 15, 2018 2:18 pm

Re: 2016 Wrangler steering controls

Post by JustinFerroni » Fri Jul 05, 2019 8:48 am

confirm that the 4 pin blue connector is not being used at all. then take the 3pin black to 3.5mm audio cable is plugged into the Pioneers AUX input. there shouldn't be anything plugged into the WR port at all as this is what causes the radios steering wheel controls to randomly stop working. If you'd like you can provide the maestro's serial number and we can confirm everything on the backend side of the flash is good for you.
Justin Ferroni
Technical Support Specialist- Maestro
T: 514.807.2888
TF: 866.427.2999

mblough83
New User
Posts: 2
Joined: Thu Jul 04, 2019 8:05 pm

Re: 2016 Wrangler steering controls

Post by mblough83 » Fri Jul 05, 2019 3:40 pm

Confirmed the 4 pin Blue connector is not being used. For the SWC I'm using the 3 pin black connector to 3.5MM aux and its plugged into the AUX port on the back of the radio.

SN A72D0D3A3C
SW Ver.ADS-RR(SR)-CHR01-DS (512)
v4.3

JustinFerroni
ADS Team
Posts: 403
Joined: Mon Jan 15, 2018 2:18 pm

Re: 2016 Wrangler steering controls

Post by JustinFerroni » Tue Jul 09, 2019 8:34 am

mblough83 wrote:
Fri Jul 05, 2019 3:40 pm
Confirmed the 4 pin Blue connector is not being used. For the SWC I'm using the 3 pin black connector to 3.5MM aux and its plugged into the AUX port on the back of the radio.

SN A72D0D3A3C
SW Ver.ADS-RR(SR)-CHR01-DS (512)
v4.3
That is the audio cable SWC on that platform are handled over the the 4 pin data cable that should be plugged into the radios port labled iDatalink I/F with the other end plugged into the Maestro next to the mini USB port
Justin Ferroni
Technical Support Specialist- Maestro
T: 514.807.2888
TF: 866.427.2999

Post Reply

Return to “Dodge, Chrysler, Jeep”