2006 JEEP GCherokee no sound coming from phone, rest is ok.

Post Reply
macatt
New User
Posts: 3
Joined: Tue Jul 02, 2019 5:00 pm

2006 JEEP GCherokee no sound coming from phone, rest is ok.

Post by macatt » Wed Jul 03, 2019 3:37 pm

Dears, I guess that your solution is in this forum but files after download them came with errors so I do not see any other option than ask for it again.

I installed and aftermarket Pioneer avh2550nex on my JEEP Grand Cherokee 2006 with maestro RR + Maestro CH2 harness.
Everything it seems that work great but the only situation that I have not been able to overcame is that when I pick up a call, people hear me but I can´t hear them. Also, I do not hear waze or gps instructions.
I have check online on different sides I guess that to solve this issue I have to swap some wires but I´m not sure about it.
I share a photo of the only stock plug (dark grey) that jeep has. Here is goes the link: https://drive.google.com/file/d/1-KHbof ... sp=sharing
In the photo you will see a small plug (light grey) from Maestro CH2 unplugged because I do not find any plug on Jeep side.
I keep waiting for your reply. Thank you in advance.
Rgds,
Miguel.

User avatar
Dara DeGrand
ADS Team
Posts: 6248
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2006 JEEP GCherokee no sound coming from phone, rest is ok.

Post by Dara DeGrand » Wed Jul 03, 2019 4:20 pm

That plug has nothing to do with the phone call audio. Switch the black and white plugs (front and rear speaker wires) on the t-harness and that will fix it.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

macatt
New User
Posts: 3
Joined: Tue Jul 02, 2019 5:00 pm

Re: 2006 JEEP GCherokee no sound coming from phone, rest is ok.

Post by macatt » Wed Jul 03, 2019 7:10 pm

Dear Dara, thank you for your promptly reply.
Black wire on T-harness I guess that belongs to ground, not to speakers. Am I wrong.
Please find photo at follwing link: https://drive.google.com/file/d/1-lIjLV ... sp=sharing
Do you mean this four wires (of the photo, two pairs of white and two of gray) to be switched? Please explain me how to do it. I`m affraid that it is not clear for me about how to proceed.
Thank you,
Miguel

User avatar
Zack Flynn
ADS Team
Posts: 691
Joined: Mon Dec 12, 2011 9:46 am

Re: 2006 JEEP GCherokee no sound coming from phone, rest is ok.

Post by Zack Flynn » Wed Jul 03, 2019 8:31 pm

Swap that 4 pin white connector (that has the whites and grays in it) with the 4 pin black connector (that has the greens and purples in it). So you will have the white plugged into the black, and the black plugged into the white.
Zack Flynn
Automotive Data Solutions
Technical Support & MECP Master Installation Technician
Zachary.flynn@adsdata.ca

macatt
New User
Posts: 3
Joined: Tue Jul 02, 2019 5:00 pm

Re: 2006 JEEP GCherokee no sound coming from phone, rest is ok.

Post by macatt » Thu Jul 04, 2019 2:14 pm

Dear Zack, I have checked online after sending my last post and see in a Maestro CH2 photo that I should have a black plug (similar that the white one) with green and pruple wires pair. That black plug I suppose is the one that you and Dara are talking about and I have to swap with the white plug.
I will double check the harness. I feel that I missed the black plug wihtout noticing that it is in the harness.

User avatar
Zack Flynn
ADS Team
Posts: 691
Joined: Mon Dec 12, 2011 9:46 am

Re: 2006 JEEP GCherokee no sound coming from phone, rest is ok.

Post by Zack Flynn » Mon Jul 08, 2019 12:54 pm

It is right in the same picture you posted of the white one, but to the left of your fingers and the yellow wires
Zack Flynn
Automotive Data Solutions
Technical Support & MECP Master Installation Technician
Zachary.flynn@adsdata.ca

Post Reply

Return to “CH2 radio replacement solution”