Maestro RR & Alpine ilx-207 powering on and off repeatedly

Group using the FO1 and FO2 firmware for Ford SYNC retention * see specific firmware for full feature list.
Post Reply
daleverb20
New User
Posts: 5
Joined: Fri Apr 05, 2019 11:49 pm

Maestro RR & Alpine ilx-207 powering on and off repeatedly

Post by daleverb20 » Fri Apr 05, 2019 11:55 pm

To anyone who can help. I just completed the install to the point of connecting everything and turning the key for the first time. I can hear the RR clicking every 2-3 seconds and the Alpine headunit is turning on for about 1 second and then back off. Cycle repeats until I turn the key off. Not sure if I botched the wiring with the harness for the FTR1 or something else is going on. Am going to try a re-flash before I pull the harnesses and unwrap everything to inspect my wiring.

2015 Ford F-150
"4.3" retaining sync" are the instructions I followed.
Connected to Alpine ILX-207

User avatar
Dara DeGrand
ADS Team
Posts: 5598
Joined: Mon Dec 02, 2013 1:34 pm

Re: Maestro RR & Alpine ilx-207 powering on and off repeatedly

Post by Dara DeGrand » Mon Apr 08, 2019 9:31 am

On the T harness, there is a blue 2-pin plug (it has red and black wires in it). Make sure that isn't connected to anything (especially the black 2-pin plug), or the truck and radio will act very strangely.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

daleverb20
New User
Posts: 5
Joined: Fri Apr 05, 2019 11:49 pm

Re: Maestro RR & Alpine ilx-207 powering on and off repeatedly

Post by daleverb20 » Thu Apr 11, 2019 1:05 am

Thanks. I figured it out though I'm not sure exactly which thing I did was the fix. Did a re-flash and reconnected everything this time following the instructions to a T as to the order I plugged everything in. I may have had the radio power connected prior to connected all the plugs to the RR the first go around. Either way it's working.

Only thing I have yet to sort out is the sync/voice button on the steering wheel doesn't do anything. Everything else works however.

User avatar
Dara DeGrand
ADS Team
Posts: 5598
Joined: Mon Dec 02, 2013 1:34 pm

Re: Maestro RR & Alpine ilx-207 powering on and off repeatedly

Post by Dara DeGrand » Thu Apr 11, 2019 8:38 am

When you hit the voice button on the steering wheel, does the light on the Rr blink like it sees you hitting that button? Does the radio mute or respond to the voice button press?
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

daleverb20
New User
Posts: 5
Joined: Fri Apr 05, 2019 11:49 pm

Re: Maestro RR & Alpine ilx-207 powering on and off repeatedly

Post by daleverb20 » Mon Apr 15, 2019 2:10 pm

To follow through on this post. The light on the RR did blink when I pressed the button but the radio didn't respond at all. I did notice that in the settings on the radio I could never select "sync" as the voice device. It was highlighted white like it was able to be selected but wouldn't switch from the default.

In the end I just pulled the sync module, re-flashed the RR, and added the other harness that connects to the factory sync harness with the 2 pin connector, yellow RCA plug(not used) and the black ground. That allowed the voice button on the steering to work with google assistant and I basically get the same functionality. That and having 2 different Bluetooth systems to work around and navigate through was just pointless.

Post Reply

Return to “Ford, Lincoln, Mercury, Mazda”