2008 Camry: Missing Connector = No sound or wheel controls

Group using the TO1 and TO2 firmware * see specific firmware for full feature list.
Post Reply
tcooper185
New User
Posts: 2
Joined: Sat Dec 22, 2018 12:12 pm

2008 Camry: Missing Connector = No sound or wheel controls

Post by tcooper185 » Sat Dec 22, 2018 12:34 pm

2008 Toyota Camry LE with JBL
Pioneer AVH-4200NEX head unit
ADS-RR(SR)-TOY01-DS-IG
Maestro RR

I'm replacing my OEM head unit with the above items. Wired the TOY01 up and connected everything, but I have a 20-pin connector inside my Camry that isn't attached to anything (nothing from the TOY01 has that size connector).
Flashed the Maestro RR, plugged everything in, seated the Pioneer head unit, powered on the car. Pioneer fires up properly, but no sound plays from speakers. No controls on the steering wheel do anything on the head unit.
Unplugged everything, reflashed the Maestro RR, again connected everything up, and same results.

Below are pics of the 3 connectors inside my Camry dash, followed by a pic of the 2 that get connected to something and the 1 that is left open.

Where do I get the correct sized connector for that last remaining plug? I even bought a second TOY01 to see if I was missing a connector, and it has all of the same parts.

Thanks in advance for your help!

https://photos.app.goo.gl/h4L9GcngxZZqbCEu9

User avatar
Dara DeGrand
ADS Team
Posts: 5347
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2008 Camry: Missing Connector = No sound or wheel controls

Post by Dara DeGrand » Wed Dec 26, 2018 12:34 pm

There is a 20 pin connector that comes in the box with the TO1 harness. That is the plug where your steering wheel controls are. See the photo I attached. The 20 pin is circled.
TO1 20 pin.png

EDIT: It looks like you have the plug connected to the car in your 3rd picture; you just need to plug the other end into the TO1 harness. There will be a white/cream colored 10 pin plug that the other end connects to; it's sort of in the middle of the TO1 t-harness.
You do not have the required permissions to view the files attached to this post.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

tcooper185
New User
Posts: 2
Joined: Sat Dec 22, 2018 12:12 pm

Re: 2008 Camry: Missing Connector = No sound or wheel controls

Post by tcooper185 » Mon Dec 31, 2018 12:54 pm

So, to be clear, I should be plugging in two harnesses into my car, leaving this third one vacant? See 4th picture in original link, also pasted below:
https://photos.app.goo.gl/h4L9GcngxZZqbCEu9

Tim

JustinFerroni
ADS Team
Posts: 295
Joined: Mon Jan 15, 2018 2:18 pm

Re: 2008 Camry: Missing Connector = No sound or wheel controls

Post by JustinFerroni » Wed Jan 02, 2019 8:52 am

In the 4th picture you sent you have aconnector with 2 RCA plugs and a little 2pin connector with 2 green wires. the RCA's need to be plugged into the radios Front RCA inputs and the 2 pin coonector has a matching 2pin connector coming off the the TO1 harness that has the amplifiers data lines, this also needs to be connected.
Justin Ferroni
Technical Support Specialist- Maestro
T: 514.807.2888
TF: 866.427.2999

Post Reply

Return to “Toyota”