Rear Speakers not working

Group using the CH1, CH2 and CH3 firmwares for uConnect, steering wheel controls, OEM amplifier retention. compatible with select Mitsubishi and Volkswagen vehicles * see specific firmware for full feature list.
Post Reply
jeep_owner_31
New User
Posts: 13
Joined: Mon May 15, 2017 2:42 pm

Rear Speakers not working

Post by jeep_owner_31 » Thu Dec 06, 2018 6:05 pm

I have a 2012 Jeep Wrangler. I have installed a Kenwood ddx374bt using the Maestro RR module and the CH1 module. My rear speakers recently stopped working, I also noticed that the fade or balance is not working. Can you help?

User avatar
Zack Flynn
ADS Team
Posts: 344
Joined: Mon Dec 12, 2011 9:46 am

Re: Rear Speakers not working

Post by Zack Flynn » Thu Dec 06, 2018 6:48 pm

What is the LED on the RR module doing? Do you get any other features still like gauges or vehicle information showing on your radio screen?
Zack Flynn
Automotive Data Solutions
Technical Support & MECP Master Installation Technician
Zachary.flynn@adsdata.ca

jeep_owner_31
New User
Posts: 13
Joined: Mon May 15, 2017 2:42 pm

Re: Rear Speakers not working

Post by jeep_owner_31 » Fri Dec 07, 2018 7:59 am

I think my issue was the amp. I removed the fuse(it was not blown), and put it back in. This reset the settings on the radio and everything is now fine.

User avatar
Zack Flynn
ADS Team
Posts: 344
Joined: Mon Dec 12, 2011 9:46 am

Re: Rear Speakers not working

Post by Zack Flynn » Fri Dec 07, 2018 8:16 pm

Great to hear
Zack Flynn
Automotive Data Solutions
Technical Support & MECP Master Installation Technician
Zachary.flynn@adsdata.ca

Post Reply

Return to “Dodge, Chrysler, Jeep”