2007 Tahoe had the Battery Replaced... now system issues

Group using the GM3 and GM5 firmware for Onstar bluetooth, sat radio, Door chime, turn signal retention and steering wheel control, custom gauges, vehicle info, park assist... * see specific firmware for full feature list.
Post Reply
dculton
New User
Posts: 1
Joined: Wed Nov 28, 2018 9:56 pm

2007 Tahoe had the Battery Replaced... now system issues

Post by dculton » Wed Nov 28, 2018 10:07 pm

I installed a Pioneer AVIC 5200 NEX receiver in my 2007 Tahoe that had a factory Nav/Bose system. It's probably been in the vehicle working fine for nearly 2 years. I just took the vehicle in for a wheel hub replacement and the shop (for whatever reason) somehow killed the battery.

They used a portable handheld jumper unit to get the car to start again, and the receiver turned on and went through the language selection screen again, and so on... like it was a new install I suppose.

But now I'm having issues - before, I had set up the iData components to work with the OEM steering wheel buttons, rear seat stuff, etc. Seemed to work fine. But now I can't get them to work. Also, when I go into the vehicle info screen where the gauges display, it shows "ignition off" at the top and none of the gauges operate.

I put the vehicle into reverse and the rear camera isn't popping up on my receiver, either.

I'm also not getting the door tones or turn signal clicks out of the mini speaker that came with the iData parts.

What could have happened that would cause all of these things to stop working? Taking the dash apart isn't the funnest thing to do in the world... well, pulling the receiver isn't too much fun, especially with all of these extra pieces of hardware behind the deck. Very tight fit, so I was hoping I didn't need to pull out the Maestro or any of the other pieces to flash them, etc.

Oh, and the last thing I noticed was when I picked my Tahoe up from the service center, the battery was dead again so they had to jump it. Again - I noticed after I got the car to run and I turned it off, my receiver didn't turn off, even with the key out of the ignition. WTF? This was never an issue before, either.

I could somewhat understand if I need to reprogram something, but why would my new radio not turn off when the key isn't in it? Changing a wheel hub shouldn't affect the computer or OBD at all - they claim they never connected a scanner to the car and the OBD plug from the Pioneer unit was still snapped into the dash OBD port.

I'm at a loss and extremely frustrated, especially after dropping over $500 at the shop on the wheel hub and CV replacement, only to come out with a radio not working properly. And, it's almost Christmas so definitely not the best time of year to drop that kind of cash on an unexpected vehicle repair.

HELP, please?

dculton@cox.net

User avatar
billr
ADS Team
Posts: 139
Joined: Mon Feb 05, 2018 9:18 am

Re: 2007 Tahoe had the Battery Replaced... now system issues

Post by billr » Thu Nov 29, 2018 9:31 am

i've seen it where when the vehicle battery voltage gets too low or even when the battery goes dead the Maestro doesn't like it and will get locked up and not communicate with the radio, just doesn't do much. Unfortunately the way to fix this is to get to the Maestro unit itself behind the radio and reset the unit. I understand you're not a fan of taking it all apart and I can totally understand but in this case it will need to be done.
With the ignition off:
get to the Maestro unit and you will need to unplug all the connectors (make a mental note of where they all plugged into, most only fit in one location anyway).
Once unplugged you will need to hold down the reset button on the side of the Maestro unit. While you are holding that down plug in just the 3 pin Black power connector (it has a Black, Yellow, and Red wire on it). Keep the reset button down till you see the led start flashing really fast red, then you can let go of the reset button. at this point the led should turn green for a second then go out. at this point you can reconnect the rest of the connectors and turn the truck on and see if the radio now comes and and features start working again.
William (Bill) Repicky
Automotive Data Solutions Technical Support
MECP Master Certified
ASE A6 Certified
866-427-2999

Post Reply

Return to “Chevrolet, GMC, Buick, Cadillac, Pontiac, Saturn, Hummer”