2013 RAV4 XLE w/o JBL Rear Camera 16 pin Connector

Post Reply
ptho2
New User
Posts: 4
Joined: Sun Nov 04, 2018 2:56 am

2013 RAV4 XLE w/o JBL Rear Camera 16 pin Connector

Post by ptho2 » Sun Nov 04, 2018 10:10 am

I have a 2013 RAV4 XLE w/o JBL OEM stereo. I'm changing out the HU with a Kenwood DMX 7704S. I purchased the Maestro RR and T02 harness. All the connectors matched except for the rear backup camera connector. The one off of the OEM stereo is 16 pin but the one from T02 is a 24 pin connector. Where can I find a 16 pin connector?

User avatar
Dara DeGrand
ADS Team
Posts: 5346
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2013 RAV4 XLE w/o JBL Rear Camera 16 pin Connector

Post by Dara DeGrand » Mon Nov 05, 2018 3:06 pm

We do not make a 16 pin connector. In this application, the camera must be hardwired. See attached.
TO2 backup cam.jpg
You do not have the required permissions to view the files attached to this post.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

ptho2
New User
Posts: 4
Joined: Sun Nov 04, 2018 2:56 am

Re: 2013 RAV4 XLE w/o JBL Rear Camera 16 pin Connector

Post by ptho2 » Sat Nov 10, 2018 12:59 am

Thank you for the quick reply. However, I am disappointed. The main reason for getting the harness is to retain all the factory connectors. At least provide splice connectors so the factory connector doesn't have to be cut off. Plus, the instruction was not in the Rav4 manual so now I have to go back to pull the HU out to do this fix.

ptho2
New User
Posts: 4
Joined: Sun Nov 04, 2018 2:56 am

Re: 2013 RAV4 XLE w/o JBL Rear Camera 16 pin Connector

Post by ptho2 » Mon Nov 12, 2018 2:13 am

Hardwired the rear camera and video was showing up initially. Flashed the RR to change some steering wheel controls but now the camera is no longer showing up. Engine information is also now not working.

ptho2
New User
Posts: 4
Joined: Sun Nov 04, 2018 2:56 am

Re: 2013 RAV4 XLE w/o JBL Rear Camera 16 pin Connector

Post by ptho2 » Sat Nov 17, 2018 12:03 am

Someone from Maestro team please help.

User avatar
Dara DeGrand
ADS Team
Posts: 5346
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2013 RAV4 XLE w/o JBL Rear Camera 16 pin Connector

Post by Dara DeGrand » Tue Nov 20, 2018 7:59 am

Re-flashing shouldn't affect the camera function at all. Same with the gauges. Have you reset the RR? What error message is showing on the gauges screen?
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Patrikk
New User
Posts: 11
Joined: Sat Sep 24, 2016 4:31 pm

Re: 2013 RAV4 XLE w/o JBL Rear Camera 16 pin Connector

Post by Patrikk » Sat Nov 24, 2018 6:59 pm

I bought an Metra AX Toycam1 Harness from Amazon. You can cut this harness up and solder it to the RR harness to keep from having to cut the factory toyota harness






ptho2 wrote:
Sun Nov 04, 2018 10:10 am
I have a 2013 RAV4 XLE w/o JBL OEM stereo. I'm changing out the HU with a Kenwood DMX 7704S. I purchased the Maestro RR and T02 harness. All the connectors matched except for the rear backup camera connector. The one off of the OEM stereo is 16 pin but the one from T02 is a 24 pin connector. Where can I find a 16 pin connector?

Post Reply

Return to “TO2 radio replacement solution”