2017 BRZ backup camera black screen

Group using the TO1 and TO2 firmware * see specific firmware for full feature list.
Post Reply
COBlue
New User
Posts: 3
Joined: Sat Oct 27, 2018 11:09 am

2017 BRZ backup camera black screen

Post by COBlue » Wed Oct 31, 2018 1:42 pm

Everything works great except I can't get past the dreaded black screen for the backup camera. Maybe somebody can find what I'm missing? 2017 BRZ PP with Pioneer AVH-2440NEX through Maestro RR with Drok 12v-6v and TO1 harness modified as below. 6.01v to camera verified.

Antenna adapter (blue) wire to 10pin harness pin 8 ANT + (blue wire)

28 PIN HARNESS PINS
2 (Reverse) - HU Reverse Gear Signal Input (purple/white) AND Drok Converter 12V (red)
9 (Amp Signal 12v) - HU Remote System Control (blue/white)
11 (Camera power 6v) - DROK 6v (yellow)
12 (Camera +) - RCA camera + (yellow)
13 (Camera -) - RCA camera - (brown)
15 (Parking) - HU Parking brake (light green) if no bypass used
17 (Vehicle Speed VSS) - HU VSS wire (if used)
20 (Camera Pwr GND) - DROK 6v ground (black)
21 (SW1) - RR yellow/red (iDatalink doc shows purple/red)
22 (SW2) - RR pink/red
23 (SW grnd) - RR black AND Drok 12 ground (black)

COBlue
New User
Posts: 3
Joined: Sat Oct 27, 2018 11:09 am

Re: 2017 BRZ backup camera black screen

Post by COBlue » Wed Oct 31, 2018 4:10 pm

Turns out it was a bad wire. So for those looking to install (and for iDatalink reference), the above pinouts do work for 2017 BRZ. (Although note that the proper USB adapter is the Axxess AX-SUBUSB2, NOT the AX-TOYUSB).

Post Reply

Return to “Toyota”