2012 Vw CC maestro rr and kenwood 9904s help

Group using the VW1 firmware for Media Device Interface (MDI), Multi-Funtion Display (MFD), bluetooth, amplifier turn on, amplifier digital fader, amplifier gain adjustment, steering wheel control, custom gauges, vehicle info, park assist, Navigation arrows on MFD, climate status screen...
Selkec
New User
Posts: 15
Joined: Sat Sep 22, 2018 8:52 pm

2012 Vw CC maestro rr and kenwood 9904s help

Post by Selkec » Sun Sep 23, 2018 6:58 am

Have couple questions about installing. I have a few wires left that aren’t connected.

1. Maestro rr has a yellow/black foot brake and a pink speed sensor wire left with nothing to connect too on the kenwood. Do I need to splice them into something else?

2. The kenwood wiring harness has a blue/yellow steering wheel remote wire that has nothing to connect too by following the maestro instructions.

Now there is a blue port on maestro that has what looks like a data cable with a blue yellow wire but it’s not being used according to the maestro instructions. Could that be used to connect to the kenwood as a data and also to the left over matching wire?

Please help me.

User avatar
Dara DeGrand
ADS Team
Posts: 5009
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2012 Vw CC maestro rr and kenwood 9904s help

Post by Dara DeGrand » Mon Sep 24, 2018 9:26 am

1. These do not need to be connected.

2. Do not connect the Kenwood's blue/yellow, and do not use the blue plug on the maestro. They aren't needed for your install type.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Selkec
New User
Posts: 15
Joined: Sat Sep 22, 2018 8:52 pm

Re: 2012 Vw CC maestro rr and kenwood 9904s help

Post by Selkec » Tue Sep 25, 2018 10:05 am

Ok. Got it up and running. Works for the most part. The gauges are way off. Says I’m going over 100mph and says I have more fuel in tank than I do. And I have changed he amount in the setup but no matter what I set it too it says I have over 17 gallons.

It also will not show the tire pressure but it does in my mfd...

The hd radio will only play for 5 seconds then the volume fades away. If I change the setting to analog it works fine.

I now can not connect at all to my Vw Bluetooth no matter what setting I try. My car doesn’t even have the option anymore... I want to use the car because I don’t wanna use the cheap mic kenwood gives.

I still need to get a gps adapter so maybe that is why the mph is off?

And the adapter everyplace shows for Sirius radio is wrong for kenwood so guess I won’t hook it up. My kenwood has some plenty school looking round plug with many holes in it. Looks like a svideo almost.

I have done firmware updates to both units

Selkec
New User
Posts: 15
Joined: Sat Sep 22, 2018 8:52 pm

Re: 2012 Vw CC maestro rr and kenwood 9904s help

Post by Selkec » Tue Sep 25, 2018 10:24 am

Should the maestro rr have lights lit up because there is none. Occasionally I’ll see it light green but not much

Selkec
New User
Posts: 15
Joined: Sat Sep 22, 2018 8:52 pm

Re: 2012 Vw CC maestro rr and kenwood 9904s help

Post by Selkec » Tue Sep 25, 2018 4:05 pm

I forgot to mention. I have an Apr ecu tune and also the dsg tune for the transmission.

User avatar
Dara DeGrand
ADS Team
Posts: 5009
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2012 Vw CC maestro rr and kenwood 9904s help

Post by Dara DeGrand » Wed Sep 26, 2018 10:06 am

-We do not support TPMS display in this firmware.

-The only time it should light up is if we see you pushing a steering wheel button.

-There is a menu in the OEM Setup of the Kenwood for Gauges. You may have to change the engine type in the setting to get your gauges to read accurately. It is possible the tune could affect how we read from the car, but it's not likely.

-To have satellite radio in this car, you must add a tuner.

-For information on using and pairing your OEM bluetooth, see the owner's guide at the link below. Just so you know, if you are trying to use CarPlay, you must install the Kenwood supplied microphone.

http://images.idatalink.com/corporate/C ... 140708.pdf
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Selkec
New User
Posts: 15
Joined: Sat Sep 22, 2018 8:52 pm

Re: 2012 Vw CC maestro rr and kenwood 9904s help

Post by Selkec » Wed Sep 26, 2018 11:59 am

Ok thanks.
About the gauges I have tried all the settings in Oem setup and even changed the gas tank size to 14 but it still reads 16 and it also fluctuates from 12-16 depending on how fast I’m driving. Kinda like it’s following the rpm...

Ive also changed and tried different engines but no matter what I choose the mph is really far off at 60 it says I’m going over 100mph

And that makes total sense about why the radio has a different connector for sat radio.

Is there plans to make the tpms work in the future?
And is there a way to make the volume on the steering wheel go up just by holding it in instead of hitting it 50 times?

User avatar
Dara DeGrand
ADS Team
Posts: 5009
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2012 Vw CC maestro rr and kenwood 9904s help

Post by Dara DeGrand » Wed Sep 26, 2018 12:12 pm

There are no plans to make TPMS work because it can't be done in VW. The sensors don't send a numeric value on the lines where we're reading, so we aren't able to get the information.

No, this is a limitation of the Kenwood. Any volume past 15, you must push the button for each volume level. Even the radio's volume buttons work this way.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Selkec
New User
Posts: 15
Joined: Sat Sep 22, 2018 8:52 pm

Re: 2012 Vw CC maestro rr and kenwood 9904s help

Post by Selkec » Sat Sep 29, 2018 1:21 pm

About the Bluetooth. I won’t be using it to speak for texting or anything in car play. I would just like it to be able to connect to my VW Bluetooth but with maestro connected there is not even bluetooth options in my vw mfd or anywhere to even try to connect it. It’s like maestro deleted it from my car. Can I get it back?

Selkec
New User
Posts: 15
Joined: Sat Sep 22, 2018 8:52 pm

Re: 2012 Vw CC maestro rr and kenwood 9904s help

Post by Selkec » Sun Sep 30, 2018 12:37 pm

I have been trying everything including reinitializing the maestro and or kenwood several times but the MPH is still way off no matter what engine I choose and the fuel is way off no matter what I choose. I just set it in again and to 10 gallons when I really have 16 gal tank. But no matter the setting it will say I have about 17 gallons then it will drop. If I floor the gas pedal the fuel gauge will drop under 10 gallons and never rise back up....

Is there any hidden settings we could check out? Remember I have the Apr stage 1 tune and I have the apr dsg tune for the transmission.

I do have a obdeleven that I can read and or change some of the settings inside my ecu. Kind of like the real vagcom or vcds.... maybe that could help us diagnose?

Selkec
New User
Posts: 15
Joined: Sat Sep 22, 2018 8:52 pm

Re: 2012 Vw CC maestro rr and kenwood 9904s help

Post by Selkec » Sun Sep 30, 2018 6:20 pm

The more I check there is not one gauge that is correct if it does show anything. It says I’m running up to 60lbs of boost. 😂 I’m currently texting and driving at 113mph but it’s actyly 74 mph. The only gauge that is correct is rpm. When I validate pids it gets none and no vin.

It doesn’t seem compatable with 2013 vw cc as far as I can tell

Selkec
New User
Posts: 15
Joined: Sat Sep 22, 2018 8:52 pm

Re: 2012 Vw CC maestro rr and kenwood 9904s help

Post by Selkec » Sun Sep 30, 2018 7:17 pm

I’m redoing it all again online and now it’s showimg the harness that has some white plug to plug into but my harness has no white plug. Do I need that other harness possibly?

Selkec
New User
Posts: 15
Joined: Sat Sep 22, 2018 8:52 pm

Re: 2012 Vw CC maestro rr and kenwood 9904s help

Post by Selkec » Tue Oct 02, 2018 5:36 am

So I redid everything starting online making sure all the oem options and everything was checked. Checked all settings and connections and nothing changed. Still every gauge is off except the rpm.
And no matter what Bluetooth setting I choose. I can not use my phone thru my car Bluetooth. I wanted to use it since it has a better mic than the Kenwood and now I have lost the Kenwood mic. Lol. Can you help me or suggest anything that can help some of the issues I’m having?

User avatar
Dara DeGrand
ADS Team
Posts: 5009
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2012 Vw CC maestro rr and kenwood 9904s help

Post by Dara DeGrand » Tue Oct 02, 2018 8:54 am

If the bluetooth is grayed out no matter what you do, that means we do not detect it in the vehicle. It is possible that it was built into the OEM radio. That can be the case with some VW cars, though it's rare.

Our R&D Manager owns a CC and did the majority of the testing for the VW platform on this car, so we know for a fact it is compatible. As for the gauges, we are simply taking the information the vehicle reports and populating it as a gauge. We are not calculating the data for most items, like speed. So if the speed reported is way off, that is because the vehicle is mis-reporting it. Does the car have a chip/programmer/flashed ECU, by chance?
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Selkec
New User
Posts: 15
Joined: Sat Sep 22, 2018 8:52 pm

Re: 2012 Vw CC maestro rr and kenwood 9904s help

Post by Selkec » Tue Oct 02, 2018 1:17 pm

Yes. It was tuned by APR. thats probably the issue.

When I am setting it up online I made sure it was checked to retain Bluetooth. Could there be something else I am not seeing to check to get Bluetooth connectivity back in my car?

Post Reply

Return to “Volkswagen”