Climate controls with K150 kit gone haywire

Group using the FO1 and FO2 firmware for Ford SYNC retention * see specific firmware for full feature list.
Post Reply
ranesko
New User
Posts: 9
Joined: Wed Feb 21, 2018 8:45 am

Climate controls with K150 kit gone haywire

Post by ranesko » Mon Sep 17, 2018 10:59 am

2103 F-150 XLT. Had 4.3 my ford radio. Now has JVC KW-V840BT with the maestro RR and K150 dash kit.
This week the radio rebooted twice while driving and then the next day the climate controls got stuck on the hottest heat settings. The K150 kit lights up. The radio climate control display shows what I'm selecting (max AC, coldest setting) but the vehicles climate controls do not respond. The "off" works and the blower speed works, jut stuck on hottest heat. I made the modification suggested months ago of wiring the red/black from the K-150 dash kit to the maestro yellow/black when the dash kit stopped responding completely then. Any thoughts as to maestro vs k150 kit?

PS I do have to add how disappointed I've been with these 2 parts trying to interphase with the 2013 F-150. Suggestions such as reset the maestro or re-flash the software of course involves tearing the dash apart each time.

User avatar
Zack Flynn
ADS Team
Posts: 285
Joined: Mon Dec 12, 2011 9:46 am

Re: Climate controls with K150 kit gone haywire

Post by Zack Flynn » Mon Sep 17, 2018 7:17 pm

Does the compressor under the hood turn on and off with the AC being turned on or off? Pretty much any air this time of year will feel like the heat is on high without the AC actually on. Just wondering if there is any chance of the vehicle being low or borderline on refrigerant. If it is, the compressor wont turn on to keep itself from burning up. If all the other controls (fan speed, on/of, etc are working it might be something to look at.

Also, when was the Maestro last flashed, and what version of the JVC firmware is on the radio?
Zack Flynn
Automotive Data Solutions
Technical Support & MECP Master Installation Technician
Zachary.flynn@adsdata.ca

ranesko
New User
Posts: 9
Joined: Wed Feb 21, 2018 8:45 am

Re: Climate controls with K150 kit gone haywire

Post by ranesko » Tue Sep 18, 2018 9:11 am

The Maestro RR was flashed in June or July this year after BestBuy replaced it because my head unit would reboot randomly. Yes the A/C compressor comes on. The reason I don't think it is my vehicle and the A/C system is that even in early morning or late at night, using the fresh air vent with the blower on, the air comes out HOT, much hotter than ambient temperatures. Software versions as follows:

JVC serial number 083X0204
App Version 2.0.0008.4700
System Version 1.0.0128.4400
Panel CPU Version 1.0.0129.1400

My "plan" is to remove the K-150 panel kit tomorrow and temporarily wire in the stock panel to see if it corrects the climate controls. I'll post an update here tomorrow. If it corrects the problem, which unit (K-150 kit or Maestro) is the likely defective component?

TY

Rich

User avatar
Dara DeGrand
ADS Team
Posts: 5022
Joined: Mon Dec 02, 2013 1:34 pm

Re: Climate controls with K150 kit gone haywire

Post by Dara DeGrand » Tue Sep 18, 2018 10:58 am

When the dash kit stops responding, are you able to control the climate through the radio?
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

ranesko
New User
Posts: 9
Joined: Wed Feb 21, 2018 8:45 am

Re: Climate controls with K150 kit gone haywire

Post by ranesko » Tue Sep 18, 2018 3:04 pm

Dara, the dash kit still responds and I can also use the touch screen radio to adjust the climate settings. It is just that no matter where it is set, super hot air blows out. I checked the vehicle's fuses (good) and swapped the A/C relay out with a spare. No improvement. I reset the maestro using the OEM controls on the radio- no improvement. The A/C compressor does engage and the main A/C hose is COLD to the touch, it just seems like the climate control will not change the air temperature sent into the passenger compartment despite where the temperature knob is set. Tonight or tomorrow morning I will tear into the dash and swap in the OEM dash trim to see if the climate controls work as they should. - Rich

User avatar
Dara DeGrand
ADS Team
Posts: 5022
Joined: Mon Dec 02, 2013 1:34 pm

Re: Climate controls with K150 kit gone haywire

Post by Dara DeGrand » Tue Sep 18, 2018 5:13 pm

When the air blows full hot: that is what Ford programmed the vehicle to do if it doesn't see a climate controller.

When this happens, does the radio still turn on/off like it should? Do the steering wheel controls still work?
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

ranesko
New User
Posts: 9
Joined: Wed Feb 21, 2018 8:45 am

Re: Climate controls with K150 kit gone haywire

Post by ranesko » Tue Sep 18, 2018 6:18 pm

The radio still turns on/off. The steering wheel controls work MOST OF THE TIME. Just today they did not work and then I turned off the ignition, opened the door to end the delayed accessory power and restarted the truck and the steering wheel controls worked again. Just to be clear the blower speed does work from off, to low, medium and full on. All appears to work except very hot air comes out no matter where the temp setting is.

User avatar
Dara DeGrand
ADS Team
Posts: 5022
Joined: Mon Dec 02, 2013 1:34 pm

Re: Climate controls with K150 kit gone haywire

Post by Dara DeGrand » Wed Sep 19, 2018 11:41 am

The fact that your radio turn on and off like normal, and that you are able to control fan speed, shows that the maestro is communicating with the radio. If you put the OEM radio back in, i suspect that you're going to have the same issue. Have you checked all of the fuses related to the climate system?
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

jeremylangley
12Volt Specialist
Posts: 23
Joined: Mon Jan 12, 2015 10:27 pm

Re: Climate controls with K150 kit gone haywire

Post by jeremylangley » Wed Sep 19, 2018 8:03 pm

Th blend motor that switches your cold and hot air is known to have issues in that model F150. Most of time it is the motor, but sometimes it can be recalibrated. Putting the factory radio back in will verify this is the problem.
Jeremy Langley
Autosound of Lexington
2439 Nicholasville Road
Lexington KY 40503
859-278-3043

ranesko
New User
Posts: 9
Joined: Wed Feb 21, 2018 8:45 am

Re: Climate controls with K150 kit gone haywire

Post by ranesko » Thu Sep 20, 2018 1:08 pm

Thank you all for the insight! It was a bad climate control "blend" actuator and not the maestro/k150 dash kit. My first thought was the maestro or K150 kit because I have had numerous problems with this set-up (climate controls stopped working until I did the re-wire fix). Steering wheel controls not working on occasion, but a restart of the vehicle generally takes care of this. I still battle the head unit randomly shutting off and restarting. Sometimes several times per day/trip and then again not for a few weeks later. No rhyme or reason to it. Can happen while the truck is running or in accessory position. Makes no difference if music is being played soft, loud or not at all. Makes no difference if my cell phone is in use, plugged into carplay or left in the house. I have replaced the head unit. Replaced the maestro rr. re-flashed the maestro. updated firmware in the radio and the maestro. provided an accessory feed separate from the maestro, you name it, I've tried it. Radio is JVC KW V840BT. BestBuy has been great about all in swapping out items, but they're losing money on this and even with all, the problem persists.

jeremylangley
12Volt Specialist
Posts: 23
Joined: Mon Jan 12, 2015 10:27 pm

Re: Climate controls with K150 kit gone haywire

Post by jeremylangley » Thu Sep 20, 2018 9:05 pm

Glad you got it figured out!
Jeremy Langley
Autosound of Lexington
2439 Nicholasville Road
Lexington KY 40503
859-278-3043

Post Reply

Return to “Ford, Lincoln, Mercury, Mazda”