2015 Ford Escape 5 AUDIO BUTTONS - WITH SYNC

Group using the FO1 and FO2 firmware for Ford SYNC retention * see specific firmware for full feature list.
Post Reply
velocitymotorsports
12Volt Specialist
Posts: 253
Joined: Sun Nov 04, 2007 10:16 am
Location: Morden, Manitoba

2015 Ford Escape 5 AUDIO BUTTONS - WITH SYNC

Post by velocitymotorsports » Thu Aug 30, 2018 10:52 am

Just installed a Kenwood DDX375BT with the RR and FO2 harness for a customers 2015 Ford Escape with the 5 button audio and 4.3" screen. Everything works fine except I can not get the steering wheel controls to operate. We used the 3.5 mm connector with the blue/yellow wire and attached this to the Kenwood's blue/yellow wire and still no steering wheel controls.

I know it's probably something simple and Dara will answer this is 30 seconds :lol: , but any help is appreciated. TIA
Jeff Sit, Owner & Installer
Velocity Custom Home Theater
Mobile Audio/Video Specialist
Fleet GPS Installations
Morden, Manitoba

Smfgt16
New User
Posts: 8
Joined: Fri Aug 24, 2018 11:47 am

Re: 2015 Ford Escape 5 AUDIO BUTTONS - WITH SYNC

Post by Smfgt16 » Thu Aug 30, 2018 2:14 pm

Im going to go out on a limb from just doing my 16 XLT with the 4.3" Screen and I did the exact same thing you did and it was wrong.. they ended up telling me I used the wrong wire.. if this Escape is retaining Sync and using the OBDII communication for the Kenwood.. you will have an all black small 4 pin data cable (H) and a 3.5mm connector with 3 pins on it (D) -- you shouldnt need to use the steering wheel connector wire on the Kenwood.. at least I didnt with my DDX9903S.. but my setup uses the same firmware... it should do all of its steering wheel control communication through the 2nd factory harness plug that was in the back of the factory stereo.

Image

User avatar
Dara DeGrand
ADS Team
Posts: 5022
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2015 Ford Escape 5 AUDIO BUTTONS - WITH SYNC

Post by Dara DeGrand » Thu Aug 30, 2018 4:39 pm

Jeff,
Disconnect your blue/yellow and get rid of the blue plug altogether, as it isn't needed in this install type. When you push a button on the steering wheel, does the light on the maestro flash like it sees you pushing a button? If you don't get any blinks, see the attached tech tip. There's info for how to wire the backup camera and the steering wheel controls, but you'll just follow the wiring for the steering wheel wires, of course.
FO2 tech tip backup cam plug.docx
You do not have the required permissions to view the files attached to this post.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

velocitymotorsports
12Volt Specialist
Posts: 253
Joined: Sun Nov 04, 2007 10:16 am
Location: Morden, Manitoba

Re: 2015 Ford Escape 5 AUDIO BUTTONS - WITH SYNC

Post by velocitymotorsports » Sat Oct 06, 2018 5:48 pm

Dara,

Customer came back and mentioned that it takes about 8-10 seconds for the backup camera to show an image on the screen. Is there any fix for this or is this normal operation ?
Jeff Sit, Owner & Installer
Velocity Custom Home Theater
Mobile Audio/Video Specialist
Fleet GPS Installations
Morden, Manitoba

User avatar
Dara DeGrand
ADS Team
Posts: 5022
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2015 Ford Escape 5 AUDIO BUTTONS - WITH SYNC

Post by Dara DeGrand » Mon Oct 08, 2018 8:48 am

Does the screen switch as soon as you go into reverse? If so, the maestro is doing its job. We don't do anything else with the camera in that application (we don't need to, because the vehicle powers the camera on its own).
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

velocitymotorsports
12Volt Specialist
Posts: 253
Joined: Sun Nov 04, 2007 10:16 am
Location: Morden, Manitoba

Re: 2015 Ford Escape 5 AUDIO BUTTONS - WITH SYNC

Post by velocitymotorsports » Tue Oct 09, 2018 4:42 pm

Dara,

The screen goes black the second the gear shift is placed in reverse but the image takes 10-15 seconds to appear. Also, the customer said that the warning " Check Your Surroundings " is blocking the image on the Kenwood screen. Is the message on Maestro or from Kenwood ?

Customer said if this can't be fixed, he would go back to the old screen since there's no delay in the image going to screen but from my original message, the problem I had was fixed by using the harness for the OE screen ( I didn't hook this up originally ) but when the OE screen harness is not plugged into the Maestro, the OE camera works but the error NO CD in on the OE screen when in reverse.

Sorry for the lengthy post but any ideas ??
Jeff Sit, Owner & Installer
Velocity Custom Home Theater
Mobile Audio/Video Specialist
Fleet GPS Installations
Morden, Manitoba

User avatar
Dara DeGrand
ADS Team
Posts: 5022
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2015 Ford Escape 5 AUDIO BUTTONS - WITH SYNC

Post by Dara DeGrand » Tue Oct 09, 2018 5:15 pm

The text "Check your surroundings" is default on Kenwood backup camera inputs.

This issue does not sound maestro related. We are switching to the reverse screen in a timely manner, which is all that we do with the backup camera. Because the vehicle is powering the camera and supplying the video image, I suspect the issue would be the same with the OEM radio.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Post Reply

Return to “Ford, Lincoln, Mercury, Mazda”