Toyota FJ Cruiser 2013 TO1 harness

Post Reply
Foggo
New User
Posts: 1
Joined: Thu Mar 08, 2018 11:55 am

Toyota FJ Cruiser 2013 TO1 harness

Post by Foggo » Fri Mar 09, 2018 2:14 pm

Toyota FJ Cruiser 2013, no subwoofer
Maestro RR - TO1 - Pioneer 5201NEX

Problems so far:
1) Engine check does not work, gauges and tire pressure working

2) Connected front dash camera (video in), but have some horizontal lines on the screen (like a obstruction of a signal)

3) When removed OEM radio (back side has - top row 2 harnesses, bottom row 4 harnesses). I managed to connect 4 harnesses from the bottom row to TO1, but 2 harnesses from the top did not connect. One of them looks like related to satellite radio, but with the other one, I have no clue what to do. Any comments?

4) Still need to reconnect OEM rear view mirror camera, can anyone confirm where to find OEM camera harness? I saw posts it is in driver kick panel.

User avatar
billr
ADS Team
Posts: 268
Joined: Mon Feb 05, 2018 9:18 am

Re: Toyota FJ Cruiser 2013 TO1 harness

Post by billr » Fri Mar 16, 2018 10:00 am

hello there,
sorry for not responding quicker. as for your issues:
1) since the gauges and TPMS work I know we have a good connection at the OBD2 port. One thing we can try is to rest the Maestro piece to see if we can get the check engine light to light up (I take it there is a check engine light on already on your dash?). To reset the Maestro interface, unplug all the connectors going to it, push and hold down the reset button that is on the side, while holding down the reset button plug in the 3 pin power connector (thicker Black, Red, Yellow wires). Keep holding the rest button down for a couple seconds after (you will see some blinks of the led) then release the button. now reconnect the rest of the connectors to the interface.

2) Sounds like the front camera may not have a good ground or the connector for the camera may not be snugly attached. Check the connections to the camera both at the camera itself and behind the radio.

3) All you will need it the connections on the T01 harness that we provide. the other connectors that were plugged into the OEM radio are not needed.

4) As for the rear camera wires, the best place is to get the wires right at the 14 pin connector at rear view mirror. The camera colors are: Video +: Red, pin 7, and Video - : White, pin 6
Just a fyi...those colors are used for other things in the vehicle too so that's why I say it might be best to get them right at the rear view mirror.

Hope this helps,
BIll
William (Bill) Repicky
Automotive Data Solutions Technical Support
MECP Master Certified
ASE A6 Certified
866-427-2999

summitbri
New User
Posts: 4
Joined: Fri Nov 16, 2018 2:19 pm

Re: Toyota FJ Cruiser 2013 TO1 harness

Post by summitbri » Sun Nov 18, 2018 1:20 pm

Hi, on this 14 pin harness, do you know which are the camera power wires/pins?

summitbri
New User
Posts: 4
Joined: Fri Nov 16, 2018 2:19 pm

Re: Toyota FJ Cruiser 2013 TO1 harness

Post by summitbri » Mon Nov 19, 2018 11:47 am

I think I figured out the power pins (C+ on 14, Cgnd on 13), but have a related question - is it better to splice the maestro rr camera power wires into these (with/without diode isolation?) or just replace this power with the maestro power? I would like to have the camera available for both reverse and as required on demand for a towing application. Since the maestro powers the camera on the ACC circuit, it seems the latter might make the most sense but not sure if I'm missing something. Thanks!

Post Reply

Return to “TO1 radio replacement solution”