Pioneer W4400NEX didn’t connect RR

Group using the TO1 and TO2 firmware * see specific firmware for full feature list.
User avatar
Dara DeGrand
ADS Team
Posts: 6322
Joined: Mon Dec 02, 2013 1:34 pm

Re: Pioneer W4400NEX didn’t connect RR

Post by Dara DeGrand » Mon Dec 17, 2018 8:41 am

As stated above, we're testing it and trying to replicate it. I will add your issue to our existing ticket.
Thanks,
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

jerryxsara
New User
Posts: 30
Joined: Mon Sep 24, 2018 10:40 pm

Re: Pioneer W4400NEX didn’t connect RR

Post by jerryxsara » Mon Dec 17, 2018 9:20 am

The music info didn’t show up in center dash that may not only CarPlay to cause it, recently I used SD card to play FLAC music and the center dash sometimes didn’t show the info(about 5% chance).

It’s likely the Pioneer issue, but can’t rule out the issue between Pioneer and RR if the music info is from Pioneer then via RR to the dash.

The priority still the initialization between Pioneer and RR.

DaveI
New User
Posts: 4
Joined: Tue Dec 25, 2018 2:00 pm

Re: Pioneer W4400NEX didn’t connect RR

Post by DaveI » Tue Dec 25, 2018 2:03 pm

I just purchased this for my 2015 4Runner. Should I upgrade my firmware to the latest Pioneer has to offer? I don't want to start out with issues from the beginning.

Is the only way to upgrade the firmware on the iData Link is to have it connected to a PC? This is a bit of a pain once my truck is back together. I guess I could leave the micro USB cable plugged into it and route that under the dash so future upgrades won't be an issue.

User avatar
Dara DeGrand
ADS Team
Posts: 6322
Joined: Mon Dec 02, 2013 1:34 pm

Re: Pioneer W4400NEX didn’t connect RR

Post by Dara DeGrand » Wed Dec 26, 2018 9:06 am

DaveI wrote:
Tue Dec 25, 2018 2:03 pm
I just purchased this for my 2015 4Runner. Should I upgrade my firmware to the latest Pioneer has to offer? I don't want to start out with issues from the beginning.
If you're not having problems with your radio, i don't recommend updating, especially since the reports here seem to show that the issues got worse once the radio was updated.

The RR must be hooked to a PC to update it. You can run a USB cable from the RR to the glove box, and then you'll be able to re-flash whenever you need without disassembling your dash. The only caveat is that you must remove power from the module before the PC will be able to detect it. This means either disconnecting your battery or pulling the main power fuse for the radio circuit.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

DaveI
New User
Posts: 4
Joined: Tue Dec 25, 2018 2:00 pm

Re: Pioneer W4400NEX didn’t connect RR

Post by DaveI » Wed Dec 26, 2018 9:17 am

Thanks Dara.

Good luck on the fix. Do you have an estimate on when a fix will be released? I didn't know if you all have a certain amount of time or a goal to get these types of issues resolved.

User avatar
Dara DeGrand
ADS Team
Posts: 6322
Joined: Mon Dec 02, 2013 1:34 pm

Re: Pioneer W4400NEX didn’t connect RR

Post by Dara DeGrand » Wed Dec 26, 2018 9:19 am

DaveI wrote:
Wed Dec 26, 2018 9:17 am
Thanks Dara.

Good luck on the fix. Do you have an estimate on when a fix will be released? I didn't know if you all have a certain amount of time or a goal to get these types of issues resolved.
Because this appears to be a Pioneer issue, I can't speak to an ETA on the fix. We have reported it to them, but now we have to wait until they can replicate it, code a fix, and release it.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

DaveI
New User
Posts: 4
Joined: Tue Dec 25, 2018 2:00 pm

Re: Pioneer W4400NEX didn’t connect RR

Post by DaveI » Thu Jan 03, 2019 6:31 pm

Any new news on how Pioneer is progressing with the fix? There are issues I'm experiencing that their latest update will fix but I don't want to lose my RR functionality. Thanks.

User avatar
Dara DeGrand
ADS Team
Posts: 6322
Joined: Mon Dec 02, 2013 1:34 pm

Re: Pioneer W4400NEX didn’t connect RR

Post by Dara DeGrand » Fri Jan 04, 2019 8:22 am

No updates yet. The person who reported this has been out (our office was closed for the week of the holiday), so they will return on January 7th.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

DaveI
New User
Posts: 4
Joined: Tue Dec 25, 2018 2:00 pm

Re: Pioneer W4400NEX didn’t connect RR

Post by DaveI » Sat Jan 26, 2019 8:08 am

Are these issues addressed with the latest RR update?

User avatar
Dara DeGrand
ADS Team
Posts: 6322
Joined: Mon Dec 02, 2013 1:34 pm

Re: Pioneer W4400NEX didn’t connect RR

Post by Dara DeGrand » Mon Jan 28, 2019 8:38 am

No; the most recent update (December 13) was adding new radio models to the firmware. I will update this thread once I have an update pertaining to these issues.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

jerryxsara
New User
Posts: 30
Joined: Mon Sep 24, 2018 10:40 pm

Re: Pioneer W4400NEX didn’t connect RR

Post by jerryxsara » Wed Feb 20, 2019 12:17 pm

I just saw the small screen does not display source info issue has been solved by new firmware, does it also fix this issue? Or still working on it?

Thanks!

User avatar
Dara DeGrand
ADS Team
Posts: 6322
Joined: Mon Dec 02, 2013 1:34 pm

Re: Pioneer W4400NEX didn’t connect RR

Post by Dara DeGrand » Wed Feb 20, 2019 12:37 pm

So far, we have been unable to reproduce this bug.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

jerryxsara
New User
Posts: 30
Joined: Mon Sep 24, 2018 10:40 pm

Re: Pioneer W4400NEX didn’t connect RR

Post by jerryxsara » Wed Feb 20, 2019 12:42 pm

You mean that on ver.2.6 the issue unable to be reproduced so far?

Sounds like this is related issue with source info issue.

Thanks!

User avatar
Dara DeGrand
ADS Team
Posts: 6322
Joined: Mon Dec 02, 2013 1:34 pm

Re: Pioneer W4400NEX didn’t connect RR

Post by Dara DeGrand » Wed Feb 20, 2019 12:53 pm

We are unable to reproduce the communication issues with any version of our firmware; the secondary display issues should be fixed with v2.6.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

jerryxsara
New User
Posts: 30
Joined: Mon Sep 24, 2018 10:40 pm

Re: Pioneer W4400NEX didn’t connect RR

Post by jerryxsara » Wed Feb 20, 2019 9:06 pm

Thanks Dara!

I might wait for the communication issue be fixed then pull out my Rr for a f/w upgrade, since the display issue is minor.

Post Reply

Return to “Toyota”