A few problems with Maestro RR

Group using the FI1 firmware * see specific firmware for full feature list.
Post Reply
Fiat500x
New User
Posts: 8
Joined: Mon Dec 11, 2017 3:53 am

A few problems with Maestro RR

Post by Fiat500x » Mon Dec 11, 2017 4:09 am

Hi, I have a few problems/questions with my Maestro RR that's installed on my 2016 Fiat 500x Trekking w/factory amp. I have the iDatalink Ch3x harness and the Pioneer nex radio. I assume my harnesss is closely related to Chrysler vehicles' since Fiat bought Chrysler corporation.

1. First time I tried to turn on my head unit, screen read "Radio Configuration Attempt" and it was counting up from 1 all the way to 16, and that's when it stayed at 16 for a long time. I turned off my vehicle and the radio attempt screen does not come up anymore. Is this normal?

2. It says OBD2 disconnected. The Maestro installation guide says my vehicle factory radio configuration (which is a 5.0 RA2 version) doesn't need to install the OBD connector. The gauges did not show anything. TPMS sensors now showing any info.

3. Bluetooth is not working. Tried calling on my phone connected to my headunit. Other party cannot hear me and I could not hear the other party through the car speakers as well. However, Bluetooth radio works and I am able to access my contacts, missed calls, etc. on the headunit display.

4. Bluetooth Answer and End buttons are not working.

5. The odomoter is flashing on my cluster info display screen. Does this mean something has happened to my car while install the Maestro and radio? I've never seen the odometer flashing before.

6. The clock setting on my radio is not correct. I cannot find any settings to set clock!!!!

I did a Maestro Master Reset through the Pioneer Maestro features menu and it doesn't solve all my problems at all.

Please help!!! I've done a few research online and not much advice really help my situation.

User avatar
Dara DeGrand
ADS Team
Posts: 6224
Joined: Mon Dec 02, 2013 1:34 pm

Re: A few problems with Maestro RR

Post by Dara DeGrand » Mon Dec 11, 2017 8:40 am

1, 2 & 5. I would recommend using the other install type for this vehicle, which uses the OBD2 connection. This should resolve both of these issues.

3. What bluetooth system are you pairing to- Pioneer? If so, did you install the Pioneer microphone?

4. Does the light on the maestro blink when you push the answer/hang up buttons on your steering wheel?

6. I'm sure there's a setting in there somewhere. If you can't find it, you might look in the Pioneer owner's manual to show you where the menu is.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Fiat500x
New User
Posts: 8
Joined: Mon Dec 11, 2017 3:53 am

Re: A few problems with Maestro RR

Post by Fiat500x » Mon Dec 11, 2017 1:15 pm

Hi Dara Debt and,

1, 2, & 5. Thanks so much for the quick reply. I will try the other install type soon. Will let you guys know how it went.

3. No, I didn't install the Pioneer Mic because Maestro has a wire that could plug into anywhere except the Aux input, so I plugged that wire in the Aux. Does the Pioneer has a seperate Mic input?

4. I will have to try and verify when I'm going to start on the alternative install method. But I think at least the Hang Up button is working, but for sure the Answer button isn't working.

5. Ok, I will look harder. Lol.

Thanks so much and I will be in touch. 😊


Sincerely,

Anson

Fiat500x
New User
Posts: 8
Joined: Mon Dec 11, 2017 3:53 am

Re: A few problems with Maestro RR

Post by Fiat500x » Mon Dec 11, 2017 7:21 pm

Dara DeGrand,

Thank you for your advices. The OBD2 problems are fixed and odometer is not flashing!!! And I am able to find the clock and date setting. It's like hidden in an inconspicous spot of the menu system. lol

However, the Bluetooth problem is still unresolved. The Maestro does blink green lights 2-3 time for each button (Hang up, Answer Call) that I pressed. Through the Pioneer headunit, I am able to search my contact list and dial it. I just cannot hear a dial tone, but can connect to the other party. Once connected, I cannot hear the other party through my speakers, nor can the other party hear me. I tried plugging the Maestro 3.5mm plug to both of the Aux and Rear Audio Output of the headunit, but still no sound whatsoever. I can play Pandora music through Bluetooth though, which is kinda strange to me. I haven't got a chance to try plugging in the Pioneer microphone, but would that solve both sound problem? I forgot to bring the microphone to the install place.

Please let me know what other solutions you may have. Thanks so much!!!

User avatar
Zack Flynn
ADS Team
Posts: 679
Joined: Mon Dec 12, 2011 9:46 am

Re: A few problems with Maestro RR

Post by Zack Flynn » Mon Dec 11, 2017 7:37 pm

You will need to plug in the Pioneer microphone for them to be able to hear you. And as far as you being able to hear them, you need to try swapping the two 4 pin connectors (white and green) that have the speaker wires in them to be able to hear them, due to the way that Chrysler products get audio into the factory amplifiers.
Zack Flynn
Automotive Data Solutions
Technical Support & MECP Master Installation Technician
Zachary.flynn@adsdata.ca

Fiat500x
New User
Posts: 8
Joined: Mon Dec 11, 2017 3:53 am

Re: A few problems with Maestro RR

Post by Fiat500x » Tue Jan 09, 2018 4:38 am

Hi again,

Everything is working fine now except for one more button that isn't working. The Bluetooth Call/off-hook button isn't working. However, it's weird the End Call/on-hook button works. Do you know what may have caused this? I tried to reset the module and re-flashed, but still the same problem. However, I'm glad everything else is working fine.

User avatar
Dara DeGrand
ADS Team
Posts: 6224
Joined: Mon Dec 02, 2013 1:34 pm

Re: A few problems with Maestro RR

Post by Dara DeGrand » Tue Jan 09, 2018 8:26 am

Does the light on the maestro blink when you press this button on the steering wheel?
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Fiat500x
New User
Posts: 8
Joined: Mon Dec 11, 2017 3:53 am

Re: A few problems with Maestro RR

Post by Fiat500x » Tue Jan 09, 2018 12:13 pm

Yes, it did blink when I pressed the Call button.

User avatar
Dara DeGrand
ADS Team
Posts: 6224
Joined: Mon Dec 02, 2013 1:34 pm

Re: A few problems with Maestro RR

Post by Dara DeGrand » Tue Jan 09, 2018 12:54 pm

The flash looks good. If it's blinking when you press that button, and all the other buttons are working properly, it sounds like the maestro is doing its job. There's a possibility that the radio might have a firmware bug that affects that specific steering wheel command. Have you checked to see if your radio's firmware is up to date?
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Fiat500x
New User
Posts: 8
Joined: Mon Dec 11, 2017 3:53 am

Re: A few problems with Maestro RR

Post by Fiat500x » Fri Jan 12, 2018 5:24 am

I checked and it has the latest firmware update. :(

User avatar
Dara DeGrand
ADS Team
Posts: 6224
Joined: Mon Dec 02, 2013 1:34 pm

Re: A few problems with Maestro RR

Post by Dara DeGrand » Fri Jan 12, 2018 8:31 am

The last thing to check is to make sure there is nothing plugged into the W/R of the pioneer. From what you're describing, I don't think you do. Normally you would have more problems with the steering wheel controls if you did.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Post Reply

Return to “Fiat”