Post Install Issues - 2016 CR-V with 7"

Post Reply
mcluvin
New User
Posts: 4
Joined: Wed Jul 10, 2019 4:04 pm

Post Install Issues - 2016 CR-V with 7"

Post by mcluvin »

I installed a JVC KW-M75BT using a Maestro RR and HO2 harness and am experiencing the following issues.
  • The camera display is too dim. I've adjusted it using the display settings on the JVC, but it still doesn't look as good as with the OEM head unit.
  • The steering wheel controls all work, but if I press the off-hook button without actually completing a call, pressing the on-hook button doesn't make the phone keypad go away as it would with the OEM head unit. I have to actually hit return on the JVC display. If I do make a call, pressing the on-hook button terminates the call properly.
  • The instructions I followed (Honda cr-v WitHout aMP not retaining oeM BluetootH 2012-2016
    ) said to unhook the bluetooth module above the glove box and attach SWI2 (orange/red) to one of the wires on the connector. I could not find a bluetooth module above the glove box and subsequent research suggests it was incorporated into the head unit on 2015-16 models. Am I missing anything by not connecting the orange/red wire to something? Other than the above issues, everything seems to be working properly. This part of the install was very confusing.
Thanks!

User avatar
billr
ADS Team
Posts: 645
Joined: Mon Feb 05, 2018 9:18 am

Re: Post Install Issues - 2016 CR-V with 7"

Post by billr »

Unfortunately aside from the display adjustments the JVC has, there is no other way of making the backup camera video brighter.
The On-Hook button will end a call however if the keypad is on the screen it will not make it go away, that's just how the JVC works.
As for the Orange/Red wire, if your phone buttons are working on the steering wheel now you don't need to connect the wire, just tape it up.
William (Bill) Repicky
Automotive Data Solutions Technical Support
MECP Master Certified
ASE A6 Certified
866-427-2999

mcluvin
New User
Posts: 4
Joined: Wed Jul 10, 2019 4:04 pm

Re: Post Install Issues - 2016 CR-V with 7"

Post by mcluvin »

Thanks for the response. I did end up taping it up. The first 2 are more annoyances than real issues. The camera is at least usable and I will rarely hit the off-hook button without actually making a call. I'd sure like to see the instructions updated regarding the orange/red wire. I spent hours trying to sort that out. The fact that the on-hook button wouldn't clear the keypad made me think the buttons weren't working properly and down the rabbit hole I went. There is scant and vague info on the internet regarding this.

One other thing I'd suggest, include a longer USB cable for programming the Maestro. This way you can run it somewhere convenient under the dash for future programming updates without taking the dash apart again.

Thanks again!

Post Reply

Return to “HO2 radio replacement solution”