Page 1 of 1

2015 Tacoma non-JBL, Kenwood DDX8906S, SXV300, Maestro RR, TO1,

Posted: Mon May 18, 2020 2:15 pm
by BadDNA
I connected my TO1 harness to the radio harness as per the instructions starting on pg 331: https://images.idatalink.com/corporate/ ... 191114.pdf

Does not sense when transmission is in P
No OBD-II data on radio
No tire pressure data or door alarms on radio
Reverse camera works when I hit the CAM button, but not when shifting to R
Satellite antenna not compatible with sTO1 adapter, looks like the sTO2 adapter will work

Re: 2015 Tacoma non-JBL, Kenwood DDX8906S, SXV300, Maestro RR, TO1,

Posted: Mon May 18, 2020 3:37 pm
by Dara DeGrand
Did you plug in the OBD2? Pretty much everything you're missing comes from that connector, so it seems like there is probably an issue with that.

Re: 2015 Tacoma non-JBL, Kenwood DDX8906S, SXV300, Maestro RR, TO1,

Posted: Mon May 18, 2020 3:50 pm
by BadDNA
I did plug it in. I'll double check it all though as soon as I get a minute.

Re: 2015 Tacoma non-JBL, Kenwood DDX8906S, SXV300, Maestro RR, TO1,

Posted: Mon May 18, 2020 4:49 pm
by Dara DeGrand
Ensure the other end of it is also plugged into the TO1 harness; that could be where the missing link is.

Re: 2015 Tacoma non-JBL, Kenwood DDX8906S, SXV300, Maestro RR, TO1,

Posted: Mon May 18, 2020 11:26 pm
by BadDNA
I had missed the connection to the main harness, thank you.

It senses park, drive, etc. now, but still does not allow access to any function requiring the vehicle to be parked, such as configuring Android Auto, or making adjustments to the parking guide lines on the rear camera.

Re: 2015 Tacoma non-JBL, Kenwood DDX8906S, SXV300, Maestro RR, TO1,

Posted: Tue May 19, 2020 8:23 am
by Dara DeGrand
If you go to setup > AV > OEM Setup > Maestro features > maestro module > diagnostics > inputs and outputs

Does it sense parking brake and gear position?

Re: 2015 Tacoma non-JBL, Kenwood DDX8906S, SXV300, Maestro RR, TO1,

Posted: Tue May 19, 2020 8:55 am
by BadDNA
Parking brake N/A, Foot Brake shows off even when engaged, It does detect the proper gear selection.

Illumination also shows N/A, but it's hooked up, the display and buttons won't dim with the rest of the dash though.

Re: 2015 Tacoma non-JBL, Kenwood DDX8906S, SXV300, Maestro RR, TO1,

Posted: Tue May 19, 2020 9:04 am
by BadDNA

Re: 2015 Tacoma non-JBL, Kenwood DDX8906S, SXV300, Maestro RR, TO1,

Posted: Tue May 19, 2020 9:31 am
by Dara DeGrand
Can you change the privacy setting on your photos so we can see them, please?

Re: 2015 Tacoma non-JBL, Kenwood DDX8906S, SXV300, Maestro RR, TO1,

Posted: Tue May 19, 2020 9:34 am
by BadDNA
Should be good to go.

Re: 2015 Tacoma non-JBL, Kenwood DDX8906S, SXV300, Maestro RR, TO1,

Posted: Wed May 20, 2020 7:43 am
by Dara DeGrand
You don't need foot brake for a kenwood, so I wouldn't worry too much about that.

Is it detecting the parking brake? If not, the radio may not let you adjust certain settings for safety purposes. Regardless of gear position, it needs to see the parking brake engaged to let you into some menus.

Re: 2015 Tacoma non-JBL, Kenwood DDX8906S, SXV300, Maestro RR, TO1,

Posted: Wed May 20, 2020 9:37 am
by BadDNA
No, it does not detect the parking brake.

Re: 2015 Tacoma non-JBL, Kenwood DDX8906S, SXV300, Maestro RR, TO1,

Posted: Thu May 21, 2020 5:06 pm
by Dara DeGrand
In some vehicles, very commonly in the Tacoma, the parking brake signal may not be present on the data lines. In this case, if we can't sense it, we aren't able to generate the output. Connecting the radio's p-brake wire directly to the parking brake in the vehicle is the way to go in this case.