2017 Corolla iM - No Parking Brake or Reverse Signal

Post Reply
Oxycleanman
New User
Posts: 2
Joined: Wed Nov 01, 2017 10:05 pm

2017 Corolla iM - No Parking Brake or Reverse Signal

Post by Oxycleanman » Wed Nov 01, 2017 10:18 pm

Hello everyone. I just finished installing a Pioneer AVH-2300NEX in my 2017 Toyota Corolla iM. I used the Maestro RR unit with the T01 harness. My steering wheel controls that I customized before flashing the RR unit all work correctly, as do the vehicle information and gauges screens. My problem is that the parking brake and reverse signal wires don’t seem to be giving any signal to the head unit.

My OEM camera is working, but only if I open the Camera View on the head unit, it does not automatically open the back up camera when putting the car in reverse.

As for the parking brake, the head unit is acting like the parking brake is always off. As a work around, I’ve grounded the parking brake wire from the head unit which allows me to use the features I couldn’t use before grounding it.

I noticed that the parking brake, reverse signal and illumination all show as N/A in the inputs section of the maestro diagnostics screen. I’ve triple checked the wiring, and the only thing I can find is that there’s four connectors showing in the instructions that should connect to the factory harness, but I only have three to connect to in my vehicle.

Thanks in advance for your help!

User avatar
Dara DeGrand
ADS Team
Posts: 5128
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2017 Corolla iM - No Parking Brake or Reverse Signal

Post by Dara DeGrand » Thu Nov 02, 2017 9:37 am

Chris,
I think we may have a firmware bug, so I'm going to roll you back to the previous firmware version. To flash it, login and hit "flash your module". Select the "flash by user firmware" tab, choose the firmware that's in that section (TO1 version 2.4), and proceed with the flash. Give that a try, and let us know how it works out for you.

Thanks,
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Oxycleanman
New User
Posts: 2
Joined: Wed Nov 01, 2017 10:05 pm

Re: 2017 Corolla iM - No Parking Brake or Reverse Signal

Post by Oxycleanman » Thu Nov 02, 2017 1:03 pm

Thanks for the reply. I spoke to someone on the phone this morning who told me that those signals weren’t expected to come through the Maestro unit in my vehicle, so I’ve already ran wires to the reverse lights and parking brake to get everything working. Is it expected that these signals would come through the unit?

User avatar
Dara DeGrand
ADS Team
Posts: 5128
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2017 Corolla iM - No Parking Brake or Reverse Signal

Post by Dara DeGrand » Thu Nov 02, 2017 2:10 pm

Yes- we've had about 15 people with 2017 Corolla iMs flash for the RR. I can't imagine that all of them would be having this problem and not call us about it. The only difference between you and the rest of them, is that you were using firmware 2.5, and they all had 2.4. It was worth a shot to roll you back to v2.4 and see if there was an issue with the most current firmware.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

barqer
New User
Posts: 6
Joined: Mon Feb 05, 2018 10:47 am

Re: 2017 Corolla iM - No Parking Brake or Reverse Signal

Post by barqer » Mon Feb 05, 2018 11:00 am

Was there a solution posted for this? I have the same problem with a 2017 Toyota 86. The Maestro RR wiring diagram shows 4 white plugs from the car. I have 3 just as the previous poster. The 4th plug seems to contain the connections for the functions that are not working for me. No reverse signal, parking brake, etc.

Everything else is working as expected. The camera works if manually selected, but won't auto enable in reverse. No parking signal so I am locked out of all of those functions.

User avatar
Dara DeGrand
ADS Team
Posts: 5128
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2017 Corolla iM - No Parking Brake or Reverse Signal

Post by Dara DeGrand » Mon Feb 05, 2018 11:48 am

If you have those analog signals at the radio cavity, that means they aren't on the data lines, so the maestro doesn't see those signals and can't create outputs. If those wires are already present, though, you can just manually hook them up to the radio and that should give it what it needs to function properly.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

barqer
New User
Posts: 6
Joined: Mon Feb 05, 2018 10:47 am

Re: 2017 Corolla iM - No Parking Brake or Reverse Signal

Post by barqer » Mon Feb 05, 2018 1:06 pm

so does that mean the wiring diagram needs to be updated? I just want to make sure that this harness doesn't exist and I'm not just missing it. I looked all through the dash as best I could. I don't see it. Honestly, there isn't much wiring in the 86 to begin with.

User avatar
Dara DeGrand
ADS Team
Posts: 5128
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2017 Corolla iM - No Parking Brake or Reverse Signal

Post by Dara DeGrand » Mon Feb 05, 2018 3:37 pm

The plug you're describing isn't part of the t-harness. It's pretty uncommon that the reverse, brake, etc are analog at the radio, so we're likely not going to add a new harness into the mix at this time.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

barqer
New User
Posts: 6
Joined: Mon Feb 05, 2018 10:47 am

Re: 2017 Corolla iM - No Parking Brake or Reverse Signal

Post by barqer » Mon Feb 05, 2018 3:40 pm

You're misunderstanding. I have an extra plug on the T01 side. There are 4 on the T01 side and only 3 coming from the car. I don't need an extra plug on the T01, it's already there :lol:

I might submit a pic of the setup tonight so you can see what myself and the previous poster meant.

barqer
New User
Posts: 6
Joined: Mon Feb 05, 2018 10:47 am

Re: 2017 Corolla iM - No Parking Brake or Reverse Signal

Post by barqer » Mon Feb 05, 2018 9:52 pm

Here is a pic of the setup. Trying to find a wiring diagram of the 2017 86 is challenging.

Image

User avatar
Dara DeGrand
ADS Team
Posts: 5128
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2017 Corolla iM - No Parking Brake or Reverse Signal

Post by Dara DeGrand » Tue Feb 06, 2018 8:41 am

Agreed- we don't have access to them yet, either. That plug isn't present in all vehicles- it's data lines for OEM audio add-ons (OEM USB if it has an external module, satellite radio, etc). It all just boils down to the build of the vehicle. With toyota, there is a lot of variability in how each vehicle is built, so it's pretty common to have extra plugs.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

barqer
New User
Posts: 6
Joined: Mon Feb 05, 2018 10:47 am

Re: 2017 Corolla iM - No Parking Brake or Reverse Signal

Post by barqer » Tue Feb 06, 2018 8:49 am

alright. I understand that.

What do I need to do to get the stock backup camera and reverse signal working? I purchased the Maestro RR and T01 harness because it said it maintained all stock system functionality, and the 2017 86 was specifically listed as "supported".

If I need to manually connect some wires, I can do that, I just need to know which ones or how to find them.

Thank you for the assistance.

User avatar
Dara DeGrand
ADS Team
Posts: 5128
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2017 Corolla iM - No Parking Brake or Reverse Signal

Post by Dara DeGrand » Tue Feb 06, 2018 9:13 am

http://images.idatalink.com/corporate/C ... 180110.pdf

See page 73 of the guide for camera wiring information.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

barqer
New User
Posts: 6
Joined: Mon Feb 05, 2018 10:47 am

Re: 2017 Corolla iM - No Parking Brake or Reverse Signal

Post by barqer » Tue Feb 06, 2018 9:21 am

I already have the camera working via the connections in the diagram you mentioned.

My problem is the backup signal is missing so the camera doesn't come on automatically.

1. I need reverse signal to make camera come on automatically.
2. I need parking brake signal so I can update firmware and change other settings that are locked.

User avatar
Dara DeGrand
ADS Team
Posts: 5128
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2017 Corolla iM - No Parking Brake or Reverse Signal

Post by Dara DeGrand » Tue Feb 06, 2018 10:15 am

If the RR is not generating the reverse and parking brake outputs, the only option would be to connect them to the radio manually. To know for sure whether or not the RR is seeing those signals on the data lines, you can go into the OEM setup, and see the input/output diagnostics in the "Maestro Module" setup menu. If reverse and parking brake show as N/A or --, the vehicle doesn't have that information on the data lines.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Post Reply

Return to “TO1 radio replacement solution”