2008 Charger & DNX890HD: No OBDII gauges

Post Reply
De-Mo-Jsa
New User
Posts: 7
Joined: Fri Apr 03, 2015 11:06 pm

2008 Charger & DNX890HD: No OBDII gauges

Post by De-Mo-Jsa » Fri Apr 03, 2015 11:18 pm

I just installed the Maestro RR in a 08 Charger w/ a Kenwood DNX890HD. Everything seems to be working except for the OBDII gauges. The gauge screen says "OBDII Disconnected" and none of the gauges work. I used "T-taps" to splice into the OBD wire harness. I thought it might have been a bad connection, so I plugged the Maestro OBD wires directly into their respecctive pins on the OBDII port and still no joy. Any ideas? Thanks!

-Dan

User avatar
Murph
Site Admin
Posts: 7358
Joined: Sun Oct 23, 2011 8:35 pm

Re: 2008 Charger & DNX890HD: No OBDII gauges

Post by Murph » Fri Apr 03, 2015 11:42 pm

You need to lose the T taps. They are a horrible connection especially on data wires. You need to do a military splice.
Image

Make sure the can h and can l are not backwards.
Brian Murphy
MECP Advanced Certified Installer
ADS Tech Support
Automotive Data Solutions inc.
8400, Bougainville, Montreal, QC.
1-866-427-2999
support@idatalink.com

De-Mo-Jsa
New User
Posts: 7
Joined: Fri Apr 03, 2015 11:06 pm

Re: 2008 Charger & DNX890HD: No OBDII gauges

Post by De-Mo-Jsa » Sat Apr 04, 2015 5:28 pm

Awesome! The splice worked! Thanks for the advice! For some reason it didn't work the first time I booted up the radio, but it works fine now.

On a separate note, will it ever be possible to flash the Maestro module without having to disconnect power to the radio/module? Not sure if that is possible in a firmware update, but it sure would be nice not to have to pull my dash apart if I want to change the steering wheel controls. Is anything like that in the works? Thanks!

-Dan

User avatar
Murph
Site Admin
Posts: 7358
Joined: Sun Oct 23, 2011 8:35 pm

Re: 2008 Charger & DNX890HD: No OBDII gauges

Post by Murph » Sat Apr 04, 2015 10:15 pm

No it will not. The module is essentially a small computer. It needs to be inactive and not part of a live circuit while being flashed.
Brian Murphy
MECP Advanced Certified Installer
ADS Tech Support
Automotive Data Solutions inc.
8400, Bougainville, Montreal, QC.
1-866-427-2999
support@idatalink.com

pedroomar76
New User
Posts: 5
Joined: Sat Jun 13, 2015 10:59 pm

Re: 2008 Charger & DNX890HD: No OBDII gauges

Post by pedroomar76 » Sat Jul 18, 2015 10:31 pm

I have the same problem with my 2008 Dodge Caliber SRT4, Kicker factory sound and Kenwood DNX690HD, everything works but the OBDII that says is not connected but i still get TPMS, Battery monitoring and thats it. I did the military splice and let the radio boot like ten times and nothing. Do i need to get them solder or something like that for OBDII to work? Its any other thing i need to check?

User avatar
Dara DeGrand
ADS Team
Posts: 5221
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2008 Charger & DNX890HD: No OBDII gauges

Post by Dara DeGrand » Mon Jul 20, 2015 8:36 am

See the attachment; Some of the CH2 harnesses came mis-pinned.
You do not have the required permissions to view the files attached to this post.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

pedroomar76
New User
Posts: 5
Joined: Sat Jun 13, 2015 10:59 pm

Re: 2008 Charger & DNX890HD: No OBDII gauges

Post by pedroomar76 » Sat Jul 25, 2015 2:30 pm

Dara DeGrand wrote:See the attachment; Some of the CH2 harnesses came mis-pinned.

Spot On as always Dara! i took me no time and the only remark ill make is that the 2 wires had separated locking tabs, since i tought i was just one tab and then the 2 wires will come off. (silly me) :? :D

fhoward772
New User
Posts: 1
Joined: Fri May 06, 2016 3:18 pm

Re: 2008 Charger & DNX890HD: No OBDII gauges

Post by fhoward772 » Mon Jul 11, 2016 11:35 am

i am not able to open attachment. what did you do to get this to work . please

User avatar
Dara DeGrand
ADS Team
Posts: 5221
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2008 Charger & DNX890HD: No OBDII gauges

Post by Dara DeGrand » Mon Jul 11, 2016 12:59 pm

Check your email. :D
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

sordee
12Volt Specialist
Posts: 15
Joined: Wed Dec 02, 2009 1:38 pm
Location: Yakima Washington

Re: 2008 Charger & DNX890HD: No OBDII gauges

Post by sordee » Mon Jul 11, 2016 6:53 pm

looks like were having the same problem DDX393 and rr

2005 chrysler 300

no gauges OBD disconnected

tried to open your tech tip and there is nothing there

Thanks
Jason S
Jason Sorenson
Performance Auto Sound
2210 S. 1st Street
Yakima, Wa. 98903
509-452-0406

PeteB
12Volt Specialist
Posts: 102
Joined: Fri Jun 17, 2016 9:19 am

Re: 2008 Charger & DNX890HD: No OBDII gauges

Post by PeteB » Mon Jul 11, 2016 7:50 pm

here is another to try
Tech tip CH2 v2.docx
You do not have the required permissions to view the files attached to this post.
Peter Bennett

Post Reply

Return to “CH2 radio replacement solution”