Wrangler 2012 /alpine ilx-f903

Jez1969
New User
Posts: 11
Joined: Wed Nov 20, 2019 3:58 pm

Wrangler 2012 /alpine ilx-f903

Post by Jez1969 »

Hi everybody,
I installed a alpine ilx-f903 without idatalink and maestro rr/ch1
And I have 2 problems:
- I have no equalizer working just fader and balance but with strange way. If I push the fader to the front speaker there is no more sound. And if I switch the white and green wires with 4 pins on ch1 it's happen the opposit( push the cursor to the back speakers and no sound).
- And I can't have subwoofer modification like more or les basses.
That's mean maybe I don't have amplifier ? (Jeep wrangler 2012 2.8 crd arctic version with infinity speakers.
But when I flash maestro without factory amplifier I have no more song.
Just Thant's to help me if you can in advance.
Really best regards.
Jez

User avatar
Dara DeGrand
ADS Team
Posts: 6970
Joined: Mon Dec 02, 2013 1:34 pm

Re: Wrangler 2012 /alpine ilx-f903

Post by Dara DeGrand »

You do have a factory amplifier.

This radio is a European model, so it is not iDatalink compatible. Because of this, the Jeep's digital fader cannot be retained. The behavior you are reporting is normal. There is no dedicated subwoofer adjustment because there is one set of speaker outputs that go to the amplifier for all the speakers. From there, the amp controls the output to the sub. You would need to adjust the bass in the EQ and that would ultimately adjust the subwoofer volume.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Jez1969
New User
Posts: 11
Joined: Wed Nov 20, 2019 3:58 pm

Re: Wrangler 2012 /alpine ilx-f903

Post by Jez1969 »

Really thanks for reply!!!
- It's mean if I just adjust the basse it's adjust also the subwoofer? Both are Inthe same line!?.
- may I buy a new amplifier (not factory?) It will work properly? And it's mean I don't need maestro RR and ch1?!

And last have you seen my first problem the equaliser going crazy with fader (up to front speakers no sound down to back speaker same as center is working) and when I switched the 4 pins ch1 white and green it's happened the opposite with fader ... ?!

And big thanks to help me.

Best regards.

Jez

User avatar
Zack Flynn
ADS Team
Posts: 928
Joined: Mon Dec 12, 2011 9:46 am

Re: Wrangler 2012 /alpine ilx-f903

Post by Zack Flynn »

All the speakers will play, but you will not be able to fade the radio to individual channels because of the factory amplifier being controlled digitally by the RR. If you use an aftermarket amplifier instead of retaining the factory, you would still need the RR to give you steering wheel controls and accessory power as the signals coming from the jeep are not analog and unusable without an interface of some kind. You would also need to reflash the RR and uncheck that you are keeping the factory amplifier in the "OEM systems to retain section" for the fader to work properly with the aftermarket amplifier.
Zack Flynn
ILF Consulting LLC
MECP Master Installation Technician and SME

Jez1969
New User
Posts: 11
Joined: Wed Nov 20, 2019 3:58 pm

Re: Wrangler 2012 /alpine ilx-f903

Post by Jez1969 »

I don't how to thank you more. It's not conventional to give answers like you.
I understand all.
But the aftermarket amplifier must be connect to the RR and ch1 modules?!
Best regards

User avatar
Zack Flynn
ADS Team
Posts: 928
Joined: Mon Dec 12, 2011 9:46 am

Re: Wrangler 2012 /alpine ilx-f903

Post by Zack Flynn »

The aftermarket amplifier will not be specifically connected to the RR or the CH1 harness, but they are both still required to make the radio turn on and retain the steering wheel controls from the jeep. There is no usable key switched power with out them, and the steering wheel controls are all obtained from the vehicle's CAN data network, which is what the RR is there to do specifically. You need it for the radio to work, with or without either the factory amplifier or an aftermarket one.
Zack Flynn
ILF Consulting LLC
MECP Master Installation Technician and SME

Jez1969
New User
Posts: 11
Joined: Wed Nov 20, 2019 3:58 pm

Re: Wrangler 2012 /alpine ilx-f903

Post by Jez1969 »

Hello I have a problem with Android auto I have no voice with Google assistant and waze maps only the voices for the rest every thing is ok. I ask you because I was thinking about the idatalink which I don't have with ilx-f903. Maybe the voices are in a special canal maybe it was a problem with amplifier or the equaliser I couldn't use. I followed Google forums and tried a lot of fixes I ask alpine and they say it's a problem of new version of Android auto.
Can you maybe have an answer about that? 4 mounth with this problem I cannot ears message and WhatsApp message by Google Voice.
Thank's in advance.

Best regards

User avatar
Dara DeGrand
ADS Team
Posts: 6970
Joined: Mon Dec 02, 2013 1:34 pm

Re: Wrangler 2012 /alpine ilx-f903

Post by Dara DeGrand »

All of the audio for Android Auto is self contained within the radio. If you have audio on all of the other sources, like radio and bluetooth, but not an AA, there is an issue with AA (whether it is radio firmware or AA software, I am not sure).
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Jez1969
New User
Posts: 11
Joined: Wed Nov 20, 2019 3:58 pm

Re: Wrangler 2012 /alpine ilx-f903

Post by Jez1969 »

Thank's for reply really.
I'm goin crazy with that all works in AA only voices in Google assistant and waze maps WhatsApp. I heard a little bit a saturated sound .

Jez1969
New User
Posts: 11
Joined: Wed Nov 20, 2019 3:58 pm

Re: Wrangler 2012 /alpine ilx-f903

Post by Jez1969 »

Hello again i tried m'ly phone (pixel 4xl) on another alpine ilx-f903 from a seller and the voices are working !!!
It.s look the fact if my radio is not idatalink the voices don't work !! Maybe the voices use the front speakers.
What do think!?
And last question the new sony xav ax8000 is idatalink ?

Thanks in advance for all time spending for me.
👍

User avatar
Dara DeGrand
ADS Team
Posts: 6970
Joined: Mon Dec 02, 2013 1:34 pm

Re: Wrangler 2012 /alpine ilx-f903

Post by Dara DeGrand »

The voices have nothing to do with the maestro. However, if you have it wired incorrectly and it is amplified, the audio for bluetooth, maps, etc. will not come through.

The XAV-AX8000 is not iDatalink compatible. You can see the list of compatible radios here:
https://maestro.idatalink.com/compatible-radios
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Jez1969
New User
Posts: 11
Joined: Wed Nov 20, 2019 3:58 pm

Re: Wrangler 2012 /alpine ilx-f903

Post by Jez1969 »

Hello what does mean it is amplified? Maybe I wired bad! Ok it's an option I followed the maestro diagram. You have an idée of which wire is the bad one?
Thank's again

User avatar
Dara DeGrand
ADS Team
Posts: 6970
Joined: Mon Dec 02, 2013 1:34 pm

Re: Wrangler 2012 /alpine ilx-f903

Post by Dara DeGrand »

Switch the white and green plugs.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Jez1969
New User
Posts: 11
Joined: Wed Nov 20, 2019 3:58 pm

Re: Wrangler 2012 /alpine ilx-f903

Post by Jez1969 »

Ok I'll try .
Thank's for reply .
Really best regards

Jez1969
New User
Posts: 11
Joined: Wed Nov 20, 2019 3:58 pm

Re: Wrangler 2012 /alpine ilx-f903

Post by Jez1969 »

Hello Sara
I switched white to white and green to green and everything goes ok . You're right!. But it's mean this configuration is for non amp. And I have amp. I don't understand really. Wrangler 2012 arctic version 200cdr 2 doors and uconnect. I think you know more than you say 😉

Post Reply

Return to “CH1 radio replacement solution”