Service Parking Assist 2008 Yukon XL 1500 Pioneer 4200NEX

Post Reply
lbdelaney
New User
Posts: 1
Joined: Sat Mar 30, 2019 8:00 pm

Service Parking Assist 2008 Yukon XL 1500 Pioneer 4200NEX

Post by lbdelaney »

OK Have everything plugged in with RR and GM5+ with factory Bose system.
Everything seems to be working but have the following issues
" haven't tested on Star as the vehicle is to old for that service "2008"
  • Parking assist not working, and dash now says service parking assist. more of a Backup assist you know the kind with the 3 lights by the hatch and the beeps" :x
    Put Factory Radio back in and that goes away.
  • Thought that the chimes went through the car speakers, had to plug in the external speaker to hear turn signals. :?
  • No sound on XM either, shows connected and SN numbers etc.. but no sound.
Have put the factory radio back in for now till I figure this out. :cry:

User avatar
Dara DeGrand
ADS Team
Posts: 6630
Joined: Mon Dec 02, 2013 1:34 pm

Re: Service Parking Assist 2008 Yukon XL 1500 Pioneer 4200NEX

Post by Dara DeGrand »

There is an audio cable that runs between the maestro and the radio. If that is not plugged in, or plugged into the wrong port, the satellite radio will not be audible. Make sure that you have it plugged into the AUX on the Pioneer.

Make sure that the "P" parking assist button on the dash is plugged in and lights up when you push it. Otherwise, that message generally means that you have a parking sensor that needs to be cleaned.

You are correct, you do need to install the external speaker as it shows on the install guide.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Post Reply

Return to “GM5+ radio replacement solution”