2013 silverado and kenwood dnx890hd

Post Reply
montess8468
New User
Posts: 4
Joined: Tue Jun 24, 2014 9:58 am

2013 silverado and kenwood dnx890hd

Post by montess8468 »

When I installed my radio into my truck and connected into my OBDII port all the gauges in my truck went haywire. If I leave it disconnected everything works fine. When it is connected my stabilitrack, traction control, parking assist and my check engine light all cycle on and off. Also the transmission doesn't shift and I have to shift it manually. I am just curious if I connected something wrong or there is some other problem. I have the maestro ads-mrr and also the gm5 wiring harness if that helps. Thanks.

User avatar
Murph
Site Admin
Posts: 6699
Joined: Sun Oct 23, 2011 8:35 pm

Re: 2013 silverado and kenwood dnx890hd

Post by Murph »

Either you got them backwards of they are crossed when you extended the wires.
Brian Murphy
MECP Advanced Certified Installer
ADS Tech Support
Automotive Data Solutions inc.
8400, Bougainville, Montreal, QC.
1-866-427-2999
support@idatalink.com

montess8468
New User
Posts: 4
Joined: Tue Jun 24, 2014 9:58 am

Re: 2013 silverado and kenwood dnx890hd

Post by montess8468 »

I have checked my wires and they are not crossed. The brown/red goes to the tan/black and the brown/yellow is connected to the tan. Originally it worked for a week and then it stopped working.

User avatar
Murph
Site Admin
Posts: 6699
Joined: Sun Oct 23, 2011 8:35 pm

Re: 2013 silverado and kenwood dnx890hd

Post by Murph »

Did you use T taps on the can wires?
Brian Murphy
MECP Advanced Certified Installer
ADS Tech Support
Automotive Data Solutions inc.
8400, Bougainville, Montreal, QC.
1-866-427-2999
support@idatalink.com

montess8468
New User
Posts: 4
Joined: Tue Jun 24, 2014 9:58 am

Re: 2013 silverado and kenwood dnx890hd

Post by montess8468 »

I did use T-taps to connect into the wiring.

zynan
New User
Posts: 11
Joined: Sun Jun 29, 2014 12:33 am

Re: 2013 silverado and kenwood dnx890hd

Post by zynan »

I have a 2011 Tundra and my gauges started going haywire as well when I tapped into the ODB wires. I checked that they are mapped properly. When I disconnected the wires, everything went back to normal. Does anybody have some idea's?

User avatar
Dara DeGrand
ADS Team
Posts: 6628
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2013 silverado and kenwood dnx890hd

Post by Dara DeGrand »

montess8468 wrote:I did use T-taps to connect into the wiring.
Remove your t-taps. Every time I see issues with the obd wires causing issues in a vehicle, it is either due to reversed wires or a poor connection. I have even seen an improper connection at those wires cause a vehicle not to start. These data connections are essential to your vehicle functioning properly, so it's very important to make a good connection when splicing into them.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

montess8468
New User
Posts: 4
Joined: Tue Jun 24, 2014 9:58 am

Re: 2013 silverado and kenwood dnx890hd

Post by montess8468 »

I removed the T-taps and stripped back some of the wire and spliced directly into the wires and soldered it back together and everything is working again. It must have been a bad connection with the t-taps. Thanks.

User avatar
Murph
Site Admin
Posts: 6699
Joined: Sun Oct 23, 2011 8:35 pm

Re: 2013 silverado and kenwood dnx890hd

Post by Murph »

Never use T taps on data wires.
Brian Murphy
MECP Advanced Certified Installer
ADS Tech Support
Automotive Data Solutions inc.
8400, Bougainville, Montreal, QC.
1-866-427-2999
support@idatalink.com

User avatar
Dara DeGrand
ADS Team
Posts: 6628
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2013 silverado and kenwood dnx890hd

Post by Dara DeGrand »

Good to hear you've got it up and running.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Max Power
12Volt Specialist
Posts: 161
Joined: Tue Dec 07, 2010 11:27 am

Re: 2013 silverado and kenwood dnx890hd

Post by Max Power »

Murph wrote:Never use T taps.
Fixed it for you.
Tony Nostedt
N3 Sales Inc.
154 Railway Ave.
Rathwell Mantioba Canada
R0G 1S0
1-888-749-2013
President

tstrelka
New User
Posts: 2
Joined: Thu Jun 27, 2019 9:48 pm

Re: 2013 silverado and kenwood dnx890hd

Post by tstrelka »

I haven't tapped into the OBDII wires yet. I'm using the plug connector and since I installed the radio and Maestro RR, I have messages Service StabiliTrak, Service Traction Control in the Driver Information Center along with the warning lights. It's random and does not happen every day. I will unplug the OBDII for the gauges and see if the issue persists before I bring it to the dealer for repair. I have a 2012 Silverado with the 5.3L V8 and a Sony XAV-AX210 stereo system.

Post Reply

Return to “GM5+ radio replacement solution”