Stuck on “turn key to off position”

Find answers to common installation issues with the WebLink Updater.
Post Reply
jilewis843
New User
Posts: 5
Joined: Tue Mar 02, 2021 11:01 pm

Stuck on “turn key to off position”

Post by jilewis843 »

I have a 2008 Mustang with a Pioneer 4200-NEX. I have 2 problems, 1. The red light flashes(twice) even though I’ve made sure all the connections are secure. 2. If I start my vehicle it starts the setup, doesn’t detect a vin number, chooses platform 1 and the switches to “turn key to off position.” Turning the key does nothing, radio will stay on in the off position, even if I open the driver’s door.

User avatar
Dara DeGrand
ADS Team
Posts: 7528
Joined: Mon Dec 02, 2013 1:34 pm

Re: Stuck on “turn key to off position”

Post by Dara DeGrand »

On the t-harness, there are 3 plugs that could connect to the car (the big rectangular one, the medium sized one, and the small one). Of those connectors, are all three plugged in? Is the OBD2 connector plugged into the car?
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

jilewis843
New User
Posts: 5
Joined: Tue Mar 02, 2021 11:01 pm

Re: Stuck on “turn key to off position”

Post by jilewis843 »

Yes, everything is plugged in.

jilewis843
New User
Posts: 5
Joined: Tue Mar 02, 2021 11:01 pm

Re: Stuck on “turn key to off position”

Post by jilewis843 »

So I unhooked everything and redid it all. Now at least it beeps when I turn the car off. That’s new, but it’s still stuck on that screen, still flashes a red light twice and I don’t know where else to go.

Radio works without it hooked up as it should, so it’s got to be with communication somewhere.

jilewis843
New User
Posts: 5
Joined: Tue Mar 02, 2021 11:01 pm

Re: Stuck on “turn key to off position”

Post by jilewis843 »

Also, there was no pink wire from the radio for speed detection, do I need to run that wire to somewhere in the car or is it not need to operate? Other than that, the foot brake isn’t hooked up either. If those need to be run into spots in the car, I can find those and hook up if needed.

User avatar
Dara DeGrand
ADS Team
Posts: 7528
Joined: Mon Dec 02, 2013 1:34 pm

Re: Stuck on “turn key to off position”

Post by Dara DeGrand »

What you're reporting doesn't make sense. If you're getting 2 red blinks, that means the maestro isn't communicating with the radio. However, if you're getting the menus for platform selection, it shouldn't be flashing red.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

jilewis843
New User
Posts: 5
Joined: Tue Mar 02, 2021 11:01 pm

Re: Stuck on “turn key to off position”

Post by jilewis843 »

Once hooked up, it does flash red(twice) every few seconds. If I turn the ignition on, it pops up to start setup on the HU. Once I click start, it doesn’t detect a VIN and just says Mustang platform 1, click next and it says turn key to off position. I turn the key to the off position and at that point it does nothing. Radio stays on, beeps every few seconds, but doesn’t change. Screen slightly flickers(but only in setup) if that means anything, but that is exactly what happens. I’ve reset it, reflashed it, re-hooked everything up and it stays the same.
Last edited by jilewis843 on Wed Mar 03, 2021 12:46 pm, edited 1 time in total.

Chris LaRoche
Moderator
Posts: 436
Joined: Mon Oct 07, 2019 12:49 pm

Re: Stuck on “turn key to off position”

Post by Chris LaRoche »

What harness/version number are you using? There's a label on the harness itself. One side will have QC pass and a date, the other has the model and version number. What is that?

Also, what all is connected to the radio's red wire?
Chris LaRoche
Automotive Data Solutions
Technical Support - Maestro
MECP Master Installer

jilewis843
New User
Posts: 5
Joined: Tue Mar 02, 2021 11:01 pm

Re: Stuck on “turn key to off position”

Post by jilewis843 »

Ads-hrn(sr) FOR01 VER1.60
QC passed 2020/09/28

The red blinking stops once platform selection starts, it just stays stuck on turn key off. The red wire is hooked to the red wire on the harness and an aftermarket camera.

I disconnected the camera wires and it’s now moving forward, and platform selection is complete. Any suggestions on where to plug in the camera? It has a red and brown wire.
Last edited by jilewis843 on Thu Mar 04, 2021 11:47 am, edited 2 times in total.

jilewis843
New User
Posts: 5
Joined: Tue Mar 02, 2021 11:01 pm

Re: Stuck on “turn key to off position”

Post by jilewis843 »

I have unhooked anything that wasn’t part of the harness. Everything works except camera view(while not in reverse) it works fine in reverse. Had the backup camera installed by a shop, they ran those wires, camera has always only worked while in reverse, so I have no clue what those wires were for. 🤷🏼‍♂️

But everything is working now, gauges and all.

Chris LaRoche
Moderator
Posts: 436
Joined: Mon Oct 07, 2019 12:49 pm

Re: Stuck on “turn key to off position”

Post by Chris LaRoche »

Ah, it's possible that red wire in the cam was connected in the rear to reverse lights, causing the car to backfeed voltage and keeping the radio on. Either way, glad it's working!
Chris LaRoche
Automotive Data Solutions
Technical Support - Maestro
MECP Master Installer

Post Reply

Return to “Weblink Updater”