USB cable not detected

Find answers to common installation issues with the WebLink Updater.
Post Reply
111tomsk
New User
Posts: 7
Joined: Wed Mar 27, 2019 8:11 am

USB cable not detected

Post by 111tomsk »

Hi! Ordered device "MAESTRO SW-HD1". When I try to install the driver the message "the Current language is not supported by the device installation wizard"appears. I'm from Russia, I have Windows 10 Home, Russian language. What shall I do? How do I update my device? Since after connecting to the Harley-Davidson Electra Glide Ultra Classic 2005 and aftermarket CAR Audio JVC KD-X 35 MB S, the steering wheel control does not work, I think that you need to update MAESTRO SW-HD1, but in your account maestro.idatalink.com the system writes "USB cable not detected". Help, please!

billr
ADS Team
Posts: 674
Joined: Mon Feb 05, 2018 9:18 am

Re: USB cable not detected

Post by billr »

i'll send you an email with the files that should let you flash the SW.

billr
ADS Team
Posts: 674
Joined: Mon Feb 05, 2018 9:18 am

Re: USB cable not detected

Post by billr »

so the email got kicked back so use this link, go to step 4 and look for Manual Install Non-English computers for Windows 10.
https://rftech.custhelp.com/app/answers ... MjElMjE%3D

111tomsk
New User
Posts: 7
Joined: Wed Mar 27, 2019 8:11 am

Re: USB cable not detected

Post by 111tomsk »

Thank you! The drivers installed, the device can see the flash happened, but buttons does not match the one set up before flashing. The volume button is not readable at all (no plus, no minus, no pressing).

111tomsk
New User
Posts: 7
Joined: Wed Mar 27, 2019 8:11 am

Re: USB cable not detected

Post by 111tomsk »

Maybe it's the fact that following the Council (https://rftech.custhelp.com/app/answers ... MjElMjE%3D), I installed drivers from DSR 1 signal processor, instead of Maestro SW-HD1?

billr
ADS Team
Posts: 674
Joined: Mon Feb 05, 2018 9:18 am

Re: USB cable not detected

Post by billr »

the file folders are the same, we just have these files on the Rockford Fosgate website for the DSR1 but they are used in our Maestro RR and SW interfaces also.
Did you select the correct handlebar controls when you originally flashed the interface?

111tomsk
New User
Posts: 7
Joined: Wed Mar 27, 2019 8:11 am

Re: USB cable not detected

Post by 111tomsk »

Yes, I chose my type of control for the year and the model of the motorcycle. Just now I was able to change the language to Win 10 on my computer to English and I was able to install the drivers using the standard tool "SetupActiveX636.msi". But the volume button still doesn't work. This button worked on the old original radio. Maybe I should try different model years?

111tomsk
New User
Posts: 7
Joined: Wed Mar 27, 2019 8:11 am

Re: USB cable not detected

Post by 111tomsk »

Found a temporary way out of the situation. I set the volume control to the "SQ+" and "SQ-"buttons. Along the way, I found out that another button does not work with the adapter "Maestro SW-HD 1" - button to select the next track. I had to register " Seek+" in place of "mode sel.". Sorry for the translation, I use an online translator )) :D

billr
ADS Team
Posts: 674
Joined: Mon Feb 05, 2018 9:18 am

Re: USB cable not detected

Post by billr »

when you pushed the volume up or down button on the Harley, did the little light on the side of the SW blink at all? That would tell us if the SW saw the button being pushed or it didn't. It's possible that the Harley has some slight differences.

111tomsk
New User
Posts: 7
Joined: Wed Mar 27, 2019 8:11 am

Re: USB cable not detected

Post by 111tomsk »

When I press the volume, there is no blinking led.

billr
ADS Team
Posts: 674
Joined: Mon Feb 05, 2018 9:18 am

Re: USB cable not detected

Post by billr »

so that tells us we are not seeing the button being pushed either because the resistance is different than what we are looking for, that wire for that function is in a different location, or this may be something wrong with the little circuit board in heat shrink that came with the SW.

111tomsk
New User
Posts: 7
Joined: Wed Mar 27, 2019 8:11 am

Re: USB cable not detected

Post by 111tomsk »

With the original magnetic buttons all work, so the buttons are working. Maybe I got it wrong in the connection diagram? 3.5 3.5 mm I did not connect, but connected two wires: one with the radio, SW SW "steering wheel control cable".

billr
ADS Team
Posts: 674
Joined: Mon Feb 05, 2018 9:18 am

Re: USB cable not detected

Post by billr »

if the other buttons work with your radio then it's not a connection issue with your radio. Like I said before either because the resistance is different than what we are looking for, that wire for that function is in a different location, or this may be something wrong with the little circuit board in heat shrink that came with the SW.

vidyaman
New User
Posts: 1
Joined: Thu Sep 26, 2019 4:31 am
Contact:

Re: USB cable not detected

Post by vidyaman »

Thank you, helpful information.

Post Reply

Return to “Weblink Updater”